Sign in with
Sign up | Sign in
Your question

Ubuntu/Win7 Dual Boot Problem

Last response: in Linux/Free BSD
Share
March 8, 2011 3:40:40 PM

Hi Guys,

I have partitioned my hard drive and tried instally Ubuntu on my partition. I can run Memtests and Win7 fine after choosing them from the GRUB menu. However, when I try to boot Ubuntu I just get a blinking underscore in the top right hand corner.

Any help would be apprecitated.

Thanks Alot,
EdenC
March 8, 2011 3:48:34 PM

Oh, here is a picture of my partitions as in Computer Management:
March 8, 2011 5:39:06 PM

I guess first question would be, did the install complete without errors?

Assuming you're using the latest version of ubuntu, did you see the plymouth splash screen at all? It should be a pink/purple screen with the ubuntu logo on the middle


Since you said you can get into grub, you can also try booting ubuntu without the splash screen to make it spit out the error messages if any. on the grub selection screen, highlight ubuntu then press 'e'. This should allow you to edit the boot options. go the the longest line (3rd one I think) and delete everything from the word "splash" up until the end and type in "text" in the spot where you deleted all those text from. after editing the boot options press ctrl+x

(not 100% sure on this because I'm at work and don't have my ubuntu box to look at but once you're in the boot options editor you can probably figure out what I'm talking about)


then have a camera ready to snap a picture of the texts printed on the screen specially ones that look like errors or warnings
Related resources
March 9, 2011 1:48:57 PM

I pressed e when on the Linux choice and the following came up:

Quote:
GNU GRUB version 1.98+20100804-5ubuntu3

recordfail
insmod part_msdos
insmod exit2
set root= ' (hd0, msdos3) '
search --no-floppy-fs-uuid --set 6a3296ab-2020-41a5-b52a-c721104cf\
116
linux /bot/vminuz-2.6.35-22-generic-pae root=UUID=6a3296av-2020-41\
a5-b52a-c721104cf166 ro quiet splash
initrd /boot/initrd.img-2.6.35-22-generic pae


Exactly, which text will I need to delete and what should I put in its place?

Thanks Alot For Your Time And Help,
EdenC
March 9, 2011 2:00:44 PM

this line:

a5-b52a-c721104cf166 ro quiet splash



you wanna take out "splash" and replace it with "text"
March 11, 2011 10:08:42 PM

Sorry I couldn't get back at you sooner, picturepush.com was blocked at work :D 


anyways, they don't seem to be errors

are these the last set of messages before getting the blinking cursor screen?


also what hardware are you using?

March 12, 2011 9:33:20 AM

kitkat12012 said:
Sorry I couldn't get back at you sooner, picturepush.com was blocked at work :D 


Thats ok, will try to remember not to upload there again.



kitkat12012 said:
are these the last set of messages before getting the blinking cursor screen?


Theses are the messages that come up after changing splash to text. They stop where I've taken the photos and the blinking cursor now appears at the bottom of the screen.
The blinking cursor screen described in the OP was when I chose Linux from the GRUB menu with splash.[/quotemsg]


[/quotemsg]also what hardware are you using?[/quotemsg]

I built my own computer with the following hardware:

Asus Motherboard -> M4A88TD-M EVO
Processor -> AMD Phenom II X4 965 3.40 GHz
OCZ Stealth Stream Power Supply 2 [Power Supply]
Pioneer DVD-RW DVR-118L ATA [DVD Drive]
ATI Radeon HD 5600 Series [Graphics Card]
4GB of RAM

March 12, 2011 9:35:45 AM

^^^ Sorry for the mess up on the Quotemsg stuff in my previous post. I can't seem able to edit any of my own posts atm. ^^^
March 14, 2011 1:47:07 PM

Hardware looks plenty good for Ubuntu so that shouldn't be a problem

Does your mobo have a built in gpu? If so, can you try running Ubuntu on that and disconnect the 5600 just to rule out driver problems. Although your boot messages didn't hint on any gpu driver problems.


The boot printout you had before mostly has hdd stuff on it. Can you post your partition scheme copied from a "real" partition manager? The windows partition manager you posted before didn't have the complete info on partitions (eg it didn't have the filesystem type for your linux partition). You can probably grab a copy of your partition scheme using the Ubuntu livecd.


Another thing to look at is, also in the grub boot editor, try leaving the "quiet" keyword and just replacing "splash" with "text". I've read before that the quiet keyword suppresses/shows different messages. If the messages you get is entirely different than the ones you posted before, post them here too.

Another thing to check is if the OS files were copied correctly. Boot into your live cd, mount your hdd, and just browse through the contents and make sure the important looking folders have stuff in them.


Since I'm guessing this is your first install, you can also try repartitioning and reinstalling. It wouldn't hurt since you don't have data yet and it should only take about half an hour.


Finally when all else fails, try posting over at Ubuntu Forums. I bet you can find hundreds of experts there more knowledgeable than me :D 
March 19, 2011 3:06:54 PM

I tried to use the Linux Live CD, but that doesn't want to load either. I think I've got to the stage where I just want to either:

1 -> Unistall what is in my Linux Parition and reinstall it
OR
2-> Just have windows and forget Linux for now

However, I only want to go ahead with one of these stages if it will not delete my Windows partition, as I have quite a lot of stuff on there!

Thanks A Lot For All Your Help,
EdenC
March 20, 2011 10:08:08 AM

EdenC said:

insmod exit2


Is this a direct copy paste? Looks like "ext2" is misspelled. Though not sure why the ext2 filesystem would be used, I'd suppose ubuntu defaults to ext3 in installs since ext2 is kinda old and ext3/4 replaces it.

In the days before GRUB, a blinking underscore used to mean a messed up boot manager installation... if memory serves. Not sure if that helps any :wahoo: 

How did the LiveCD fail? That could be helpful information - maybe the Ubuntu defaults somehow aren't fit for your system and you need to boot with a different livecd/usb stick, install grub with correct configuration and then you can boot. In any case booting a linux and checking some things helps with troubleshooting. You can even just boot the ubuntu installer and take a shell, because obviously the installer was a working linux on your system. Or just try installing a different Linux distribution.

Neither of option 1) or 2) should touch your Windows partition, just reformat/reinstall on the partition you used for Linux. Provided you don't accidentally mess up. I'd make backups of your data on Windows before installing linux anyway, because of the possibility of human error...

But yes I'd take this to the Ubuntu forums, should be someone that can suggest a solution.
March 21, 2011 12:57:43 PM

just curious, how did you get it installed if the livecd fails?

did you make any major changes (hardware maybe?) after installation?
March 21, 2011 3:34:49 PM

Hi there, thanks for all your help, but I have now fixed the problem over at the Ubuntu forums:
!