Sign in with
Sign up | Sign in
Your question

I cannot boot from an external USB HDD. Can you?

Last response: in Motherboards
Share
May 17, 2007 2:41:48 PM

As the subject says, I'm trying to boot from an external hard drive which is attached via USB. I have a rev 3.3 Gigabyte GA-965P-DS3 with F11 BIOS that should support this, but it is not working for me. Worse, I'm not really sure where to start poking around for answers on how to get it to work. Anyone out there got any ideas?

Some additional background info:

I've tried booting with the BIOS setting for "Legacy USB storage detect" both enabled and disabled. No joy either way.

I have Linux Ubuntu 7.04 installed on the hard drive I'd like to boot from. I have had no problems booting from this drive when it is directly attached as an internal HDD. I also have no problems with my PC "seeing" the USB attached external drive when I have booted either Windows XP (my primary OS) or Linux Ubuntu 7.04 (booted from the Live DVD). (I actually did a "text mode" install of Linux to the drive while it was attached via USB).

I've tried Googling for info on this topic, but haven't found anything helpful so far. Most of the info out there seems to focus on booting from a USB "thumb" drive rather than from a USB attached hard drive. At this point I'm starting to wonder if this actually works for anyone at all out there. Perhaps it's not something other people actually do but rather just something everyone assumes can be done. :wink: :roll:

-john, the confused dinosaur

More about : boot external usb hdd

May 17, 2007 3:04:56 PM

Is the drive showing up in the bios? I think it should show up as a disk when choosing the hard drive boot order. I have booted from a USB flash drive on a rev 1.3 before. If I remember correct, it was detected and showed up as a boot option in the bios. I would think a USB hard drive would show up in a similar fashion. You probably need to have "Legacy USB storage detect Enabled".
May 17, 2007 3:31:13 PM

Quote:
Is the drive showing up in the bios?

No, it does not. My F11 BIOS boot options for the Gigabyte 965-DS3 work like this. I can select a first, second, and third boot device setting from the following list of devices: Floppy, LS120, Hard Disk, CDROM, ZIP, USB-FDD, USB-ZIP, USB-CDROM, USB-HDD, LAN, Disabled.

Currently my BIOS boot devices are set as follows:
First Boot Device: USB-HDD
Second Boot Device: Hard Disk
Third Boot Device: CDROM

There is another list of hard drive priorities available from another menu in the BIOS. This lists all the hard drives which are attached internally via SATA, PATA, or a PCI adapter card. However, USB attached hard drives do not show up in this list. In other words, this list only prioritizes the "Hard Disks" which are connected "internally".

If you specify booting from a USB-HDD and there are multiple USB-HDD attached, I would guess the BIOS is supposed to function the same way it does when booting from CDROM if I have multiple CDROMs with bootable CDs. But I really have no idea how it is supposed to work since at this point I cannot get it to work at all. :cry: 

-john, the confused dinosaur
Related resources
May 17, 2007 4:23:50 PM

Hmmm. I'm stumped. I'm fairly sure the usb flash drive showed up under the hard drive boot options for me. This was on a rev. 1.3 bios F10. However, I built this computer for a friend, so I no longer have it and and can't check. Try plugging in a usb flash drive and see if it shows up in the bios.
June 4, 2007 7:25:31 PM

Quote:
I'm fairly sure the usb flash drive showed up under the hard drive boot options for me. This was on a rev. 1.3 bios F10.

This is embarrassing, but you were right and I was wrong. I don't know why I stated in my OP that the USB attached hard drives do not show up in list displayed when you select "Hard Disk" as the boot option. I must have found this to be the case at least in some way when I made that post. But whatever I thought then, that is in fact how things seem to work.

When I press F12 and select "Hard Disk" as the boot source, the USB attached external hard drive now does appear in the selection list of hard disks that the BIOS displays. I have found that I can successfully boot Ubuntu from my external USB drive by selecting it as the boot source using this method.

Probably the most frustrating aspect of this experience was the complete lack of useful information from Gigabyte support. I received very prompt replies to all my posts about my problem to their support board. However, all of the replies contained stonewalling questions. Questions like "Was linux installed on the hdd from this system or was it from an different system?" and "The OS was loaded on this motherboard?" and finally "What kind of external hdd you are using or what kind of enclosure does it uses?"

I mentioned at least 3 or 4 times in our exchange that I had set the first boot device to USB-HDD but Gigabyte tech support never told me that this does not work. I strongly suspect that whoever was answering my questions actually knew less about booting from a USB device than I do. And that's both very sad and very lame and very, very disappointing.

While I suppose that's where this tale will end, I still have some questions.

The most obvious question is what on earth the BIOS option to boot from USB-HDD is supposed to do. It clearly does not work for me. I cannot boot from a USB attached hard drive by specifying USB-HDD as the boot source. :?

At one point I thought USB-HDD worked for me to boot from a USB Flash Drive. But I've tried that again and it also does not work. Instead the USB Flash Drive also shows up in the list displayed when I select boot from Hard Disk.

Another question is why I cannot select which USB device to boot from? If I have both a USB Flash Drive and a USB HDD attached, I can only boot from one of them no matter which one I select from the "priority list". I'm guessing that the BIOS just takes whichever USB device appears to be "first" in some internal USB device list. But why list all the USB devices in the hard drive priority list if you cannot actually select the specific USB HDD device you want to boot from? :?

-john, the confused clueless (essentially) dinosaur
June 6, 2007 7:00:47 AM

I think there are two issues at work here, the 1st of which is wether or not the USB thumb IS actually configured as a 'mass storage device'. That phrase is key to solving the prob as some thumbs are recognized as a flash drive... unsupported in bios, HOWEVER that is fixed with the new Vista thumbs.

I had this issue 9 months ago when for farts and giggles I tried to load a thumb drive onto W98se. DRIVERware is key. A particular 3-letter brand had awful driver code, and even left the name blank. (Problem big-time in W98se, as its 'null'). Once the ini was tweaked, the thumb loaded properly.

Of course, it died 60 days later as most of these particular brand of thumbs do. But it could image a 3.5Gb HDD of op-sys.

2nd is wether XP whatever will actually LET you do this... I would thoroughly investigate user/admin privilidges and restrixions. Might be a maze to get it to accept.

I do not recommend imaging anything absolutely essential onto a stick, thats why CD-R was invented.

JMH2c

f61
June 6, 2007 7:29:38 PM

Quote:
I think there are two issues at work here, the 1st of which is whether or not the USB thumb IS actually configured as a 'mass storage device'.

Not sure what you mean. The flash drive shows up in the WinXP device manager as a USB Mass Storage Device so I assume that is how it is configured. No?

As for using a flash drive with W98SE, that would have separate problems, wouldn't it, due to the much less robust support for USB in that OS. I know my Lexar Jumpdrive Pro requires the installation of a device driver for Win98SE to recognize it.

I haven't noticed any problems booting from the flash drive now that I finally realized I have to look for it under the Hard Disk boot source and not use USB-HDD as the boot source which was my more original naive expectation. But I still don't understand why the USB-HDD boot source does not work. It doesn't make any sense to me.

The lack of any real information about how the USB boot setups work is very frustrating.

-john, the irrational, confused dinosaur
Anonymous
a b V Motherboard
September 1, 2010 5:07:30 PM

zjohnr said:
Quote:
I don't know why I stated in my OP that the USB attached hard drives do not show up in list displayed when you select "Hard Disk" as the boot option. I must have found this to be the case at least in some way when I made that post. But whatever I thought then, that is in fact how things seem to work.

When I press F12 and select "Hard Disk" as the boot source, the USB attached external hard drive now does appear in the selection list of hard disks that the BIOS displays. I have found that I can successfully boot Ubuntu from my external USB drive by selecting it as the boot source using this method.

Quote:

Hi John
Please help me to understand (including when to press F12) how you got the USB to be recognized by BIOS since I have similar issue. Like yours, my old PC bios has boot option 1 to 3 listed and let's me choose different modes including different USBs but somehow after the "starting Up..." message there is no progress.!
a c 716 V Motherboard
September 1, 2010 5:26:56 PM

This is a 3-year old post... You'll get better responses with a NEW post.
Anonymous
a b V Motherboard
November 1, 2010 12:18:23 PM

my usb is detecting in bios.but not booting
February 9, 2011 2:02:53 AM

I know this is an old thread but it is the first result in Google for the term "Gigabyte USB Boot" so I'm posting this solution here. Like many I ran into this problem trying to boot to a USB flash drive on a new build with a Gigabyte 880GM-UD2H motherboard. However unlike a lot of folks out there I had access to several computers and several flash drives of various capacity from several manufactures for testing. SO After 5 hours of searching forums with no solution in sight :pt1cable:  I stumbled upon one untested suggestion on Gigabyte's forums and set to work testing it.

Background:

Drives:
Sandisk Cruzer Micro 4GB (X4)
Sandisk Cruzer Micro 2GB (X1)
Patriot 8GB (X10)

All of our Patriot sticks were initially set up with UBCD using a Linux Mint 10 HD install with UNetbootn (formated with Gparted). All failed to boot the system. :fou: 

Configuration attempts:

USB Legacy:D isabled/Enabled
USB Mass Storage: Disabled/Enabled
Boot Priority: 1st USB HDD
F12 boot menu USB HDD, USB CD ROM, USB FDD, +Hard Drive

No combination of BIOS settings or boot menu options would work. All attempts yielded the same "Starting Operating System...Boot Error" :heink:  message.

Several of the Sandisk Cruzer 4GB sticks had been configured as Windows 7 installation media using Windows 7 disk manager to format them to NTFS, and using the Microsoft USB/DVD download tool. These sticks booted perfectly from the F12 menu. :D 

The 2GB Sandisk Cruzer had been configured with DRBL using Linux Mint 10 HD install with UNetbootn (formated with Gparted). It also failed in the exact same way as the other sticks formated with Gparted.


Solution:
On a system running Windows 7 all sticks in question were formated using Disk Manager to either NTFS (for Windows boot media) or Fat32 (for Linux based boot media). After the sticks were formated, the ones that would be receiving Windows media (iso) were configured on Windows with the Microsoft USB/DVD download tool. The others were configured with Linux media on a Linux Mint 10 system with Unetbootn. The Linux sticks were NOT reformatted with gparted or any other Linux based tools.

After formating and configuring the sticks all were tested against two identical systems with the Gigabyte 880GM-UD2H, with optimized defaults set in the bios. From the F12 menu all drives appeared under the "+Hard Disk" section and booted the system as intended!!!!! :bounce: 



Conclusion:
Based on the testing I did tonight I'm fairly sure that the problem and the solution are one in the same. Award must be using a Microsoft provided MBR driver, or mounting system of some sort. So long as you work with in that system your fine (by formating your sticks using Windows). As soon as you step outside that box (with a new stick that was formated via a UNIX or Linux system) your screwed. As soon as Gigabyte sends me my account confirmation email I'll be posting this info to their forums as well. But in the mean time if you stumbled across this thread like I did, hopefully this saves you some time. Though this is an old thread if anyone else can confirm what I have here I would appreciate it.
June 22, 2011 8:01:39 PM

I had the sae situation. I had to go to the BIOS and went to the Hard Drives. There I could see my HDD and USB Flash drive with boot order 1 and 2. I changed the boot order as USB Flash Drive as 1 and my other HDD as 2. Don't mix it up with BIOS Boot Sequence but HDD->Boot Sequence. That fixed my issue and working great.

Fazlul Chowdhury

http://fazlulchowdhury.blogspot.com
a c 716 V Motherboard
June 22, 2011 8:12:53 PM

ONLY NATIVE USB PORTS ARE BOOTABLE :) 
October 1, 2011 8:10:30 PM

jaquith said:
ONLY NATIVE USB PORTS ARE BOOTABLE :) 

how do you know which ports are native?
October 9, 2011 2:49:42 AM

Assuming people already know exactly how to make bootable USB.

Problem: Usb HDD is in boot manager (F12) but still not booting..(Gigabyte Mobo)

Solution:
step 1- in the bios setup, change Hardisk Priority to your USB using Page UP/DOWN.
step 2- in the bios setup, change Boot Priority to USB HDD or you can choose from the Boot manager (F12)
November 26, 2011 1:12:42 PM

i found another good solution on this
http://www.patriks.tk/?p=64
it was very help full, i tried many times from other places at last i got this in hand and done...



zjohnr said:
Quote:
Is the drive showing up in the bios?

No, it does not. My F11 BIOS boot options for the Gigabyte 965-DS3 work like this. I can select a first, second, and third boot device setting from the following list of devices: Floppy, LS120, Hard Disk, CDROM, ZIP, USB-FDD, USB-ZIP, USB-CDROM, USB-HDD, LAN, Disabled.

Currently my BIOS boot devices are set as follows:
First Boot Device: USB-HDD
Second Boot Device: Hard Disk
Third Boot Device: CDROM

There is another list of hard drive priorities available from another menu in the BIOS. This lists all the hard drives which are attached internally via SATA, PATA, or a PCI adapter card. However, USB attached hard drives do not show up in this list. In other words, this list only prioritizes the "Hard Disks" which are connected "internally".

If you specify booting from a USB-HDD and there are multiple USB-HDD attached, I would guess the BIOS is supposed to function the same way it does when booting from CDROM if I have multiple CDROMs with bootable CDs. But I really have no idea how it is supposed to work since at this point I cannot get it to work at all. :cry: 

-john, the confused dinosaur

!