Sign in with
Sign up | Sign in
Your question
Closed

Start menu > All programs icons missing

Last response: in Windows XP
Share
June 18, 2008 10:14:19 PM

I dont know why but after I done a perfect clone of my harddrive using casper xp ..some of my icons in the windows start menu > all programs section have stopped showing. I check the actual folders for these programs and the icons are there but in the start menu > all programs there are not.

Is there a quick fix for this?

I've been searching the net for the last hour and found something about removing the shellcache file or something like that but I can't find it. I am showing hidden files also and have tweak xp installed.
June 21, 2008 2:13:02 PM

As a test, create a new account & try it out.
June 28, 2008 5:03:26 AM

I am also having the same problem. :(  Also I am missing my log off icon next to the turn off icon. I created another user account and that has the all programs and log off icon..... Any help would be much appreciated. I have been trying to find a solution to this problem for weeks now.... Not much out there....
Related resources
June 28, 2008 5:06:12 AM

HERE'S A SCREENSHOT.

June 28, 2008 12:36:07 PM

Try clicking Set Program access & defaults.

If no luck, you can either migrate the contents of the problematic account to the new working account or you can copy the icons to the new account.

C:\Documents and Settings\All Users\Start Menu\Programs\Start Menu\

or

C:\Documents and Settings\Default\Start Menu\Programs\Start Menu\

or

C:\Documents and Settings\Default User\Start Menu\Programs\Start Menu\

to your folder.
July 2, 2008 7:19:31 PM

I am still having trouble sorting this out. Program access and defaults dows not work.

Now for migrating the contents of the problematic account to the new working account, you mean move EVERYTHING from the user account that I use to the new one I created that has the all programs and log off buttons? Would I just copy paste the icons???? And can I delete the problematic account after?
July 3, 2008 12:26:38 PM

Just copy and paste your own files like bookmarks, favorites, etc. on C drive from the old user folder to the new one.

Do NOT delete the old account until 1 week later cuz you MIGHT have forgotten something and you'd be SOL if that's the case.
July 9, 2008 7:35:10 PM

hi .. just in case you haven't found the solution yet:

use regedit and browse to

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

make sure the value of "StartMenuLogoff" is set to 0

.. or ..
copy and paste the following into a reg-file (somename.reg) and doubleclick the file to insert the values into the registry

Quote:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"StartMenuLogoff"=dword:00000000


you have to logoff/logon for the changes to take effect (use taskmanager)
hope it works for you as it did for me :) 

btw: i tried to fix this with TweakUI, where you can enable/disable the option "Allow Logoff on Start menu" under "Explorer", but that didn't do the trick.

if other options/icons like "search" are missing from the start menu, just use TweakUI (thats a MS-Tool, google will lead you there)


regards,
blue
August 30, 2008 5:40:51 PM

Thanks Dude
Anonymous
April 6, 2010 12:23:37 AM

The resolution to this problem is the rebuilding of the Windows 7 Icon Cache.

Follow these directions:

1. Close all folder windows that are currently open.

2. Launch Task Manager using the CTRL+SHIFT+ESC key sequence, or by running taskmgr.exe

3. In the Process tab, right-click on the Explorer.exe process and select End Process

4. Click the End process button when asked for confirmation.

5. From the File menu of Task Manager, select New Task (Run…)

6. Type CMD.EXE, and click OK

7. In the Command Prompt window, type the commands one by one and press ENTER after each command:

CD /d %userprofile%\AppData\Local
DEL IconCache.db /a
EXIT

8. In Task Manager, click File, select New Task (Run…)

9. Type EXPLORER.EXE, and click OK.

Your icons should be as good as new!
July 23, 2011 9:45:33 PM

blueintheface said:
hi .. just in case you haven't found the solution yet:

use regedit and browse to

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

make sure the value of "StartMenuLogoff" is set to 0

.. or ..
copy and paste the following into a reg-file (somename.reg) and doubleclick the file to insert the values into the registry

Quote:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"StartMenuLogoff"=dword:00000000


you have to logoff/logon for the changes to take effect (use taskmanager)
hope it works for you as it did for me :) 

btw: i tried to fix this with TweakUI, where you can enable/disable the option "Allow Logoff on Start menu" under "Explorer", but that didn't do the trick.

if other options/icons like "search" are missing from the start menu, just use TweakUI (thats a MS-Tool, google will lead you there)


regards,
blue




thanx a lot,this really helped solve my problem
July 25, 2011 1:55:14 PM

This topic has been closed by Area51reopened
!