USB Problems /o\

The broken PC saga continues, but is hopefully close to reaching a happy ending. :-)

Ever since doing the second format of my PC last week some time the front USB ports haven't worked, which wasn't a massive drama (okay, it's still annoying though) until I just bought a Maxtor One Touch III external drive thingy that just doesn't seem to work at all.

I plug it into the front USB ports and obviously it does nothing, when I plug it into the back ports it fails to install but at least Windows recognises it (just has a yellow exclaimation mark and says device failed to start) and the lights on consistantly so I guess it's not a power problem.

So, my USB ports are well and truely screwed. I'd love to sort it, and I'd love to sort the front USB ports too if possible.

I've got an Asus a7n8x-e deluxe motherboard, afaik everything's setup correctly in the BIOS and I think the drivers installed correctly. I tried removing some of the USB devices from the device manager to try and re-install the drivers in case something was corrupt, in turn this just killed my mouse and keyboard and it wouldn't re-install when I rebooted the PC, yes, I'm dumb :-)

Any help in this matter would be ace, thanks!
24 answers Last reply
More about problems
  1. What OS are you running, and have you tried reinstalling it? Also when you reinstalled the USB drivers, was that for the devices themselfs or "The" USB drivers? When did you start having the problem with your USB in the first place?
  2. I'm running Windows XP, don't really fnacy the hassle of yet another format, especially since it may not fix it! :(

    I'm not sure about the drivers, I think they're the same as before, although on both occasions I just let Windows XP install what it wanted to ;o

    One other thing I should point out, is that when I leave this new Maxtor USB drive plugged in when I boot up the PC it freezes on the memory test at around 250mb~. As soon as I unplug the drive it shoots straight back up to the proper size and boots up as normal.
  3. It could be a bad controller on the mobo, in which case the mobo needs to be replaced, it could be compatibility between the devices connected to USB. It could be that windows has corrupted drivers, in which case windows will keep installing the bad drivers, unless they are replaced (I don't remember were to find the drivers and cabs windows uses, so I can't tell you how to replace them without a reinstall). It could be that the Mobo isn’t compatible with that external HDD, in which case the mobo may have a BIOS update for it, or you might never be able to use it on that mobo.

    P.S. also don't have anything plugged into the host controller that the external HD is connected too, or they'll conflict.
  4. Thanks again for your help. I don't think it's a problem with the board since it's only happened since a format, so I guess that'd rule out that the connectors aren't plugged in correctly too although I'll definitely check they're connected properly again. Sounds like you could be right about the Windows drivers, and in fact the ones I downloaded from the Asus website. I'm already running the latest firmware for the board unfortunately so I really hope that it's compatible! :( Final question, pardon the ignorance but what do you mean by the host controller? fwiw the only things I have plugged into the USB ports are my keyboard and mouse, should I try it without them?
  5. Any idea why this hard drive could cause my computer to crash when it's doing the memory test during boot up btw?
  6. For every two USB ports there is a host controller, basically it's what controls the flow of data. If you have a device on one port and plug something like a printer, modem, or an external hard drive (they are high bandwidth using devices), then the controller has to make a choice as to what will work, so that might be your problem. This could also cause the problem with the BIOS. I've had a few motherboards that would hang if I change the hard drive on the computer, because they are trying to detect them based off of what it knew form the last hard drive, so that could be what's happening with the BIOS. Some of the older BIOS's have a problem with detecting large USB drives too.

    BTW is the drive formatted?
  7. Huge thanks once again for the reply. Quick update: The front USB ports seem to be working fine, in fact every thing seems to be working fine apart from this Maxtor. It still isn't working correctly even with the two USB ports plugged in (I presume one for power, one for data) - the lights show up fine, it recognises it as a Maxtor OneTouch III when you first connect it but then it just brings up an error saying "This device cannot start. (Code 10)".

    It also makes a beeping sound almost every time I connect it, and when I tried booting it up with the drive connected it froze on the POST screen again and was making all sorts of beeping noises, I wonder whether maybe the drive is corrupt, I guess the best thing to do would be to is try it on another PC if I can. It'd help if I could grab the drivers from somewhere 'cos I've got a feeling it could be a driver issue.
  8. You only have to plug the drive into one port, just leave the other port next to the port, it is connected to, empty. Trying the drive on another computer is a good idea. This way you will know if the problem is with the drive or the computer. Code 10 is usually caused by the device not communicating with the pc, bad drivers, or a bad connection.
  9. Just plugged it into my parent's 5 year old PC downstairs and it works just fine, bah.

    :(
  10. *sigh* Try updating the drivers, for the device, to the newest you can find, after you connect it to your computer. Make sure you have just one usb cable going from the computer to the device, and that the port next to the port, it's connected to on the computer, has nothing in it. Check to make sure your mobo's bios is to the most resent version, if not then update it.
  11. Sorry to be a pain! :(

    I've tried updating the nForce drivers and the USB drives without any luck, I've also tried every single combination for the cables on this hard drive I can think of, and again I haven't had any luck. My BIOS is up to date too :(

    Tempted to get this PCI USB thingy - think that'd be a good idea?
  12. Sorry to post about this yet again, but I've just realised that I'm having what I think are USB problems when playing games too, for example I've tried TFC and Counter-Strike Source and quite often the input devices will lock and no matter what I press it'll just carry on doing what I was doing before, and then all of a sudden it'll do all of the commands I entered whilst it froze :/ Not sure if it's related, I guess it is, going to try removing every single driver related to the USB things in device manager and see how I get on, fingers crossed!
  13. The problem with the games sounds like a resource conflict, it could be you usb controllers are sharing an IRQ with another device. At this point it's either the OS or the Mobo. If you get one of those usb PCI cards and still doesn't work then it's an IRQ or OS problem, If it does then the USB on you computers mobo is going bad.
  14. Hmm cheers, is there anyway to check the IRQ conflicts before going ahead and getting a USB PCI card?
  15. Quote:
    Hmm cheers, is there anyway to check the IRQ conflicts before going ahead and getting a USB PCI card?


    Go to start->Programs->System Tools and open System Information. in there click on the Plus next to Hardware Resources and then select IRQs Scrole over so you can see status, and check to see if any of them say anything other then ok.
  16. Bugger, everything's listed as being okay, but then I guess on the plus side if I buy a PCI USB card that should work just fine, and I can plug both my mouse/keyboard and hard drive into it then? Huge thanks again for the replies and help, really appreciate it.

    Just one thing though, is there any reason why it would of worked fine before a format but then just start messing up? That's why I thought it was a software/driver issue you see, 'cos it was fine before I did a format :(
  17. it could still be the os, even with the IRQ's ok. The OS may not use the device properly, or might have the wrong drivers, that it insists on installing. If it's the Os the new card won't work, and you'll know it's the OS, if it does work, then it's the Mobo Controler.
  18. I see, thanks. I guess another format is in order then, out of interest would you recommend I just let Windows XP SP2 set up the USB things for me, or should I try and get the drivers seperately for the board (I've tried before but they didn't work) or should I just grab the latest nForce drivers right from the start? If it doesn't work after that then I guess I'll just buy the PCI USB thingy.
  19. install with sp2, and when you can get to the desktop and set up enough (and updated enough), grab the latest ones from the manufacturers web site. Hopefully that will eliminate any OS problems.
  20. Hmm, what a nightmare.

    I've fitted a USB 2.0 PCI card and not an awful lot has changed; the hard drive shows up in My Computer now at least and installs itself, but it's still incredibly unstable and keeps clicking/beeping every time I try to access something. Also, I tried running my mouse and keyboard through there and it's still lagging loads whilst playing any Steam game.

    The hard drive thing isn't going to be a massive problem, I'm just going to stick the PCI card in my parents PC, plug the hard drive in to there and just transfer the files I want to backup over the network, not an ideal solution but it's not going to bother me much either, so that's fine.

    The fact that Steam games are causing problems too (I assume it's a USB problem) is really going to bug me since I really enjoyed my recent game of TFC and there's a few Steam games coming out in the near future as wel. As certain as I am that it's a USB problem, it's odd that it only effects those games and other games I've briefly tried and Windows have ran just fine. I tried running my mouse through a USB -> PS2 adapter and it didn't work at all :(
  21. Have you reinstalled your OS?
  22. Nope, think it's all sorted now anyway though! The hard drive I guess is just due to my PC sucking and not giving it enough power, so I'll run it through my parents PC anyway, and regarding the input problems turns out it's not a USB error at all, I stopped the ATI services from running on my graphics card and it's just fine now! I think it was the ATI hot key service or something ;_;

    Huge thanks for your continued help and replies btw, really appreciate it!
  23. no worries
  24. Under your device manager , Do you have Enhanced Host Controller?

    You problem seam to be that the Maxtor is looking for USB 2.0 If the above device is not present you need to install it. Some older MB only have USB2.0 on a couple of ports. All the modern ones have it on all.

    Also make sure you BIOS has High Speed enabled.

    One other thing to check. Make sure you have the BIOS controlling the interupts. Most have a setting like Plug N Play OS. SET TO NO, this way the bios will read you hardware and XP will accept the settings. Causes a lot less problems.
Ask a new question

Read More

Motherboards USB