Sign in with
Sign up | Sign in
Your question

Help with Memory Problem on Gigabyte 965P-DS3

Tags:
  • Memory
  • Gigabyte
  • Product
Last response: in Memory
Share
May 18, 2007 3:32:11 AM

I just built my first computer. Now I'm having a problem setting the right timings with my memory. The stuff I got is Patriot extreme performance (This stuff)
The motherboard is Gigabyte 965P-DS3 revision 3.3 with F10 bios.

It's rated for 4-4-4-12 at 2.2V. It defaulted to 5-5-5-16 at 1.8V with no problems and windows installed fine. I ran memtest86+ for a few hours with no errors. I moved up the voltage to set the timings right. It only would post at 2.1 or 2.2 V. At 2.1V It ran for a while. With my overclock of my e6600 to 334x9, it survived 18.5 hours of orthos with no problems and a few hours of memtest86+. 2.1V wasn't completely working though. Windows would completely freeze sometimes and the system wouldn't post half the time, so I increased the voltage and assumed it was fine until I got a BSOD and ran memtest86+ again. I ran it a few times and I got a few hundred errors only on tests 6 and 7. I tried 2.3V and the system wouldn't post. I tried increasing the MCH and FSB voltages but got the same errors.

I tested each ram module individually. I tried each one alone in each slot on the motherboard, and had no errors at 2.2V. Whenever I had both sticks in, in either single or dual channel, I got the same errors in memtest86+ in tests 6 and 7.
Oh, and the memtest errors seem to come from 2 certain ranges, like ~480-520 MB and ~1480-1520MB.

The problem boils down to whenever I set the voltage of the memory to 2.2V with both modules installed I get errors even though its rated for it.

Are these defective modules or some motherboard compatibility problem or something?
Thanks for your help

More about : memory problem gigabyte 965p ds3

May 18, 2007 3:51:03 AM

1) So what speed are you running the memory bus at?
2) Do the problems with the RAM at 2.2V & 4-4-4-12 happen when the CPU is not OC'd?
3) Have you verified the running speed/timings of the RAM by using something like CPU-Z?
May 18, 2007 10:23:04 AM

I was running at the rated speed. I had the cpu overclocked to 334 FSB, so the memory was at 835 when I first had the problem. After that, I tested it all at stock speeds of 266 FSB and 800 for the ram, at 4-4-4-12, 2.2V.
Related resources
May 19, 2007 4:48:25 PM

Wow, I have this exact same problem! Or at least something very similar...in fact I just made a post about it.

I have the same motherboard, same memory, and I also get errors in memtest on test 7 in exclusively those memory ranges. You can read my post about it here:
http://forumz.tomshardware.com/hardware/DDR2-800-Stable...

It runs stable at 3:2 at stock speeds, but if I change the settings to 1:1 then I start getting the same errors you reported. I tried an OC to 333MHz at 1:1 and then it was not stable. It seems like it doesn't want to run at less than 800MHz. I did a quick check at running it at 2.5:2 at 333MHz (ram now at 833MHz), and the problem seemed to go away, although I didn't test it for very long. Although where at 533 I got at least 10 errors per pass in test 7, I got no errors after 3 passes at 833. I know its not long enough to declare it stable, but I'm impatient now and I will try to run it again overnight.


I put my vDIMM to 2.2V since the beginning and I haven't ever tried changing it, although it posted and ran fine at 1.8V.

Anyway ill let you know if I ever do find a solution to this. Make sure to post back here if you ever do fix it as well, thats interesting that our problems are so similar, down to the ranges of the memory that seem defective.
May 19, 2007 4:55:47 PM

Also out of curiosity, do all of your errors come from bit 0...00040? Every single error I have gotten in memtest says that bit as the faulty bit, regardless of the error location.
May 19, 2007 6:48:55 PM

All my errors were bit 00200000 I believe...it was definitely a 2, though not sure where in all the 0's. The addresses were all given in the ranges of ~480-520 MB and ~1480-1520. All errors were on tests 6 and 7, not just 7.

I'm getting more sure that it's an issue with the motherboard, although I'm not entirely sure what. My problem seems related only to the voltage. I might test it in a friend's computer just to be sure the memory's not defective. I was able to boot and run memtest and windows at 4-4-4-12 825 MHz at 2.1V. I even ran orthos 18.5 hours straight without issue. After that, I rebooted and the system wouldn't post and needed BIOS reset. I usually get 1 boot and those settings and after that it fails. No matter what speed or timings I set the errors came when I set 2.2V. I tried 533, 667, 800, and 1000 at 4-4-4-12 and with 5-5-5-16. I tried different FSB:Mem ratios and it only failed still at 2.2v set.

I checked the PC Health status section in the bios, and DDR18V Said Fail...no numbers given for the voltages. I started windows at 2.2V. The errors were so subtle, I ran at 2.2V for a few days before I got a bluescreen and started investigating.

I used speedfan and determined that the board was overvolting the memory. When I set the bios to 2.1V, Speedfan reads 2.1V, but at 2.2V set, it reads 2.32. I called gigabyte tech support but the guy wasn't all that helpful and I could barely understand him. I think he said something about memory not so stable at timings, even though figured out that only the voltage is the issue, and that patriot wasn't on the list of supported memory, and I should use a different brand. Anyway, I found some random post somewhere that issues on test 7 seem to be related to tRAS issues on newer intel chipsets. I relaxed the tRAS from 12 to 16 at 2.1V and now the system is stable with the memory at 800, 835, and 888 Mhz, maybe even higher though I haven't tried yet. I still get the same issues with those timings at 2.2 (actually 2.3V). tRAS doesn't really matter. It only makes ~1% difference as far as I know.
I'm happy with 4-4-4-16, and that solves it as far as I'm concerned. Though some of the reviews on newegg had people saying it ran at the right timings on this board...maybe it's a bios issue that wasn't there in older bios revisions, or maybe those people never ran memtest86.
May 19, 2007 6:51:24 PM

And another thing I forgot....I don't have the 2.2V issue with only one stick installed. Speedfan still reads 2.3V, but there are no issues in memtest86. Maybe there's a problem with the power needed for both at the higher voltage with the board?
May 19, 2007 7:22:27 PM

Yeah I seem to have the same thing on the vDIMM issue. My bios also says fail for the voltage for DDR18. I had ignored it in the past thinking that at 2.2V it was just out of spec for the board, I never thought that it might be a problem. I also see vCore2 at 2.32V in speedfan, I'm assuming that that is the vDIMM. I never paid much attention to speedfan as it doesn't really look like it is right at all for my board. It just gives bogus numbers like 2.8V for V12+ and -19V for V12-, -9V for V5-, etc... Those are just too wierd to be possible, given that the system is stable at stock cpu and a nice overclock on my 8800gts, with a solid corsair 620W psu.

I will try to go back to 2.1V or change the tRAS and see if that fixes any of my problems. Thanks for the info, seems like you did a good job investigating this. I would have ran more tests but I've just been having this problem now for 2-3 days or so and I just haven't had enough time to run long stability tests.
May 19, 2007 7:24:59 PM

May have spoken too soon. I did a restart from another successful memtest86+ test and got a failed boot. I reset the bios and set up my overclock/memory right again. I've been restarting from windows 5 times now and it hasn't happened again yet, so it might be ok.
May 19, 2007 8:58:34 PM

I've been testing it for a while now, restarting and full shutdown/turn on from windows and memtest86. It seems ok and restarts normally without failed boots at 4-4-4-16. I think I was trying 4-4-4-12 again when I failed to boot again. I also got an error in Orthos at 4-4-4-12. I'm pretty sure everything is set now, but I'll post back again if I have any more problems with this.
May 19, 2007 9:54:10 PM

Because of the motherboard you can't set it to the recommended voltage.
May 20, 2007 12:55:15 AM

Remember that the onboard voltage monitoring is not that accurate. If it is accurate to within 5% of the true value, you'd be lucky. 5% of 2.2V is 0.11V, so I certainly wouldn't believe any reported difference of that magnitude or smaller without verifying it with a real voltmeter.
May 20, 2007 2:22:02 PM

Quote:
Remember that the onboard voltage monitoring is not that accurate. If it is accurate to within 5% of the true value, you'd be lucky. 5% of 2.2V is 0.11V, so I certainly wouldn't believe any reported difference of that magnitude or smaller without verifying it with a real voltmeter.


While this may be true, the motherboard health screen in the BIOS reads FAIL in red for vDIMM when its set to 2.2 with these sticks, so that may give an indication that something is really wrong with this.
May 20, 2007 7:41:42 PM

The motherboard health screen is almost certainly using the same low-accuracy voltage readings, and so isn't an independent check on this. I'm not saying "don't worry", I'm just saying "verify the reading".
!