Sign in with
Sign up | Sign in
Your question
Solved

Fujitsu S series lifebook wifi on

Last response: in Linux/Free BSD
Share
June 30, 2011 7:12:58 AM

Hello, I am trying to connect to the internet using a Fujitsu S series Lifebook which is running Puppy Linux. I'm repeatedly getting messages that eth0 netork configuration is unsuccessful. I have the ipw2200 driver, so is it possible that there is a switch somewhere on the laptop that has manually turned wifi off? Or what?
June 30, 2011 2:10:01 PM

eth0 is your wired lan connection. Your wireless connection should be wlan0.
m
0
l
June 30, 2011 4:37:01 PM

Pyroflea said:
eth0 is your wired lan connection. Your wireless connection should be wlan0.


Ok. Well I was actually trying two different things. The first was to establish an Internet connection and the second was to connect to my other laptop with ssh. lspci shows eth0 being Realtek RTL-8139/8139C/8139+ (doing this from memory so I hope these numbers are right). I have loaded what seemed to be relevant modules....RTL8139c, RTL8139too, ipw2200, etc. For wlan it shows Broadcom device, and again I have loaded relevant modules.....b43, b43-legacy, etc.

?

m
0
l
Related resources
July 10, 2011 12:51:33 AM


Quote:
Hello ,

we noticed that your thread is not active anymore. Did you get the answer that you were seeking? We invite you to review the answers, and select the best one as your "Best Answer" (click on the gold cup above it).
Click here to review the answers to your question: http://www.tomshardware.com/forum//forum2.php?config=to...
Selecting a "Best Answer" will help the community to easily spot answers to similar issues or questions.
If you did not get the answer you were seeking, we suggest that you add details to your question. By doing so, you will get renewed attention to your issue.
Thank you for contributing the Tom's Hardware community
The Tom's Hardware community team


No, I didn't get an answer yet I have received this email repeatedly asking me to choose the best answer. There was one response and it was hardly an answer.

m
0
l

Best solution

July 16, 2011 9:59:51 PM

Ok, fishin' time :)  Grab yer waders

The RealTek is going to be your wired ethernet interface, so let's ignore that one for the time being

Can you output the listing for the Broadcom device from "lspci: (run as root or with "sudo" from a terminal)

I have to warn you that Broadcom has some spotty driver support in the kernel (or at least they did)

Some laptops have a physical switch to disable/enable the wifi and bluetooth radios, sometimes they have a so-called "software switch", read through the manual for the laptop and see where it discusses such functionality.

If it's a SW switch, you'll have to do a bit of research on how to interact with the switch (although if the driver is using the nice LinuxWireless initiative, you should be able to use
  1. rfkill --help
to get the info that you need
Share
July 17, 2011 4:43:50 AM

bmourning,


1) I found that none of the commands I tried from the rfkill man page yielded any results other than error messages.

2) Per your suggestion, I did a bit of digging and found the specs for this particular Fujitsu here.

3) As it turns out, there is some wacky little WLAN on/off switch in the BACK of the computer.



4) while toggling this switch DID enable wlan0 to be raised on one version of PuppyLinux I have on usb, it failed on another, leading me to believe that there is some wvdial configuration issue which is a separate problem, but solvable through the appropriate forum.

Anyway, it works, so thanks for the help.

:hello: 

m
0
l
July 17, 2011 4:44:27 AM

Best answer selected by Dennola4.
m
0
l
July 17, 2011 7:13:24 AM

Glad to be of service, although I'd be surprised if wvdial is causing an issue here since the toolset is usually used for PPP/dialup type connections, unless you're doing something kinda odd like a wireless connection to a PPPoE-type modem
m
0
l
July 17, 2011 3:43:32 PM

Ready to do some reading?? :-)

I have several different versions of Puppy on several different usb devices. Most of them are configured to automatically connect to the Internet using my PCMCIA card (Sprint Sierra Wireless Card). After having turned the Fujitsu external switch to the on position, the usb device containing Puppy 4.1.2 successfully raised wlan0 and connected to an open network while the two with LUPU did not. I ran the 4.3.1 live cd and it also successfully raised wlan0 and connected to an open network so I started thinking: maybe there was some /etc file associated with connection which was automatically configured for me as a result of some gui button-push, but my guesses (i.e. wvdial) are just ignorant shots in the dark since I don't fully understand the functionality of these programs.

This all started because my partner's macbook monitor died. While the computer is being fixed I thought I'd dust off of her old Fujitsu (which has a borked HDD) and run Puppy on it from usb. It runs fine but there was an Internet connectivity issue, hence this thread. Unfortunately the open local network we usually connect to provides a very weak signal on the old Fujitsu and is virtually unusable. I find that we can tether it to her mobile device (which becomes a hotspot) but encryption options for the older Puppies is Open and WEP, but not WPA/WPA2.

So to make my Linux-on-old-laptop solution a success, I either need to have her switch her mobile hotspot from WPA encryption to Open (Booooo!!!) or find a way to create an ad hoc network wherby she can connect to my laptop which runs SalixOS 13.1, stays on all day so I can access it remotely from work, and which she is NOT allowed to use. ;-)

Whew. Anyway, thanks again for the help.

m
0
l
!