Sign in with
Sign up | Sign in
Your question
Closed

file corruption after install vista64bit

Tags:
  • Partition
  • Windows Vista
Last response: in Windows Vista
Share
September 11, 2008 12:56:06 AM

Gigabyte ep45-ds3r mobo
intel q9550 cpu
8 gb mushkin ram
wd caviar 640 gb hd

this is a new build & i installed win xppro on the c primary partition but am having all kinds of problems with vista. I've tried it on a d primary partition, a g logical & last a g primary.

Currently attempting my 4th install of home premium 64bit & keep seeing corrupt files show up.

Symptoms I've seen are unable to save file to vista partition but success saving to any other partition; after booting to xppro it does a file check on the vista partition & finds problems & deletes lines of index files; unable to do the windows update; msg saying 'disk structure corrupt & unreadable' when trying to load certain driver cd's.

I'm suspecting bad install dvd, bad hard drive, mobo & video card driver incompatability. I also have the gigabyte hdd s.m.a.r.t. drive check thing enabled in the bios tho I think it was disabled for one of the bad installs.

Any ideas out there?

More about : file corruption install vista64bit

September 11, 2008 11:55:15 AM

On a working pc, get this to a disk:

http://www.memtest.org/#downiso

Boot it up on the problematic pc for 8 passes. If it errors out, reset pc, go to bios, load default, bump up ddr2 voltage by +0.1v up to +0.3v, rerun memtest.
September 11, 2008 6:33:34 PM

yes, it finally dawned on me it could be memory, that would explain why no probs in xp 32bit but data corrupt in vista 64bit.

i ran memtest v3.4 last nite, so far 3 passes, 11 hours, 0 errors.

i ran the vista repair option last nite & noticed it had a memory test. ran it but couldn't see results as it rebooted to a black screen after login.

this is a tough one. i'm thinking the sata conn or hard drive but the problems are only showing up in vista...so far.

i see memtest+ is a diff version. more up to date? i'll d/l & try that also. i'm still leaning towards memory as the culprit.

these probs are showing up after i d/l/install windows updates or mobo/video drivers. but maybe it's a time thing that has nothing to do with that.
Related resources
September 12, 2008 12:11:28 PM

Memtest86+ V2.01 (21/02/2008) is the latest unless they release a new one after my post.

Regardless, for over 4 gigs, Vista MUST be updated. There's one for over 4 gigs of ram. The name/kb# escapes me. Otherwise, Vista may run into problems.

Have you loaded bios default?
September 12, 2008 12:45:15 PM

If SP1 is installed, KB929777 is already on the computer. That solved an issue with certain types of memory controller preventing an install. If you don't have it, the workaround is to remove some DIMMS and drop installed RAM to 2GB or so. Then install, (local drivers before attaching to the network, please), and update Vista. Once you are done, you can go and put the RAM back.

For the memory, I recommend manually setting all timings. Manually set all voltages to the high side of the maker's recommended specs. Ensure the command rate is set to 2T. And check that tRFC ("Refresh to Activate Delay") is set to a value greater than 54. Normally, that'll do the trick as long as the modules are all good and you have a quality mobo.

You might need to bump the voltage to the FSB a notch or two - More than that and you can be sure the issue is elsewhere.


Regarding the disc: Ensure 'IDE Mode' is specified in the drive options. Then boot to a C prompt or use your favorite utility to zero write and reformat the partition you are attempting to install Vista to. I'm also VERY curious why XP would be screwing with the Vista partition. That shouldn't happen, ever. Do you have a separate hard drive?
September 13, 2008 6:38:12 PM

the vista install disk (home premium 64bit) sez includes sp1.

i'll check the timings/volts when I do my 5th! install later today.

i do see ide references when I boot, was surprised as everythings sata on this machine. i guess thats normal then.

been using acronis disk mgr 10 to partition/format. i was thinking of using win disk mgr from xp to see if that makes any diff.

i've seen the automatic chkdsk when rebooting to both xp & vista. either op system will say it sees problems on the vista partition & chkdsk & start deleting files. i've also seen it say something about the journal file being too big or something, it flashes by fast.

i do have 2 other hard drives on the machine. worth trying an install there? cant hurt i guess.

there is interaction going on. as stated in my other post, vista hoses the modem so i have to reseat it to get it to work in xp. modem works fine in vista though.

i also updated the bios on the gigabyte mobo yesterday from f5 to f8. hoping that might help. also downloaded all the vista 64 bit drivers for the mobo & video card & will try those.

edit-got into bios & changed timings from 5-5-5-18 to mushkin rec 4-4-4-12. the dram voltage was set to 1.8, mushkin rec is 2.0-2.1 so i set it to 2.0.

the cmd thing was set to 0 (auto) but when i booted to xp & ran cpu-z it said ir was 2t. no sure what that is or whatthe rec is for this memory.

there was also a bunch of weird stuff under advanced timing i didn't mess with-tRRD, tWTR, tWR,etc. also a 'dram termination' set to.900v.

i'll try another install of vista & see how it goes.
September 14, 2008 6:16:41 PM

problem appears solved. reinstalled last night after adjusting timing & voltages to specs rec by Mushkin & sucessfully installed drivers & 20 some updates.

9 passes with memtest+ last nite show 0 errors.

Mushkin rocks. posted the problem on their forum yesterday & the admin came back with detailed specs a 1/2 hour later.

thanks for the ideas/help.
!