Sign in with
Sign up | Sign in
Your question

Windows Media Center -- Choppy 1080i Video

Last response: in Apps General Discussion
Share
June 4, 2009 4:31:09 AM

Hello,

I’m getting choppy 1080i video in Vista Media Center. My computer is not a dedicated HTPC per se, but I sort of use it like one. I mainly use MC to watch and record OTA HD.

Here’s my setup:

C2D e4400 (2.0 GHz)
2 GB RAM
Vista Home Premium 32-bit
GeForce 7300gt
Hauppauge 1250 OTA HDTV tuner
21.5” 1080P LCD, DVI connection

The problem of choppy 1080i video started when I got my new monitor. My old monitor was a 17” CRT set to 1024x768. I never had any choppy video issues, which I’m guessing is because it scaled down the 1080i content. Now that I have a monitor with 1080 resolution, I’m getting problems with the 1080i stuff. I’m sure it’s just 1080i, because it’s only NBC and CBS that have the issue; ABC and FOX, which broadcast in 720p, play just fine.

Also, the problem is present whether I’m watching TV live or a recording.

A quick Google search reveals that I’m not the only one with the problem. I initially thought I needed a new video card, but now I’m not so sure. I understand that Microsoft recommends a video card with a memory bandwidth of at least 10gb/sec., and my 7300gt is pushing it at 10.7gb/sec. But I’ve read that even better cards (i.e., 8600gt) had the same stutter/choppiness issue. So I’m not convinced I need a newer card.

Another issue seems to be the Media Center codec. I haven’t experimented with any codecs at all, so I can’t comment on this. But I’ve read many examples where this didn’t solve the problem, either.

The good news is that I think I have found some kind of solution. If I open the Nvidia Control Panel > Adjust video image settings, my default is “Use video player setting” for both Edge enhancement and Noise reduction, and the Use inverse telecine box is unchecked. So I tried checking the box and moving the sliders over a bit to Use the NVIDIA setting. This actually made my 1080i video even worse. But get this—when I unchecked the box and went back to the “Use video player setting,” my 1080i played perfectly smooth!

I thought I had the problem solved, but after restarting the computer a few times since yesterday my choppy 1080i returned. So I did the rain dance again—I checked the inverse telecine box, applied the setting, then unchecked it and applied again. Smooth 1080i video again! I closed and re-opened MC and the video was still playing smoothly. I restarted my computer and 1080i was still smooth. I’m guessing after a few more restarts it’ll revert back, and I’ll have to do my quirky fix again.

What the heck is going on here? Any ideas for me? Thanks!

June 9, 2009 11:14:46 AM

If your new monitor is LCD, maybe I have an idea what's the probem.
If LCD monitor is connected to the Video Card through D-Sub cable interferences are possible especialy if resolution is set not to its "optimal". but in this case you should experience the same chopping int windows too.
but if you have set the resolution in windows to the optimal and your TV playback program resets the resoluton to some other at full screen (as games do) maybe this is the problem. But in this case you should not have the problem when you watch TV ta windowed mode.
Anyway if this is the problem there is one solution for it. connect the monitor through DVI-D cable if its possible, if your card doesen't have DVI connector you'll have ot change it.

Is that helps
!