Linux

Hello,
I would like to know how to enable 3D features on a Linux operating system. I have a Ubuntu desktop.
13 answers Last reply
More about linux
  1. jenbamvi said:
    ... I have a Ubuntu desktop.


    What version? Unless it's fairly old (pre 8.x, as I recall) it should already be there and you just need to configure it (on 10.10, it's under System->Preferences->CompizConfig Settings Manager)
  2. Oh yeah, forgot to ask: what video card? Usually Ubuntu will prompt you to install closed-source drivers anyway after the first login, but it's something to check whether or not you have an appropriate driver installed that supports AIGLX
  3. First check your CPU's capabilities
    for example, from http://ark.intel.com/products/54624

    Processor Graphics
    Intel® HD Graphics 3000
    Graphics Base Frequency
    350 MHz
    Graphics Max Dynamic Frequency
    950 MHz
    Graphics Output
    eDP/DP/HDMI/SDVO/CRTProcessor Graphics
    Intel® HD Graphics 3000
    Graphics Base Frequency
    350 MHz
    Graphics Max Dynamic Frequency
    950 MHz
    Graphics Output
    eDP/DP/HDMI/SDVO/CRT
    Intel® Quick Sync Video
    Yes
    Intel® InTru™ 3D Technology,
    Yes
  4. chamaecyparis said:
    ...
    Intel® InTru™ 3D Technology,
    Yes

    Ah, excellent point.

    jenbamvi, are you asking about "wobbly windows, desktop cube"-type 3d or "wearing a pair of glasses"-type 3d?
  5. It's difficult to know which of those alternatives is the less desirable.

    There's also the "using hardware acceleration to play games" option.
  6. bmouring said:
    Oh yeah, forgot to ask: what video card? Usually Ubuntu will prompt you to install closed-source drivers anyway after the first login, but it's something to check whether or not you have an appropriate driver installed that supports AIGLX

    I have Ubuntu 10.04
  7. bmouring said:
    Ah, excellent point.

    jenbamvi, are you asking about "wobbly windows, desktop cube"-type 3d or "wearing a pair of glasses"-type 3d?

    desktop cube
  8. I don't know which video card. If it helps, I will be installing Compiz in the system.
  9. So, it should already be installed (or you should have been prompted whether or not to install the closed-source drivers) already, also Compiz should already be installed, just pop open the configuration UI and play around with it (System -> Preferences -> CompizConfig Settings Manager)
  10. I tried that, but I wasn't able to see CompizConfig Settings Manager. I'll try to remove it and download it again.
  11. If you can't find it, just pop open a terminal and run "ccsm" (without quotes of course) and it will reveal itself. The cube is not enabled by default so you will need to use CCSM to enable it. You may be prompted to disable a conflicting plugin in the process.
  12. jenbamvi said:
    I have Ubuntu 10.04

    10.04, you say? Here's a guide I found covering that version (and 9.10 as well)
  13. randomizer said:
    If you can't find it, just pop open a terminal and run "ccsm" (without quotes of course) and it will reveal itself. The cube is not enabled by default so you will need to use CCSM to enable it. You may be prompted to disable a conflicting plugin in the process.

    Ok i'll try that. Thanks
Ask a new question

Read More

Linux Desktops 3D Ubuntu