Sign in with
Sign up | Sign in
Your question

Problem Networking XP Pro for file/printer sharing thru WRT54G Router

Last response: in Wireless Networking
Share
August 14, 2007 4:26:25 PM

Sigh...

This is ridiculous. I realize that most likely the problem, like most all of my problems, will end up being something simple that I simply overlooked but if anyone can help me then by all means PLEASE suggest something.

Anyhow my problem is this. Three computers are needed to be networked and all are running Windows XP Pro. The two laptops connects wirelessly behind a Linksys WRT54G Router, and the Desktop connects via an Ethernet cable from the router. First I tried the easy stuff:

1) Used Network Wizard and shut off all firewalls. I even uninstalled a couple.
2) Set all workgroups generically to MSHOME (I used DAS_CASA first but then reconfigured them to run under MSHOME thinking that a more generic name would work better).
3) Enabled simple file sharing on all PC's (tried without it too).
4) Picked different folders for file sharing. No go.
5) Tried to see if the Epson CX3800 printer was available on the network. No go.
6) Registry cleaned, virus scanned, etc. No go.

Basically after all that I could not see any of the computers in My Network Places. I click on My Network Places ==> MSHOME and then the explorer is blank with nothing in the network share. Oh, all computers were of course online and restarted after all this. Then I was sure to double check some setting in the group policy menu and turned off local password access so no password are required.

Then after that I tried to Manually set the workgroup name and file sharing settings. No go. I tried uninstalling and reinstalling TCP/IP. No go. When I ping the computers IP Addresses they show up in the CMD Prompt no problem but I still can't see them in My Network Places.

I tried the program Network Magic by Pure Networks and that worked flawlessly so I know the computers can see each other but why it does not display in my Network Places I don't know.

After reconfiguring one of the laptop PC's it should up in My Network Places and shared everything no problem but only to the other wireless laptop and not the wired desktop. However, the other wireless laptop and the wired desktop were still not showing up in My Network Places. Weird I know. Obviously the router I do not believe can be the cause since on PC is working fine, but what about the others? Is there something I missed under the Group Policy? A built in restriction? Anything? Help appreciated and thanks in advance.

-Fred
August 15, 2007 8:46:35 PM

Do you have the router security turned off?
August 15, 2007 9:15:01 PM

If by security you mean firewall then yes, it is off. The WEP encryption is enabled but that only applies to the Wi-Fi and MAC address filtering is off. Thanks.
Related resources
September 4, 2007 3:50:13 PM

[]Try reinstall all NET Frameworks
April 3, 2008 12:07:30 PM

I use the free program called Network Magic and it was able to add my printer to all my computers,and works fine try that. In the program it has a setup it can go through to add your printer to the whole network and share it
August 29, 2009 6:50:15 AM

Ok, I know this thread's been dead for a while, but it's right on queue for me. I have a home network which starts with a Linksys BEFSR41 gateway router. This is a 4 port hardwire unit. I tried replacing it with a Linksys WRT54G Wireless Router my son brought home. When I did, the laptop I was previously connecting through a subnet wireless lost it's ability to access network files and printers. Unless I'm missing something, this has nothing to do with how my computers are configured. Observably, it seems true, that my XP Pro laptop connected wirelessly to the WRT54G cannot use netbeui to access the workgroup whereas if the same laptop were wireless connected to a Netgear WG602v3 connected via various hubs to a BEFSR41 everything works just fine.

Some discussions I've seen on the web suggest that that WRT54G is suppressing client activity on netbeui ports, and that it can be configured to correct this. Other discussions suggest that the netbeui ports are terribly dangerous and that the last thing you would want to do is open those ports to the outside. Nevertheless, I've tried using port triggering to find a workaround to the problem but failed.

Just to clarify, I am not trying to use netbeui over TCP/IP. I don't trust it from a security point of view. And I still have some Win 98 computers on my network. So I install the old netbeui protocol in XP and disable netbeui over TCP/IP.

Any insights would be appreciated.

Murray E
!