Sign in with
Sign up | Sign in
Your question

sanskrit fonts not working in word

Last response: in Windows XP
Share
September 5, 2008 3:17:27 PM

I have downloaded and installed sanskrit 2003 truetype font in the fonts folder via control panel. The font appears in the drop down menu of word / excel. Unfortunately, when i use it the resulting font i see is an english font. when i tried to view the font with the windows font viewer, i had the same problem - english font is displayed. Can someone help me in this regard. thanks
May 7, 2009 11:29:59 AM

Hari Om!
Problem is that sanskrit2003 font actually includes 2 different "set of fonts"; you can see that by opening the .ttf file with fontforge or fontmatrix (under Linux).
So to use devanagari/sanskrit fonts you have to change the input language (keyboard language).

To do this:

Windows (Xp):
control panel --> regional and language options --> languages tab --> flag "Install files for complex script and right-to-left languages.
Give apply/ok and let Windows install files.

Then go back to the same tab and clic the "details" button: in the "Text services and input languages" dialog box (settings tab), clic on "add", choose and then set "sanskrit - devanagari - INSCRIPT" as the default input language.
In the same tab you better choose in the preferences --> "language bar" your preferences, so to show language bar switch in the application bar (you can also add this through right-clic on the application bar --> toolbars --> language bar).
Give ok on every dialog box.


Linux (under Debian Lenny/Gnome - other distros/DE should be more or less the same):
system --> preferences --> keyboard -- disposition (layouts) tab --> add hindi (or indian) layout and set as default.
Close everything


Page 108 of the itmanual2003 could be useful. You can find it here.


Remember to go back to your default input language, after using sanskrit2003 fonts! ;) 

Namastè! :) 
!