Sign in with
Sign up | Sign in
Your question

Phantom audio card took my sound away! Please help!

Last response: in Windows XP
Share
September 7, 2008 6:00:10 AM

I just formatted and clean installed Win XP Pro, installed all mainboard drivers and there's no sound.

I got a C-Media internal high definition audio card integrated on a Gygabyte 8 series mainboard.

In the device manager there are two instances of the audio card showing up. One recognized and working OK and another phantom one, as an unknown device with a driver not installed error code, listed at the same location as the working one.

This is really strange, I've clean installed the same windows, on the same computer, with the same mainboard drivers cd a few times before and it never did this.

What can be wrong?

I've tried uninstalling the phantom instance, manually pointing the location of the driver to it, using an updated version of the driver and nothing worked. Whenever I start up the windows the new hardware wizard pops up for this duplicate instance of the sound card. And with no sound, despite the windows showing sound available. I can even adjust the volume slider and all the other channel balance, recording volume, mic volume, etc. sliders, but there's no sound coming out.

Now, if the onboard card would have been dead, then it shouldn't have been recognized and stated as properly working in the device manager, right?

What can be causing this phantom, duplicate, unmanageable instance of the sound card to show up and kill my sound?

As I said, the HD is just formatted, the Windows is just installed and the mainboard drivers just installed as well. There's nothing else on this drive other than the windows and the mainboard drivers.
September 7, 2008 11:10:51 AM

chances are that both instances of the sound cards are trying to use the same resources, and since the one worked at boot time its not letting anything else step on its territory.

Delete both instances of the sound cards and reboot.
It should then find the sound card and allow you to install the drivers once and all should be ok.
September 7, 2008 11:14:12 AM

By deleting them you mean uninstalling them from the device manager ?
Related resources
September 7, 2008 12:04:05 PM

yes get rid of both and let the computer find it again and then give it the drivers
September 7, 2008 2:35:34 PM

Will try that.
September 7, 2008 6:53:23 PM

Also try downloading the latest drivers direct from C-Media... the drivers on the mobo manufacturer's website are rarely the latest ones available.
September 8, 2008 5:09:01 AM

Zoron said:
Also try downloading the latest drivers direct from C-Media... the drivers on the mobo manufacturer's website are rarely the latest ones available.


It worked before with those from the mobo disc.
September 8, 2008 2:01:42 PM

OK, I've tried to uninstall both instances of the sound card, restarted and ... nothing! The add wizards pops up for the phantom card and the real one appears as "working properly" at it's normal place. No sound at all.

The error message on the phantom instance is "device not configured correctly", but it won't update the driver, not even when I'm pointing it towards it.

I've looked into Bios and under "Integrated Peripherals" all I could find about audio devices were:
1. Azalia Codec section - set on Auto
and
2. Front Panel Type section set on HD Audio, with the other option being AC97. This thing is kinda useless since I'm using the rear panel for the audio jack connection. The front panel cables are unplugged from the mainboard.

Under "PnP devices" everything was on.

Other than that I couldn't find anything related to the audio part in there.
September 9, 2008 12:41:08 AM

I still suggest trying the drivers from their website... yes, I realize the drivers from the CD were working before, but perhaps something has changed between then and now. What is the name of the card that shows as working? You should have HD Audio codec in there somewhere.
September 9, 2008 5:12:48 AM

It only says C-Media High Definition Audio in the Device Manager. I've looked for the most recent driver on the Gigabyte (mainboard) site and it's the one I got.
September 9, 2008 9:25:09 AM

It's not the drivers dude!

It's a sound card integrated into the mainboard, I haven't changed neither the card nor the driver nor the windows version nor the Bios version since the last time it worked.
I'm not fussy about the performance of the current driver, so that I'd want to change the driver with the one that came out yesterday.
I got no sound at all.
I'm not into sound production or anything, I just want the dam thing to beep and click to start with, right now it doesn't make a single sound.
September 10, 2008 2:52:17 AM

Well if there isn't a driver installed for the other device, then quite obviously, it IS the driver. Either that or your onboard codec died and won't install a driver.

As I was typing this, another idea occurred to me... do you have the latest chipset drivers installed? Some of the HD audio codecs will NOT work without proper chipset driver support installed. You should have "High Definition Audio Controller" under your System devices... especially if you have an Intel chipset motherboard.
September 12, 2008 12:54:50 PM

I have the original "mobo" drivers auto installing cd plus I have newer drivers for my 'mobo' model from the main Gigabyte site.

The driver cd installs the 6.1.0.1008 Intel 915G chipset driver, I have also tested the 8.3.1.1009, wich doesn't change anything. I have the 9.0.0.1008 too, but I'm sure it isn't the chipset driver.
September 12, 2008 12:58:07 PM

It could be a dead, onboard codec though, but I can't verify that, can I ?
September 12, 2008 4:05:06 PM

Download the latest from Intel... the manufacturers always lag behind and almost never have the latest.
September 14, 2008 12:28:46 PM

OK, I've managed to fix it ... for now.

My fix (ultra-drastic indeed, but at least I got it to work again):

* I've changed the Bios/Integrated Peripherals/Front Panel Type setting from HD Audio to AC 97
* I've formatted all the HDD's
* Installed a new Windoze
* Installed the proper Microsoft UAA Bus driver for my mainboard model, first of all
* Then installed the C-Media Function driver for Intel 915 (in my case)
* Restarted and ... " :sweat:  ", I've got my sound back without any hardware wizard poping up at all. :bounce: 


Now, I've tried to reinstall the Windoze numerous times, but it just wouldn't work. The key here was (I think) formatting both my HDD's and then making sure the UAA Bus driver went on before anything else. I had to unplug my D hard disk first, then start the computer with the Windows cd in it, delete/create/format the partition and install the OS onto the C hard disk. Then, once the Windows was done installing, I plugged in the second hard disk and formatted that, using the XP built in formatting tool.

I don't know if all these steps were really necessary, but it was the only thing that worked in my case.

Why the sound went away like that in the first place, I have no idea. I know for sure that no one went into Bios and changed anything. As strange as it may sound, It must have been a combination of software and/or drivers that somehow corrupted the Windoze and/or magically changed that line in the Bios and caused all the sound to go down in flames.

Anyway, I'm glad and relieved that I got it going again and I think this thread can be marked as "Solved" or "Done" or something.

Thanks for all the replies and suggestions in it.
!