Sign in with
Sign up | Sign in
Your question

cannot copy some files on network

Last response: in Windows XP
Share
September 30, 2008 7:18:29 PM

I have an annoying problem that has been fighting me for some time.

I have 2 PCs networked with a D-Link wired router that is working well in all other respects. Both PCs are using Win XP Home SP3 (problem also existed previously with SP2)

When I attempt to copy some file types from some directories on computer A to computer B, I get the message "cannot copy filename make sure that disk is not write protected and that the file is not currently in use".

Neither disk is protected nor is the file in use.

Currently I am not able to copy EXE & PDF files although MP3, ZIP, JPG, GIF & DB files will copy. Interestingly, I can copy a PDF file from computer B to A and then copy it back to computer B! Also interestingly, I can copy these file types from other folders on computer A to B.

I have searched this and many other forums for an answer.
  • some posts have suggested changing permissions but this option is only available in XP Pro
  • some have suggested recreating the offending folder (on computer A) and deleting the old one. This works temporarily but the problem ultimately returns.
  • some have suggested ensuring the folder is shared (folder/properties/sharing/ click Share this folder...). The parent folder is shared and I have also clicked "Share this folder on the sub folder. Problem remains.

    Anyone have any insight for me?
  • More about : copy files network

    September 30, 2008 8:15:29 PM

    Did you check if problematic files can open properly ob the residing computer?

    I had a similar problem and it turned out that 60% of the files from that folder were corrupted.
    October 1, 2008 3:38:50 PM

    Yes. they open on computer A.

    By the way, I should have mentioned......
    When I have the problem, I'm working on computer B and trying to copy the files from computer A to B. If I go the Computer A, I can successfully copy the files from computer A to B. (but that sort of defeats the purpose of being able to get files from the other computer!)
    Related resources
    October 1, 2008 3:54:16 PM

    Ok. Well, I assume it is in a shared folder.

    Folder needs to have full share permissions set to everyone and proper NTFS permissions for the user (or group) who wants to copy its content.

    In this case to copy files from shared folder of computer's A to any other computer you need to have at least read permission for your user on computer's A shared folder (or if you are administrator of that computer, try to access the whole drive and navigate to the source files to check if problem still occurs).

    You can access whole drive by typing into my computer navigation bar: \\computerAname\c$ or whatever the drive letter is in your case.

    Keep in mind that if this is workgroup - you should have the same account set on both computers (the same username and password) to avoid additional problems.
    October 2, 2008 11:05:53 AM

    I am not sure that XP Home will allow for a machine to act as a server.

    You may need to switch one of the machines over to XP PRO.

    October 2, 2008 2:00:52 PM

    Yeah, I missed that "Home" part ;)  sorry.

    There might be some limitations on Home edition for sure.
    October 2, 2008 4:13:49 PM

    Thank-you 4everIT & ravenware for your replies.

    Yeah. I believe that the "XP Home" issue is a limitation. A while ago, I found many posts that spoke to the necessity of setting the folder permissions correctly. However the UI application to change these permissions only exists in XP Pro.

    Although I'm not really and expert, I am fairly PC literate. It seems to me that permissions are not the root cause of the problem. To elaborate further.....
    My file structure is built so that I have many sub-folders in the "My Documents" folder. "My Documents is set to be shared on the network. All child sub-folders automatically get this permission from the parent folder. While I haven't tested every sub-folder, I seem to be able to transfer all files between A & B computers from all other sub-folders. The problematic sub-folder is called "zTemp". I use this folder as a working folder (eg. unzipping files) and to accept downloads from everywhere (browsers, file sharing, etc). When it is intiially created (or recreated) it works perfectly. Therefore, I assume that initial permissions are set correctly. However, after a few weeks, something happens (????) that causes the failure to transfer some files. It is not always the same file types that I can't transfer. eg. currently, I can transfer ZIP files. However, in past failures, I have been unable to transfer ZIP files.

    Whenever, I get totally frustrated, I create a new sub-folder called "New Folder". Then I delete "zTemp", then rename "New Folder" to "zTemp". It works perfectly for a while but ultimately the problem returns.

    I should also mention...
    Both computers are set up with the same OS, same programs, same file structure and are used in a similar manner. However, the problem seems only to exist on one file sub-folder on computer A!

    Therefore, in my "semi-educated" opinion, there is something that is causing the permissions to change. I have searched & Googled my fingers to the bone and have not found anything that might cause the problem.

    Any other hints?
    October 2, 2008 5:14:04 PM

    There is one more thing you should know about NTFS permissions:

    Copying

    1. If you copy something within the same NTFS partition then copied items are inheriting sec. settings of the parent folder.

    2. If you copy something between different NTFS partitions then copied items are inheriting sec. settings of the parent folder as well.


    Moving:

    1. If you move something within the same NTFS partition then moved items do not inherit sec. settings of the parent folder.

    2. If you move something between different NTFS partitions then moved items are inheriting sec. settings of the parent folder.

    Check the settings on the files to make sure you have the right permissions set.

    I have no more ideas how to help you :-)
    October 2, 2008 6:12:40 PM

    Thanks again 4everIT,

    I believe that you are pointing me in the right direction - the file permissions seem to be the problem not the folder permissions.

    To test the hypothesis, here is what I did....
    -There is an EXE file in the zTemp directory on computer A that will not transfer to computer B.
    -There is another EXE file in a different directory (all it Y) on compter A that will transfer to computer B.
    -I copied the EXE file from directory "Y" to directory "zTemp" and it will transfer to computer B.

    Therefore I have one EXE file in zTemp directory on computer A that will transfer to computer B and another on that will not! I conclude that the problem is associated with the permissions associated with specific files.

    I looked at the properties of the files that will not transfer to computer B and they have a Security notice at the bottom of the Properties window that says "This file came from another computer and might be blocked to help protect this computer". There is a button beside this warning that says "Unblock". I clicked "Unblock" and the warning disappears but the file will still not transfer.

    Is there any other way to see/change the permissions on a specific file (Windows XP Home).
    October 2, 2008 6:35:21 PM

    Hmm, I wish I had Home edition on my Vmware - but I don't.
    As for the error message you have posted, this should be the solution for you for good:

    Go to start - run - type in gpedit.msc and hit enter

    Go to: User Configuration > Administrative Templates > Windows Components > Attachment Manager
    Enable: Do not preserve zone information in file attachments

    This tool may not be available on Home edition again, so check this out:
    http://www.tomshardware.com/forum/34581-45-gpedit-missi...

    Now check if you can copy files.
    October 3, 2008 4:31:08 PM

    Thanks again 4everIT,

    As you suggested, gpedit.msc is not available in XP Home.

    I looked at "http://www.tomshardware.com/forum/ [...] me-edition" and downloaded XP Security Console. However, I can't see any way that this program will allow me to change file or folder permissions.

    I did a Google search and found a program called "File Security Manager". It does give me the ability to change permissions. However, I'd really appreciate some guidance. Normally, I'd forge ahead and try it. However, the last time I tried to change permissions in the registry, I totally screwed up the computer and ended up reformatting and reinstalling everything. I'd rather not do that again. (I won't bore you further with that long and gory story)

    Here is what I'd try myself:
  • When I load "File Security Manager" and navigate to the "zTemp" sub-directory, I click on "Permissions" and I see 8 lines of permissions.
  • One line has the following info: Name-Everyone, Permission-Special, Inheritance-Not inherited, Apply to-This subfolder and files.
  • When I click "Edit" for this entry, there are 14 Permissions that can be set. 10 are set to "Allow" but "Full Control" is not set to "Allow".
  • I'd probably set the "Full Control" to "Allow"

    Does this sound correct or should I do something else?
    October 3, 2008 6:28:57 PM

    Try to force inheritance from parent folder (once you do that it should ask you to apply new permissions - confirm that) and test out.

    If that does not help - try to set FULL CONTROL to problematic file.

    You can't do any damage to that - it's just a permission that can be restored.
    October 4, 2008 8:37:24 PM

    OK. I'm completely confused. I've been thrashing around trying to change permissions and inheritance and somehow I've managed to fix computer A but I have no idea how I did it. I tried to make the permissions on Computer B match computer B but it didn't work.

    I've isolated the problem to be:
    A file that is downloaded to computer A can not be transferred to computer B using Windows Explorer at computer B. It can be transferred using Windows Explorer at computer A. I have exactly the same problem in reverse (A to B and B to A).

    Since I have Win XP Home, I used "a program called "File Security Manager" to change permissions.

    The permissions on the My Documents folder as well as all newly created sub folders look like the following:

    When I create a new sub-folder and download something into that sub-folder, I am able to transfer the file anywhere from anywhere. (just as I did to and from the original "zTemp" sub folder.

    However, after some period of time, I am no longer able to transfer files as stated above. When this happens, it appears that somehow and extra "non-inherited" permission for "Everyone" has been added. The folder permissions then look as follows:


    In attempting to fix the problem, I tried to remove the extra "non-inherited" permission for "Everyone" but I couldn't do this because the "Remove" button was greyed out. I removed the check from "Inherit from parent the permissions...." and confirmed. This duplicated most permissions but allowed me to remove the old permissions which I did. This didn't fix the problem but it did make the permissions exactly the same as the "My Documents" parent older as well as any newly created sub-folder.

    I continued to thrash around aimlessly on computer A trying different things and I finally solved the problem but I have no idea how this happened. I have been trying the same thing on computer B without success.

    Can anyone point me to specific instructions.
    October 5, 2008 4:58:52 PM

    Hey.

    First of all - there is a big mess in there.

    All permissions are set twice for each group in that zTemp folder.
    The least effective permission will be applied in this case - that is why you have problems.

    You need to remove all not needed permission on zTemp folder in the first place. To do that, uncheck the inheritance box and choose COPY when prompted for action. Once it copies permission - remove all the bad ones, like Builtin\Administrators - NONE etc

    Once you set all permission properly - check "replace permissions entries ..." and click apply - then confirm if prompted for action.

    This will fix your permission problem for good on that zTemp folder.
    October 6, 2008 4:29:26 PM

    Thanks again 4everit. You are a hero for sticking with me through this mess.

    Because I'm a coward, I tried what you said on a new sub-directory that I created just for the purpose of testing and it works. However, I'm concerned that my problem my be even bigger than the "zTemp" sub-directory.

    I also looked at the permissions for the root directory, other sub-directories as well as that of an external hard drive. Most of them have "not needed" permissions.

    Because of my screw up the last time I played with permissions in the registry, I'm hesitant to make wholesale changes without a little reassurance.

    Sorry for the space that this takes but here is a look at other permissions on my system:

    The root directory on the C: drive


    The Windows directory:


    The Documents & Settings directory:


    The external hard drive root directory"


    An external hard drive sub-directory:


    I also looked at similar directories on my other computer and I see a similar pattern.

    I have never previously directly modified the permissions on either computer (since my screw up and reinstallation).

    Do you think that I should go to the highest level directory with "not needed" permissions and delete them? (That's "sort of" what I did when I screwed up the registry on my last disaster.) Obviously something assigned these "not needed" permissions. Is there somewhere else that I should be looking to resolve the problem?
    October 6, 2008 5:16:53 PM

    I was going to tell you about your higher "root" folders - I figured they would be messed up too, since your zTemp was inheriting permission from it's parent as well (that is why I advised you to uncheck inheritance option on that folder in the first place). I didn't go further with that, since you didn't report any additional problems :-)

    Now, if you want to have the same level of access spanned through the whole drive - then I suggest you set those permission on your data drive letter and check "replace permission on child objects ... " - this will fix everything. You can't damage anything as long as you don't play with the C drive.

    If you mess up anything on your data drive - you can always fix it again. (I hope you keep data on other than c drive).

    If you keep your data on the C drive -> some folder - then stop inheritance on that highest folder (some folder), copy and set proper permission on it and apply them to child objects.

    That's it.

    btw. I don't know what could have done that mess. Just fix it and keep watching it.
    October 6, 2008 6:43:19 PM

    Thank you once again 4everIT,

    I've applied the permissions as you suggested to my "zTemp" folder and one other folder on both computers and everything seems to be working file.

    My data files are on the C: drive but backed up to my external drive. Because I'm a cautious soul after my last "permission screw-up", I'll monitor the "zTemp" folders for a while to see what happens.

    Thank you once again. You have been a real hero sticking with me on this thorny problem!!!!!!!!
    October 6, 2008 6:49:34 PM

    Good it works now.

    No problem - you're welcome.
    October 6, 2008 8:26:20 PM

    Looks like my celebration was a little premature!

    I just downloaded a file and incurred the original problem.

    The permissions on my "zTemp" folder now look as follows"
    Note: The "Everyone" permission originally applied to "This subfolder and files only". I changed it to "Subfolders and files" but it didn't help. I also tried "This folder only" and it didn't work either.


    The permissions on a downloaded file are:


    It seems that I can't transfer the downloaded file because it doesn't inherit the "Everyone - Full control" permission.

    I can put a check on the box beside "Inherit from parent the permission....." and it will add the permission for "Everyone" and the file will transfer. However, any downloaded file does not automatically inherit this permission.

    I can't see a way to force this inheritance.

    Can you help this idiot (me) once again?

    October 6, 2008 8:35:22 PM

    Ok.

    Do the test.
    Try not to download anything from the internet.
    Simply put file in zTemp folder from other location of your computer (make sure you copy not move the file).

    If the file inherited permission from zTemp folder - then everything works fine and you are ok. That also means you need to adjust other problem you had before:

    "This file came from another computer and might be blocked to help protect this computer"

    Let me know - if you still see that message on internet-downloaded file when you view properties of it.
    If you do - I bet you have used internet explorer to download the file :-)

    Try to download the file using other "downloader" or Firefox and save it to the zTemp folder - now tell me if it works.
    October 6, 2008 8:54:34 PM

    Thanks once again 4everIT,

    I moved a file from another location on the computer and ended up with only one permission - "Everyone - Full Control" and I was able to transfer it to the other computer. Therefore, it looks like that is working correctly.

    I then downloaded another file (using my default browser - Firefox) from the net it had the following permissions:


    I looked at the properties of this file and it had the warning "This file came from another computer and might be blocked to help protect this computer" . I unblocked the file and the warning message disappeared but I am still unable to transfer the file to the other computer. The only way that I am able to transfer this files is to add the "Everyone-Full Control" permission.

    I then downloaded another file using IE6 and the downloaded file inherited the correct "Everyone - Full Control" permission.

    Is it possible that a downloaded file is inheriting it's permissions from the browser rather than the parent destination folder? If so, how do I fix this?
    October 6, 2008 9:24:10 PM

    1 - I told you to copy not to move the file. There should not be "everyone permission" only on the copied file. Copied file should inherit permission from it's parent folder (destination folder). If your parent folder had "everyone" only permission set - then it is ok. If not, then try to copy, not to move the file since moving file between different NTFS partitions keeps the file original permission, it does not inherit permission of the destination folder.

    2. Which firefox are you using (I knew about explorer causing the problem, not firefox). What happens is: some security permission in your browser prevent regular user from opening a file from unknown sources (sec. permission everyone is removed) once you unblock it and add permission - it is obvious you will be able to work with that file.

    If that is really a firefox problem only (and it appears it is) then you need to go through your firefox settings one by one and try to find that setting. The easiest way would be to just use some kind of "downloader" like "Get right" instead.

    3. How do you exactly download the file? Do you point to a path of your choice? Or do you just save it in firefox default destination and then move it to zTemp folder?

    If none of the above help then try to read here:
    http://groups.google.pl/group/mozilla.support.firefox/b...

    and google little bit since this is not permission problem anymore. It is a security problem on downloaded file from unknown source (internet) and as you see it affects firefox in your case.

    Good luck.
    October 6, 2008 9:37:49 PM

    Sorry, I mis-typed. I did copy the file. The only permission on the "zTemp" folder that is set to be inherited by the files is "Everyone" (image a few messages up). The copied file did inherit that permission.

    I'm using Firefox 3.0.3.

    I have Firefox set up to download files directly to the default directory ("ZTemp" folder). If after downloading to the "zTemp" directory, I move the file to another folder, it takes on the permissions of the new folder and will transfer on the network.

    I have gone through all the Firefox settings and I can't find anything that refers to download file permissions.
    October 6, 2008 9:44:19 PM

    Ok. No problem - so you have solved your permission problem, now it is just this "thing " with FF.

    Well, this setting is available in XP Professional (as I mentioned couple posts before) and it would solve this issue.

    In case of Home edition - there is no policy editor (since Home cannot be joined to a domain).
    You probably could fix that in registry - but I really don't want you to mess with the registry with your level of experience.

    You have 2 options left:

    1. User IE
    2. Use external downloader that will download your files no matter if you use IE or FF

    October 6, 2008 10:43:05 PM

    OK. I've said it a few times before but thank-you again.

    You have led me to the source of the problem. I have already done some Googling on the Firefox/download/permission issue and I see that others have also had the problem but none of those posts have included a solution.

    I'll continue to Google and look at the Mozilla forums as well as try a separate downloader.

    If and when I find a solution, I'll post the results back here.

    Thanks again - you are a STAR!!!!!
    October 16, 2008 6:15:54 PM

    To wrap up this thread.......

    I've searched many forums and found many posts that indicate that others are having the same problem but no one has posted a solution.

    I've asked for help in this and a couple of other forums and did not receive any solution.

    Therefore, I've given up and implemented a work around. It's a bit of a nuisance but is certainly workable.

    I've created a new sub directory called "zDownload". Everything that is downloaded using Firefox is downloaded into this directory. (with missing permissions). Then I simply move the file to my "zTemp" directory where it inherits the correct permissions. Now I can access the file from my network.

    It "ain't" pretty but it works! It's just frustrating that I can't find what is causing to original problem! I hate to leave a problem unresolved!!!!!!!!!!!!
    October 25, 2008 12:34:01 AM

    I too tripped on this and found your discussion helpful.

    One added note: it is possible to get a security tab in XP Home by booting into Safe Mode (F8). From there you can modify permissions as you would in XP Pro and you don't have to install anything (potentially harmful). For more details see: http://support.microsoft.com/kb/308421

    If you simply want to copy a file or two, select the file, go to Properties->Secuity->Advanced, delete all the permissions that are there, and add one that says "Everyone, Full Control". The file can then be copied normally.
    October 26, 2008 6:53:22 PM

    One suggestion I have is to enable the Guest account and see if that works...
    February 1, 2014 8:32:51 AM

    I seem to suddenly have had this problem arise with files in a subfolder of Shared Documents on XP Pro. I haven't yet confirmed if it applies to all file types downloaded from the Internet (or whether from anywhere else on my network) or what has suddenly caused this to start happening.
    Essentially the files are not inheriting the 'Everyone' or 'Power User' permissions from the parent folder.

    However I would NOT recommend the solution suggested by jimpgh as adding Full Control to 'Everyone' could be very dangerous and insecure.
    Clicking on the Security tab, then Advanced, then Add and adding 'Everyone' with all permissions EXCEPT Full Control, Change Permissions & Take Ownership, should be quite adequate for a quick fix on an individual file basis.

    The Shared Documents folder currently has a mixture of <not inherited> and inherited from C:\Documents and Settings\All Users\ permissions
    Sub-folders have a mixture of inherited permissions from both C:\Documents and Settings\All Users\Documents and C:\Documents and Settings\All Users\
    I need to check exactly what the default permissions should be to see if they've changed.

    I'll post an update when I discover a bit more.
    !