Solved

A strange problem relating to a SUSE Studio build

I've got a strange problem with a SUSE Studio build I've done. It has downloaded and burned to DVD correctly. When I boot to it (live DVD with installer) on the hardware, it will error out when launching Firefox or any parts of YaST (not things like the Virtual Machine manager which are separate). When I boot it in VirtualBox (from the DVD, not the ISO), it works perfectly. I haven't seen any other problems with it on the hardware other than the ones mentioned above. Anyone got any ideas? Thanks.
4 answers Last reply Best Answer
More about strange problem relating suse studio build
  1. This is the error message produced by YaST:
    [cpp]sbin/yast2: line 423: 5057 Illegal instruction $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS[/cpp]

    And Firefox produces this when run from the terminal:
    [cpp] Xlib: extension "GLX" missing on display ":0".
    *** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to enable).[/cpp]
  2. Best answer
    I wonder if "Illegal instruction" refers to something to do with memory or the kernel?

    It's very strange indeed.
  3. Well, your comment gave me an idea I should have thought of before: Google the error. It seems that the YaST problem is a problem with Xen on Sandy Bridge processors: http://forums.opensuse.org/english/get-technical-help-here/applications/455995-yast2-not-working-clean-minimal-server-config-xen.html, https://bugzilla.novell.com/show_bug.cgi?id=715980
  4. Best answer selected by PreferLinux.
Ask a new question

Read More

DVD Studio Build