Sign in with
Sign up | Sign in
Your question

Linux share no access from windows 7

Last response: in Linux/Free BSD
Share
November 3, 2011 4:01:22 PM

I have a suse linux box Just set up
Smb is installed and as the purpose of this box is to be a file and web server have set up smb that came in the Package

I shared 2 drives, but access is refused and a box for changing users pops up.
There is no domain controller, but the server name is added to user name ie: nat\username
Retrying without the prefix result in the local machine name being added
Work group is selectd in smb, however that was done after I got the error.
What have I set up wrong?
Thanks
a b 5 Linux
November 4, 2011 12:53:48 AM

You do have a domain controller, it's the SUSE box. While it's not a true domain it will be the browser master and in terms of just sharing files do much the same thing, you have to authenticate against accounts held on the SUSE box.

The correct format for share names in UNC would be \\$SUSE_MACHINE_NAME\$Share_name - just like Windows uses. When connecting to the share the user name would have to be one that has an account on the SUSE box, then it would be \\$SUSE_MACHINE_NAME\$User_Name_on_SUSE

On the Windows PC make sure the workgroup is set to be the same as the one the SUSE box is using.
m
0
l
November 4, 2011 3:48:00 AM

audiovoodoo said:
You do have a domain controller, it's the SUSE box. While it's not a true domain it will be the browser master and in terms of just sharing files do much the same thing, you have to authenticate against accounts held on the SUSE box.

The correct format for share names in UNC would be \\$SUSE_MACHINE_NAME\$Share_name - just like Windows uses. When connecting to the share the user name would have to be one that has an account on the SUSE box, then it would be \\$SUSE_MACHINE_NAME\$User_Name_on_SUSE

On the Windows PC make sure the workgroup is set to be the same as the one the SUSE box is using.


All usernames and password are the same on all 4 machines.

2 win7 1 vista, 1 xp all can access each other's shares, but none can access the suse

Thanks
m
0
l
Related resources
a b $ Windows 7
a b 5 Linux
November 4, 2011 6:43:55 AM

You say all usernames and passwords are the same on all 4 machines, but then you talk about 2win 7, 1 vista, and 1 XP. Along with the SuSE machine that's 5 machines, not 4. So does the SuSE machine also have user accounts with the same names and passwords as the Windows ones?

@audiovoodoo - I'm not sure that the OP does have a DC. It sounds to me as if he is relying upon authentication using local accounts on the SuSE box. In Windows terms it's a Workgroup, not a domain, so there need to be individual accounts on all computers.
m
0
l
a b 5 Linux
November 4, 2011 12:00:09 PM

You're correct. It was a little late last night when I posted that :sleep:  I can only assume my mind was thinking about browse master.

It shouldn't matter if the names are the same on any of the machines, the issue is that when you connect you must specify a user name and password that is valid on the suse system

Quote:
NET USE
[devicename | *] [\\computername\sharename[\volume] [password | *]]
[/USER:[domainname\]username]
[/USER:[dotted domain name\]username]
[/USER:[username@dotted domain name]
[/SMARTCARD]
[/SAVECRED]
[[/DELETE] | [/PERSISTENT:{YES | NO}]]

NET USE {devicename | *} [password | *] /HOME

NET USE [/PERSISTENT:{YES | NO}]


I would suggest trying from the command line and specifying the user explicitly.

Quote:
net use x: \\$suse_box\share /user:$suse_box\$suse_user


Don't enter the password as it will prompt you anyway. I'm in a bit of a rush atm but there is also a need to have that suse user added to the correct user groups. I'll have a dig later and check on that. A way to test this would be a global share with no security, just an empty directory read only would do for testing.
m
0
l
a b $ Windows 7
a b 5 Linux
November 4, 2011 3:59:35 PM

Same username and password makes life easier but, as you say, not essential.
m
0
l
November 11, 2011 1:42:44 PM

Ijack said:
Same username and password makes life easier but, as you say, not essential.


Whether Windows or command line procedures are used, Access is denied.

I appreciate yor help

Len
m
0
l
a b $ Windows 7
a b 5 Linux
November 11, 2011 2:38:45 PM

I'm still not clear whether you have created the same accounts on the SuSE machine. Can you confirm that you have created these accounts?
m
0
l
November 13, 2011 1:05:53 AM

I recently had issues doing this in Kubuntu, and I had to make the following changes from the default settings in smb.conf:

* Use LMv2 authentication, required by Windows 7.
* Use a valid password database type, the default was gibberish and nothing could authenticate.
* Set up Samba users to match the OS users, despite turning on the option to use system accounts.

Once I did this, everything just started working flawlessly.
m
0
l
!