[UBUNTU] Connect internet via mobile as modem through data cable

Hi,

I'm having a real hard time connecting net in ubuntu ( using my mobile's net as a dial-up conn.) though data cable. I've a Nokia 5233 in case some of you may be wondering.

I'm using the traditional 'wvdial' method as don't know about other ( if they exist even)...

I used a blog for reference on setting up net in ubuntu. Here-- http://www.abttech.com/connecting-internet-in-ubuntu-using-mobile-as-modem-via-bluetooth-or-datacable/ (feel free to remove the link if it breaks any rule)

So, here wo go, my wvdial.conf file:

[cpp][Modem0]
Modem = /dev/rfcomm0
Baud = 230400
SetVolume = 0
DialCommand = ATDT
FlowControl = Hardware(CRTSCTS)

[Modem1]
Modem = /dev/ttyACM0
Baud = 460800
SetVolume = 0
DialCommand = ATDT
FlowControl = Hardware(CRTSCTS)

[Dialer GPRS]
Username = 1
Password = 1
Phone = *99#
Mode = 1
Inherits = Modem0

[Dialer DATA]
Username = A
Password = B
Phone = *99#
Mode = 1
Inherits = Modem1

[Dialer Defaults]
Modem = /dev/ttyACM0
Baud = 460800
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+CGDCONT=1,"IP","airtelgprs.com"
ISDN = 0
Modem Type = Analog Modem
Area Code =
Phone = *99#
Username =
Password =
Ask Password = 0
Dial Command = ATDT
Stupid Mode = 1
Compuserve = 0
Force Address =
Idle Seconds = 1600
DialMessage1 =
DialMessage2 =
ISDN = 0
Auto DNS = 1[/cpp]

And when i run the command sudo wvdial DATA, following output appears:
[cpp]
sudo wvdial DATA
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,"IP","airtelgprs.com"
AT+CGDCONT=1,"IP","airtelgprs.com"
OK
--> Modem initialized.
--> Idle Seconds = 1600, disabling automatic reconnect.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
CONNECT
~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Sat Nov 26 01:19:14 2011
--> Pid of pppd: 9685
--> Using interface ppp0
--> pppd: ؗ[10][08]
--> pppd: ؗ[10][08]
--> pppd: ؗ[10][08]
--> pppd: ؗ[10][08]
--> pppd: ؗ[10][08]
--> Disconnecting at Sat Nov 26 01:19:14 2011
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.[/cpp]


As you can see this PPP daemon error ( code 16 ) is killing me.. How to solve it? Pls help me guys...

PS: Running Ubuntu 10.10
PPS: I can connect to net via Bluetooth quite fine. I just paired up the phone and ubuntu asked if I'd like to use it as a modem to access net and within seconds i was up and running BUT I just don't know what the damn problem is there is data cable?

Thanks
4 answers Last reply
More about ubuntu connect internet mobile modem data cable
  1. Perhaps try the solution mentioned in this post, also see if there are any other guides to setup a data connection for your carrier, specifically APN, PPP settings, number, etc. Additionally, you may want to try to configure it through NetworkManager (have done both manual wvdial and NM setup for my BT and USB connection for my N900)
  2. Thanks but stupid mode= 1 is there in my wvdial.conf but it still doesn't work.
  3. I would suggest attempting to set it up through NetworkManager, when plugged in and configured to connect in "data" mode (or whatever your phone calls it), it should appear in the available-to-configure connections
  4. my nokia is working fine with Linux using data cable, i explained the code at my post on http://screwdesk.com/configure-dial-up-device-on-linux/ ,may it help..
Ask a new question

Read More

Mobile Modem Dial Up Connection