Sign in with
Sign up | Sign in
Your question

[UBUNTU] Connect internet via mobile as modem through data cable

Last response: in Linux/Free BSD
Share
November 25, 2011 5:58:11 PM

Hi,

I'm having a real hard time connecting net in ubuntu ( using my mobile's net as a dial-up conn.) though data cable. I've a Nokia 5233 in case some of you may be wondering.

I'm using the traditional 'wvdial' method as don't know about other ( if they exist even)...

I used a blog for reference on setting up net in ubuntu. Here-- http://www.abttech.com/connecting-internet-in-ubuntu-us... (feel free to remove the link if it breaks any rule)

So, here wo go, my wvdial.conf file:

  1. [Modem0]
  2. Modem = /dev/rfcomm0
  3. Baud = 230400
  4. SetVolume = 0
  5. DialCommand = ATDT
  6. FlowControl = Hardware(CRTSCTS)
  7.  
  8. [Modem1]
  9. Modem = /dev/ttyACM0
  10. Baud = 460800
  11. SetVolume = 0
  12. DialCommand = ATDT
  13. FlowControl = Hardware(CRTSCTS)
  14.  
  15. [Dialer GPRS]
  16. Username = 1
  17. Password = 1
  18. Phone = *99#
  19. Mode = 1
  20. Inherits = Modem0
  21.  
  22. [Dialer DATA]
  23. Username = A
  24. Password = B
  25. Phone = *99#
  26. Mode = 1
  27. Inherits = Modem1
  28.  
  29. [Dialer Defaults]
  30. Modem = /dev/ttyACM0
  31. Baud = 460800
  32. Init1 = ATZ
  33. Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
  34. Init3 = AT+CGDCONT=1,"IP","airtelgprs.com"
  35. ISDN = 0
  36. Modem Type = Analog Modem
  37. Area Code =
  38. Phone = *99#
  39. Username =
  40. Password =
  41. Ask Password = 0
  42. Dial Command = ATDT
  43. Stupid Mode = 1
  44. Compuserve = 0
  45. Force Address =
  46. Idle Seconds = 1600
  47. DialMessage1 =
  48. DialMessage2 =
  49. ISDN = 0
  50. Auto DNS = 1


And when i run the command sudo wvdial DATA, following output appears:
  1. sudo wvdial DATA
  2. --> WvDial: Internet dialer version 1.60
  3. --> Cannot get information for serial port.
  4. --> Initializing modem.
  5. --> Sending: ATZ
  6. ATZ
  7. OK
  8. --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
  9. ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
  10. OK
  11. --> Sending: AT+CGDCONT=1,"IP","airtelgprs.com"
  12. AT+CGDCONT=1,"IP","airtelgprs.com"
  13. OK
  14. --> Modem initialized.
  15. --> Idle Seconds = 1600, disabling automatic reconnect.
  16. --> Sending: ATDT*99#
  17. --> Waiting for carrier.
  18. ATDT*99#
  19. CONNECT
  20. ~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
  21. --> Carrier detected. Starting PPP immediately.
  22. --> Starting pppd at Sat Nov 26 01:19:14 2011
  23. --> Pid of pppd: 9685
  24. --> Using interface ppp0
  25. --> pppd: ؗ[10][08]
  26. --> pppd: ؗ[10][08]
  27. --> pppd: ؗ[10][08]
  28. --> pppd: ؗ[10][08]
  29. --> pppd: ؗ[10][08]
  30. --> Disconnecting at Sat Nov 26 01:19:14 2011
  31. --> The PPP daemon has died: A modem hung up the phone (exit code = 16)
  32. --> man pppd explains pppd error codes in more detail.
  33. --> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.



As you can see this PPP daemon error ( code 16 ) is killing me.. How to solve it? Pls help me guys...

PS: Running Ubuntu 10.10
PPS: I can connect to net via Bluetooth quite fine. I just paired up the phone and ubuntu asked if I'd like to use it as a modem to access net and within seconds i was up and running BUT I just don't know what the damn problem is there is data cable?

Thanks
November 29, 2011 3:17:24 AM

Perhaps try the solution mentioned in this post, also see if there are any other guides to setup a data connection for your carrier, specifically APN, PPP settings, number, etc. Additionally, you may want to try to configure it through NetworkManager (have done both manual wvdial and NM setup for my BT and USB connection for my N900)
m
0
l
December 1, 2011 2:20:24 PM

Thanks but stupid mode= 1 is there in my wvdial.conf but it still doesn't work.
m
0
l
Related resources
December 7, 2011 2:11:12 AM

I would suggest attempting to set it up through NetworkManager, when plugged in and configured to connect in "data" mode (or whatever your phone calls it), it should appear in the available-to-configure connections
m
0
l
!