Sign-in / Sign-up
Your question
Closed

How to disable USB Device Not Recognized pop up PLZ!

Tags:
  • Drivers
  • How To
  • USB
  • Devices
  • Windows XP
Last response: in Windows XP
October 28, 2008 4:52:08 PM

How to remove "unknown USB device" message?

I re-installed my machine twice over the past 7 days and both times I am left with a very annoying pop up which says "Unknown USB device - one of the devices attached to your computer has malfunctioned". This pop up can happen literally as often as 20 times a minute.

I have re-installed this exact PC probably 5 times in 2 years and never had a problem until this week's re-installs. There is no new USB hardware attached, just three basic things I've always had (webcam, USB printer, scanner). Even with ALL usb devices disconnected I still get this message. The only way I've been able to disable this pop up permanently is to disable my USB root hub in device manager. That obviously takes away my USB ports and is not much good in the long run.

I've read through your forums, and most people with this problem seem to be able to get it to identify with a particular device. In my situation, I cannot imagine what device could be causing this annoying error.

Is there any way to just disable this pop up service? My computer is running fine, all USB ports work. I have tried to detect this unknown device for almost a week and I have read a tonne of forums and help places and have had no luck. I'm just left completely clueless. Even if I disable the unknown device, it STILL pops up.

Thanks in advance!

More about : disable usb device recognized pop plz

October 29, 2008 1:54:16 PM

Heya mondoguitar,

There are two ways to disable the USB error(s) you're getting.

There's a registry hack to disable all balloon tips but the method below seems more appropriate in your situation so I will describe that one first.

OPTION 1

1. You're familiar with device manager so go into it again and expand USB Controllers (Universal Serial Bus Controllers)

2. Right click each of the USB Controllers and select "Properties"

3. Click on the "Advanced" tab at the top of the window

4. At the bottom left of the window put a check mark in "Don't tell me about USB errors" and click "OK"

Do this for each USB option in device manager and with any luck the pop-ups will stop.

METHOD 2

This method disables ALL taskbar balloon pop-ups, so it's kind of like shooting a fly with a canon ball.

Below is a MS link to "Disable Notification Area Balloon Tips In Windows XP"

http://support.microsoft.com/kb/307729
October 29, 2008 2:04:51 PM

Thanks btk1w1, that's the kind of fix I've been looking for. I just tried it, so far so good, so we'll see how it goes.

Ideally, i'd obviously like to identify this unknown device, but since that seems impossible at this point, getting rid of the nag is the next best option, since all my USB ports still work.

Thanks for your help!
Related resources
October 29, 2008 2:07:05 PM

The ONLY change that has been made to my PC since re-installing without problems the last time, was I added a 2nd SATA HDD. I don't know if that can somehow relate to a USB error, but that's the only change I can think of. I've been thinking maybe my USB setup is starting to fail? But all the ports work.

Anyways, pop up is now gone, unfortunately, that probably means I'll miss the odd pop up I'd like to see :)  But better than what it was.
October 29, 2008 2:50:35 PM

Heya mondoguitar,

Glad to hear the pop-ups have ceased.

The only thing that I can think of is that you might need to update your chipset drivers, there may have been a MS update since previous OS installs that causes this error.

A SATA HDD addition shouldn't cause this error, but it wouldn't surprise me if it has.

In any case go to your motherboard manufacturers website and have a look if there is a later chipset driver release than the one you are currently using.

If you need a utility to correctly identify the exact motherboard (make, model and version) you currently have SIW should do the job for you. It has been very good to me in the past.

Link below:

http://www.gtopala.com/

Click on the download button at the top of the page, and on the new page on the left has the freeware versions. I like the standalone version because I take it on my flashdrive with me and can use it on any pc... but the one with the installer will suffice also.
October 29, 2008 3:12:39 PM

I should add as a precautionary note that it is adviseable to back-up your system and / or important documents when performing this kind of update.
July 27, 2010 2:37:45 PM

m also facing the same problem as mentioned above.. i tried the above method and i lost the error baloon message... but i still get usb connected and disconnected sound which has got into my nerves.. is there any way to detect the actual problem and disable the error completely... if i disable the sound completely then i wont be able to get the notification for other connected devices also.. please suggest... thank you
Anonymous
a b \ Driver
September 20, 2011 1:15:56 AM

to btk1w1

i love you, first option worked for me, was ready to smash the screen if i seen that stupid balloon again
thank you soo much
Sinead
:wahoo: 
November 3, 2011 11:11:13 PM

evolution487 said:
m also facing the same problem as mentioned above.. i tried the above method and i lost the error baloon message... but i still get usb connected and disconnected sound which has got into my nerves.. is there any way to detect the actual problem and disable the error completely... if i disable the sound completely then i wont be able to get the notification for other connected devices also.. please suggest... thank you


If you go into the Sounds part of the control panel, you can set the "Device connect/disconnect" sound to "[none]" and voilà, no annoying bing... bong... bing... bong... while still having all other sounds.
June 6, 2012 6:02:19 AM

Another solution!

Hello to all. I too have pulled out most of my hair over this "USB Device not recognized" flashing message w/annoying beep.
I installed XP SP3 on a Macbook with OSX 10.6.3. I installed the Apple Windows drivers from OSX disc.
I know that many others have had this problem with XP on PCs.
I tried all of the recommended fixes....none of them solved the problem.

I found the problem to be caused by Bluetooth.

Click the Start button, click Run, enter msconfig click OK
Click the Startup tab on top.
Unclick rundll32.exe bthprops.cpl,,BluetoothAuthenticationAgent
Click OK, then restart.
After Restart, a message will appear.
Click the box for "Don't show this message or launch system configuration utility when windows starts, click OK.

After doing this, I was able to reactivate this same item, and all is fine.

This may be an Apple specific fix. I don't know.

I hope that this will help others that have been plagued by this problem...M
October 31, 2012 2:49:07 PM

thank you this article helped me
April 8, 2013 4:21:18 AM

Wow!
Option 1 did it,
THANK YOU VERY MUCH :) 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
btk1w1 said:
Heya mondoguitar,

There are two ways to disable the USB error(s) you're getting.

There's a registry hack to disable all balloon tips but the method below seems more appropriate in your situation so I will describe that one first.

OPTION 1

1. You're familiar with device manager so go into it again and expand USB Controllers (Universal Serial Bus Controllers)

2. Right click each of the USB Controllers and select "Properties"

3. Click on the "Advanced" tab at the top of the window

4. At the bottom left of the window put a check mark in "Don't tell me about USB errors" and click "OK"

Do this for each USB option in device manager and with any luck the pop-ups will stop.

METHOD 2

This method disables ALL taskbar balloon pop-ups, so it's kind of like shooting a fly with a canon ball.

Below is a MS link to "Disable Notification Area Balloon Tips In Windows XP"

http://support.microsoft.com/kb/307729