Sign in with
Sign up | Sign in
Your question
Closed

Wired network in lububtu

Last response: in Linux/Free BSD
Share
December 6, 2011 3:38:33 AM

Hello,
i just now installed L ubuntu along with windos xp. my laptop is an old Acer Travelmate 2310 with 256mb Ram and 40 Gb harddisk.
i am able to access internet from Xp but unable to access from ubuntu.
i saw some queries regarding this matter but i didnt understand anything after reading that. can any one provide me how to create wired network and connect internet.
if possible please provide me step wise procedure as i have little knowledge about programming, ubuntu etc. i am using ubuntu for the 1st time

please help me
thanks in advance

More about : wired network lububtu

December 7, 2011 3:47:32 AM

It should be automatically configured and enabled, so there is likely some issue with the ethernet driver/chipset.

First things first, can you check to see if there is a wired connection listed in the NetworkManager


If there is, go ahead and check to make sure that the settings match what is needed by your network (likely just set to use DHCP to configure the connection) and enable.

If not, post the results of running a few commands from a terminal (LXDE menu->Accessories->LXTerminal)
  1. sudo ifconfig -a
  2. //post results here
  3. sudo lspci
  4. //post results here
Score
0
December 14, 2011 2:25:01 AM

thank you for the help...i wil check today and inform you. i think its not listed there. i will check and confirm today night.
Score
0
Related resources
December 14, 2011 11:17:18 AM

I just had a look for what card that Acer uses and it seems to be an SiS 900 PCI Fast Ethernet Adapter, reports are that this should just work out of the box. However, you don't seem to be the only one that's had an issue with this and I found this thread on Linux Questions:


http://www.linuxquestions.org/questions/linux-hardware-...

There are a few suggestions in that thread but the last comment looks interesting:

Quote:
Another possibility for anyone who is experiencing a similar problem is that the OS has placed your SIS900 ethernet device at eth1 instead of eth0. So edit /etc/networking/interfaces with
Code:

sudo gedit /etc/network/interfaces

and add the lines:
Code:

auto eth1
iface eth1 inet dhcp

then save and close and in a terminal type
Code:

sudo /etc/init.d/networking restart

This change will survive a reboot.


It might well be worth seeing if you have an eth1 connection listed where bmouring indicated in that screen shot.
Score
0
December 15, 2011 2:33:31 AM

bmouring said:
It should be automatically configured and enabled, so there is likely some issue with the ethernet driver/chipset.

First things first, can you check to see if there is a wired connection listed in the NetworkManager
http://evo.homelinux.net/NM.jpg

If there is, go ahead and check to make sure that the settings match what is needed by your network (likely just set to use DHCP to configure the connection) and enable.

If not, post the results of running a few commands from a terminal (LXDE menu->Accessories->LXTerminal)
  1. sudo ifconfig -a
  2. //post results here
  3. sudo lspci
  4. //post results here



i checked this and this is the result:

1)
eth0 Link encap:Ethernet HWaddr 00:c0:9f:bc:32:c9
inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::2c0:9fff:febc:32c9/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:7 errors:0 dropped:0 overruns:0 frame:0
TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:956 (956.0 B) TX bytes:2649 (2.6 KB)
Interrupt:19 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr 00:14:a4:21:68:71
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

2)


00:00.0 Host bridge: Silicon Integrated Systems [SiS] 661FX/M661FX/M661MX Host (rev 11)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO] (rev 25)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 91)
00:06.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)
00:0b.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter


i called my friend who installed Lubuntu in my system. he told that problem might be with log in. current situation is that i can use net in XP. i have to use username and password each time i try to connect net and its not automatically connected. he told that the problem might be on using username and password each time and its not automatically connected...

if any one gets some idea about how to connect internet pls tel me....

Thanx in advance
Score
0
December 15, 2011 1:29:48 PM

It sounds to me like you're using wireless in XP rather than the wired connection. It would be very unusual for your router to be asking you for a password on the wired connection, that's much more the behaviour of an ADSL adapter connected via USB or when you authenticate your WAP/WEP credentials for a wireless session.

What's more confusing is this:

Quote:
eth0 Link encap:Ethernet HWaddr 00:c0:9f:bc:32:c9
inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::2c0:9fff:febc:32c9/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:7 errors:0 dropped:0 overruns:0 frame:0
TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:956 (956.0 B) TX bytes:2649 (2.6 KB)
Interrupt:19 Base address:0x2000


Here we can see that your network adapter (eth0) is actually being given an IP address, so we know your network adapter is being recognised by Linux and is picking up the IP address from your router - in theory it should be working :( 

Can you open up a terminal and try the following:

  1. ping -c 10 192.168.1.1


This will see if we can ping your router, you can also try opening a web browser and typing 192.168.1.1 in the adress bar, it should give you the login screen to your router.

Next try:
  1. ping -c 10 173.194.66.104


This tries to ping the IP address for Google.com so we can see if it can see the outside world

Then we can try:
  1. ping -c 10 google.com


This will tell us if your system can convert the name of a site into the IP address.

It might also be worth having a look at your network settings under WinXP, you can do this via the control pannel->networking select your network and right click on it to view properties. A screen shot of this would be handy if you can do it.
Score
0
December 16, 2011 3:08:26 AM

If you access internet via a route, try:
  1. sudo dhclient eth0

sometimes may help.
Score
0
December 16, 2011 3:32:38 AM

audiovoodoo said:
It sounds to me like you're using wireless in XP rather than the wired connection. It would be very unusual for your router to be asking you for a password on the wired connection, that's much more the behaviour of an ADSL adapter connected via USB or when you authenticate your WAP/WEP credentials for a wireless session.

What's more confusing is this:

Quote:
eth0 Link encap:Ethernet HWaddr 00:c0:9f:bc:32:c9
inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::2c0:9fff:febc:32c9/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:7 errors:0 dropped:0 overruns:0 frame:0
TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:956 (956.0 B) TX bytes:2649 (2.6 KB)
Interrupt:19 Base address:0x2000


Here we can see that your network adapter (eth0) is actually being given an IP address, so we know your network adapter is being recognised by Linux and is picking up the IP address from your router - in theory it should be working :( 

Can you open up a terminal and try the following:

  1. ping -c 10 192.168.1.1


This will see if we can ping your router, you can also try opening a web browser and typing 192.168.1.1 in the adress bar, it should give you the login screen to your router.

Next try:
  1. ping -c 10 173.194.66.104


This tries to ping the IP address for Google.com so we can see if it can see the outside world

Then we can try:
  1. ping -c 10 google.com


This will tell us if your system can convert the name of a site into the IP address.

It might also be worth having a look at your network settings under WinXP, you can do this via the control pannel->networking select your network and right click on it to view properties. A screen shot of this would be handy if you can do it.



infact i am using wired network only.....its very unusual but its a fact. i will check today evening and will inform tommorow...
Score
0
December 23, 2011 9:27:20 AM

please see the result and advice me accordingly...
the person who installed Lubuntu in my system is now asking me to uninstall Lubuntu.. what he saying is, problem lies in router/ service provider. Router is not saving username and password in it. since i have to use userid and password each time it would be difficult for me to take net from Lubuntu. he also told that he searched net but he didnt find any solution ...

can any one here help me...

( i dont know whether posting these details will cause some security problem. )
dipu@ubuntu:~$ ping -c 10 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_req=1 ttl=64 time=2.25 ms
64 bytes from 192.168.1.1: icmp_req=2 ttl=64 time=0.814 ms
64 bytes from 192.168.1.1: icmp_req=3 ttl=64 time=0.964 ms
64 bytes from 192.168.1.1: icmp_req=4 ttl=64 time=1.84 ms
64 bytes from 192.168.1.1: icmp_req=5 ttl=64 time=1.84 ms
64 bytes from 192.168.1.1: icmp_req=6 ttl=64 time=1.85 ms
64 bytes from 192.168.1.1: icmp_req=7 ttl=64 time=1.84 ms
64 bytes from 192.168.1.1: icmp_req=8 ttl=64 time=1.84 ms
64 bytes from 192.168.1.1: icmp_req=9 ttl=64 time=1.84 ms
64 bytes from 192.168.1.1: icmp_req=10 ttl=64 time=1.84 ms

--- 192.168.1.1 ping statistics ---
10 packets transmitted, 10 received, 0% packet loss, time 9013ms
rtt min/avg/max/mdev = 0.814/1.694/2.250/0.422 ms
dipu@ubuntu:~$
Usage: ping [-LRUbdfnqrvVaAD] [-c count] [-i interval] [-w deadline]
[-p pattern] [-s packetsize] [-t ttl] [-I interface]
[-M pmtudisc-hint] [-m mark] [-S sndbuf]
[-T tstamp-options] [-Q tos] [hop1 ...] destination

dipu@ubuntu:~$ ping -c 10.google.co.in
Usage: ping [-LRUbdfnqrvVaAD] [-c count] [-i interval] [-w deadline]
[-p pattern] [-s packetsize] [-t ttl] [-I interface]
[-M pmtudisc-hint] [-m mark] [-S sndbuf]
[-T tstamp-options] [-Q tos] [hop1 ...] destination



audiovoodoo said:
It sounds to me like you're using wireless in XP rather than the wired connection. It would be very unusual for your router to be asking you for a password on the wired connection, that's much more the behaviour of an ADSL adapter connected via USB or when you authenticate your WAP/WEP credentials for a wireless session.

What's more confusing is this:

Quote:
eth0 Link encap:Ethernet HWaddr 00:c0:9f:bc:32:c9
inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::2c0:9fff:febc:32c9/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:7 errors:0 dropped:0 overruns:0 frame:0
TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:956 (956.0 B) TX bytes:2649 (2.6 KB)
Interrupt:19 Base address:0x2000


Here we can see that your network adapter (eth0) is actually being given an IP address, so we know your network adapter is being recognised by Linux and is picking up the IP address from your router - in theory it should be working :( 

Can you open up a terminal and try the following:

  1. ping -c 10 192.168.1.1


This will see if we can ping your router, you can also try opening a web browser and typing 192.168.1.1 in the adress bar, it should give you the login screen to your router.

Next try:
  1. ping -c 10 173.194.66.104


This tries to ping the IP address for Google.com so we can see if it can see the outside world

Then we can try:
  1. ping -c 10 google.com


This will tell us if your system can convert the name of a site into the IP address.

It might also be worth having a look at your network settings under WinXP, you can do this via the control pannel->networking select your network and right click on it to view properties. A screen shot of this would be handy if you can do it.

Score
0
December 23, 2011 9:41:29 AM

MODS PLS DELETE THE BELOW MAIL IF ITS GOING TO CAUSE ANY SECURITY ISSUE (EITHER TO ME OR TO THIS FORUM)

please see the images and if any one can identify the problem please help me



















Score
0
December 27, 2011 6:18:30 PM

I don't quite understand your network's setup, it seems that you're configuring two separate connections: a wired ethernet connection using DHCP to presumably a router (that in turn handles the PPPoE stuff of your DSL connection) as well as a direct connection to a DSL modem (presumably over USB or a direct connection from modem to your machine over ethernet). If you have it connected via ethernet through a router, the DHCP should handle all of the local settings needed for network traffic destined for the internet (via NAT that occurs on the router itself). If it's connected via a direct connection to the modem, the issue there is that the PPPoE interface that is expected in the ifconfig listing is missing which indicates a misconfiguration issue. If you have both connection types, don't (it's unnecessarily complex and rife with potential issues)
Score
0
May 23, 2014 12:28:05 PM

dipudivakar said:
please see the result and advice me accordingly...
the person who installed Lubuntu in my system is now asking me to uninstall Lubuntu.. what he saying is, problem lies in router/ service provider. Router is not saving username and password in it. since i have to use userid and password each time it would be difficult for me to take net from Lubuntu. he also told that he searched net but he didnt find any solution ...


I had exactly the same problem! Lubuntu did not work with SiS 900 Fast PCI Ethernet driver (on motherboard). In ifconfig it showed DHCP address to be allright at eth0 (like you had in your computer), but I was not able to ping external servers, use browser to surf internet etc. Strangely software update did work (from LXDE) and I could do even major update from 13.10 to 14.02 today. Installing software (like Libre Office) did not work. The same interface was running perfectly when booting to Windows XP. Interface was detected correctly by Linux, so I thought it has some incompatibility issue.

The issue is probably a bug in Lubuntu release. I found out that it is missing from the /etc/network/interfaces. It had only loopback interface listed, no information about eth0. I did add eth0 manually and now internet is working perfectly in Lubuntu:

Do the following:

sudo pico /etc/network/interfaces

Add the following to the beginning of the file (preferably after the first comment line):

auto eth0
iface eth0 inet dhcp

Save the file and enjoy.
Score
0
!