Sign-in / Sign-up
Your question
Solved

Ubuntu and Mac file share

Tags:
  • Ubuntu
  • Macintosh
Last response: in Open Source Software
December 13, 2011 6:31:06 PM

So I just installed ubuntu server 11.10 and I successfully set up a samba share, but when I try to log in with my mac I am not able to upload anything. I can see whats in the folder, but I when I try to upload it asks for my password and tells me that i dont have permission. When I looked at the permissions under info it says that i have mixed permission. Plz help, i have no idea whats wrong.

More about : ubuntu mac file share

December 14, 2011 11:21:18 AM

You might have set share permission but not at the file system level. If you logon to the Linux box directly with the user info you've been using from the Mac then can you create and delete files in the directory that you are sharing?
m
0
l
December 14, 2011 10:43:15 PM

I cant do anything. I get an error message when I try to create or move anything to the server. Could it be that the drive im sharing doesn't have the correct permission?
m
0
l
Related resources
December 14, 2011 11:48:53 PM

Yes, it sounds like you need to set the permisions on the actual disc. Select the directory in your file browser and right click, use the options to set who has write access.
m
0
l
December 15, 2011 2:01:29 AM

its ubuntu server 11.10, need to do it through command line
m
0
l
December 15, 2011 1:13:29 PM

In that case you'll need to use the command chmod or maybe chown.

chmod - sets the permissons on the file or directory
chown - sets the ownership of the file or directory

So, you can either set the permissions so that the group your user account in has read write access or change the directory that you are sharing so that it is owned by the user account you are using to logon from the Mac.

Easist way is with chown

sudo chown <account name> <path to shared directory>

by default the owner of a file in Linux has full controll of it.
m
0
l
December 15, 2011 2:09:03 PM

Can u give guests full permission?
m
0
l

Best solution

December 16, 2011 8:34:04 AM

Yes, but you would need to use chmod for that. Type man chmod at the command prompt to get a detailed list of the command options.
Share
December 16, 2011 1:34:21 PM

Best answer selected by Eeee569.
m
0
l