Closed Solved

USB Mouse Not Working In Vista

Hi. I've just bought a new Microsoft Intellimouse Optical 1.1A USB/ PS/2. I want to use it as a USB mouse, but for some reason it will only work when I plug it in using the PS/2 adapter. I have checked to make sure USB mouse is enabled in the BIOS. I'm using Vista Ultimate (32 bit).

When I plug the mouse into a USB port it installs fine and the optical sensor starts working, but the mouse doesn't work. Nothing shows up under 'Mouse' in control panel. When I check in Device Manager, the mouse shows up as a Human Interface Device, but there is nothing there for 'Mouse'. I have tried downloading the latest mouse software from Microsoft, which installs fine, and works OK when the mouse is installed in the PS/2 port, but if I restart and put the mouse in the USB port it doesn't show up as installed even in the MS Mouse software.

I don't want to use the mouse with the PS/2 adapter because it sticks out too far at the back of the computer, and because there is some sort of grounding issue with my PS/2 ports which I'm too lazy to sort out- sometimes when I remove or plug-in a PS/2 device while the computer is switched on (I know you're not supposed to do this) the computer powers off.

Any ideas as to what I can do to get the mouse working on the USB?

Many thanks in advance for any help.
1 answer Last reply Best Answer
More about mouse working vista
  1. Best answer
    Just in case anyone reads this and is having the same problem, I found the solution here:

    http://anotherlab.rajapet.net/2008/04/work-around-for-kb938371-disabling-hid.html
Ask a new question

Read More

Drivers Mice PS/2 USB Windows Vista