Sign in with
Sign up | Sign in
Your question

Help Required - Windows XP ASR wont create Recovery Files

Last response: in Windows XP
Share
November 19, 2008 10:50:44 AM

Hi All, First Post ever from me.
Hopefully this is the most appropriate thread. If not somebody please tell me.

My machine is a Dell Dimension E520 2.13GHz 2Gb RAM 2 x 145Gb Hard Disks, Sound Card DVD R/W drive etc.

I have a problem in that Windows XP Pro wont create the ASR recovery files when an ASR backup is attempted.
Get the following message
"The files for the recovery diskette could not be created. The operation was aborted." Microsoft TechNet only has references to Windows Server 2003 and XP Home against ASR related problems.

Here's the background to this problem
The machine was supplied XP Pro 2002 SP2 preinstalled. 2 x 145 Gb disks preconfigured in RAID 1 (mirror) array. (Intel Storage Manager) ASR backup worked fine, no problems.

Because I wanted to use Linux I reconfigured the Intel S/M to remove the RAID array leaving 2 disks with identical contents.
I then put Centos 5.2 Linux on the 2nd disk, keeping XP on the first disk (drive C:\)
I used grub to dual boot and all seemed fine.
The other day I decided to carry out another full ASR backup which is when I got the error behaviour above. I removed grub and used FIXMBR to put back a Windows only boot setup into the first disk. The other disk still has Linux but I can't dual boot at present.
Even with the "Windows" MBR boot sector I still can't use ASR backup.

Has anyone else experienced this problem ? Does anyone know of a fix to it ?

Thanks in anticipation.

Regards

Grommit Here

April 5, 2009 1:47:56 PM

Hi Grommit_Here:

I have a similar setup, RAID: XP PRO SP3 and Fedora 9, and ran into the same problem.

- Install ftonline.exe from the XP install disk/SUPPORT/TOOLS/SETUP.EXE. (I don't know if you got a disk from Dell.)
http://support.microsoft.com/kb/303246/EN-US/

- cd to Program Files\Support Tools

- enter "ftonline c:"

- If you get "Online succeeded" go to the next step. If you don't, try different drive letters you've used in the past.

- In a DOS window, enter "mountvol"
http://support.microsoft.com/kb/205524

- Look for a volume that's not assigned a drive letter. ( Hopefully, you'll see one because the unassigned drive was the root cause of my problem.)

- Assign the unassigned drive(s) to an unused drive letter(s) by entering "mountvol MOUNTPOINT DRIVELETTER" Substitute the mountpoint string for MOUNTPOINT, and the unused drive letter for DRIVELETTER.

- Go to the newly assigned drives, and make sure there's nothing there that you need. There shouldn't be.

- Open the Disk Management Tool: Start/Administrative Tools/Computer Management/Disk Management

- RMB the newly assigned drives, and delete the partition.

You should be able to run ASR.

Good luck,
Duane
April 6, 2009 9:34:16 AM

Thanks

I'll give this a try.

I must be a little dull today

Cannot guess what

" - RMB the newly assigned drives, ...." means ? RMB ??

Did it mean MBR (/fix) ??


Regards

Grommit_Here
Related resources
April 6, 2009 9:39:03 AM

Googled RMB

Right Mouse Button ??

Cheers

Grommit_Here
April 6, 2009 11:40:08 AM

Correct!

You might be able to skip the ftonline steps if you can't get SUPPORT/TOOLS/* from Dell. I did that step because I was trying to piece together a procedure from support.microsoft.com.

The newly mounted volume could show up on top of your linux install the Disk Management Tool. In which case, you may be able to delete the mountpoint string in the registry, but I haven't tried that.

Duane
April 8, 2009 6:06:50 PM

Hi Duane
Well I have good news :)  ... and bad news .. :( 

The good news I got all the support tools stuff and I think I did what you said.
When I did the mountvol I only saw Drive C referenced.

Went to
Disk Management Tool: Start/Administrative Tools/Computer Management/Disk Management ...

Thought - Well this is windows so I could delete the E: drive partition (my other disk) Hmm. That was the bad news 'cos that was my Linux install.

Restart the pc and it stopped at the grub prompt. (I use grub to dual boot Windows (on drive C - first disk) and Centos (on drive E - 2nd disk).

Linux rescue couldn't find anything on my 'Linux' disk.
Windows install disk, "R" for recovery, FixMBR got Windows back .

And guess what - ASR worked again! :) 

Actually the loss of linux is not a major problem since I didn't have any serious stuff over there.

The big question will be - If I re-install Linux onto the 2nd disk, then revert to grub to dual boot will ASR "disappear" ?

I'll post the answer once I've tried it, but my money's on YES because I'm thinking its something to do with either Linux on the 2nd disk or (more likely) using grub as a boot loader.

Sorry for the long post but thanks again for the input.

Regards

Grommit_Here


!