Sign in with
Sign up | Sign in
Your question

Help me not give up on linux for ever.

Last response: in Linux/Free BSD
Share
March 4, 2012 7:14:17 AM

I have tried Linux many times, and at the behest of not smashing may computer and burning down my house in frustration I simply reinstall windows and feel human again.

All I want to do for now is get the damn thing online.

But apparently I am dumber than a dead horse. http://ubuntuforums.org/showthread.php?t=902534

I have the windows driver and I have NDISwrapper(http://sourceforge.net/projects/ndiswrapper/files/lates...) on the machine.

The machine does not have wired internet and it never will.

The wlan card is BCM4318.

The distro is Zorin 5.2 Lite.\

MAKE IS NOT INSTALLED whatever that means.

More about : give linux

a b 5 Linux
March 4, 2012 5:08:57 PM

Zorin is Debian based, so you can install 'make' via a terminal using the command:

  1. apt-get install make


You may need to prefix that command with "sudo", or if sudo is not installed, type "su" to gain root access, and run the command. While you're at it make sure gcc is installed (run the same command, but replace 'make' with 'gcc').

Once make is installed, try again! If you have any issues from there on, post them here.
m
0
l
a b 5 Linux
March 4, 2012 5:25:11 PM

Hello this chipset does NOT need ndiswrapper (though you can still use it if you really want to). It is supported by the b43 driver:
http://linuxwireless.org/en/users/Drivers/b43

Normally all you need to do is download the package from a third party computer and put it on a flash drive or something for your pc. Here are instructions for doing it without internet access (require third party pc to download files): https://help.ubuntu.com/community/WifiDocs/Driver/bcm43...

btw Make: http://manpages.ubuntu.com/manpages/hardy/man1/make.1.h...
(Hint: its used for compiling software)

Quote:
so you can install 'make' via a terminal using the command:

No, because he does not have internets on the machine yet, he can not install via apt-get
m
0
l
Related resources
a b 5 Linux
March 4, 2012 5:52:02 PM

skittle said:
Quote:
so you can install 'make' via a terminal using the command:

No, because he does not have internets on the machine yet, he can not install via apt-get


Derp, wasn't thinking. Thanks.
m
0
l
March 5, 2012 6:10:32 AM

My cd has none of this
b43 - No Internet access

If you do not have any other means of Internet access on your computer, you will have to install b43-fwcutter and patch packages from the install media. After that you will need to setup firmware manually (without the firmware automatically downloading and being set up).

Setp 1.

b43-fwcutter is located on the Ubuntu install media under ../pool/main/b/b43-fwcutter/ and patch is located under ../pool/main/p/patch/ or both in the official repositories online.

Note: In some versions (10.04 and 11.04 at least) there is not a /pool/main/p/patch/ If this file is missing then you don't need it. In this case you only need to install /pool/main/b/b43-fwcutter by following the instructions below.

Double click on the package to install or in a terminal (under the desktop menu Applications > Accessories > Terminal) navigate to the folder containing the package and issue the following command:

:/ b43-fwcutter/$ sudo dpkg -i b43-fwcutter*

In case you couldn't find the folder, wubi keeps it as a hidden folder so you have to mount it. Follow these steps:

~$ sudo mount -o loop /host/ubuntu/install/.fuse_hidden0000000400000001 /mnt
~$ cd /mnt/pool/main/b/b43-fwcutter/
~$ sudo apt-get install b43-fwcutter
~$ sudo dpkg -i b43-fwcutter*

As for the patch:

~$ cd /mnt/pool/main/p/patch/
~$ sudo apt-get install b43-fwcutter

Then unmount:

~$ sudo umount /mnt

so i downloaded ubuntu 11.10

should i just install this one?

can i change the GNU so it looks more like windows?
m
0
l
a b 5 Linux
March 5, 2012 8:11:35 AM

Lubuntu/Linux Mint LXDE?

or you could modify Ubuntu to look like either of those.
m
0
l
a b 5 Linux
March 5, 2012 5:46:00 PM

You don't need to install ubuntu, just need the b43-fwcutter package.
Also Zorin 5.2 is built on (l)ubuntu 11.04, so must use that one i believe. No harm in trying the package for 11.10 though, it may or may not work.

Alternatively you can use the package from the ubuntu 11.04 repository for zorin 5.2 to avoid downloading the entire ubuntu distrobution
http://packages.ubuntu.com/natty/b43-fwcutter (download for your architecture)

BTW sorry your having such issues, the specific wireless chipset has firmware made by broadcom that is not free to distribute :( 
im surprised more distributions do not include b43-fwcutter considering how immensely popular those chipsets are.
m
0
l
March 7, 2012 6:56:56 AM

Sorry ignored the thread. I just went with Unbuntu 11.10.

I could not get anything going on Zorin because of conflicts with gcc. So I gave up on that distro.
I also forced a switch to LXDE form this guy http://www.psychocats.net/ubuntu/purelxde using this command strain (probably wrong term):
sudo apt-get remove acpi-support acpid adium-theme-ubuntu aisleriot apg app-install-data app-install-data-partner appmenu-gtk appmenu-gtk3 appmenu-qt apt-xapian-index apturl apturl-common at-spi2-core avahi-autoipd bamfdaemon banshee banshee-extension-soundmenu banshee-extension-ubuntuonemusicstore baobab binfmt-support bluez-alsa bluez-cups bluez-gstreamer branding-ubuntu brasero brasero-cdrkit brasero-common brltty c2esp checkbox checkbox-gtk cli-common compiz compiz-core compiz-gnome compiz-plugins-default compiz-plugins-main-default compizconfig-backend-gconf cups-bsd dc deja-dup dmz-cursor-theme doc-base duplicity dvd+rw-tools empathy empathy-common eog espeak espeak-data evolution-data-server evolution-data-server-common example-content exiv2 firefox firefox-globalmenu firefox-gnome-support foo2zjs gamin gbrainy gcalctool gcc gcc-4.6 gedit gedit-common geoclue geoclue-ubuntu-geoip ghostscript-x ginn gir1.2-atspi-2.0 gir1.2-gconf-2.0 gir1.2-gmenu-3.0 gir1.2-gtksource-3.0 gir1.2-indicate-0.6 gir1.2-launchpad-integration-3.0 gir1.2-peas-1.0 gir1.2-totem-1.0 gir1.2-totem-plparser-1.0 gir1.2-wnck-3.0 gnome-accessibility-themes gnome-codec-install gnome-control-center gnome-control-center-data gnome-desktop3-data gnome-font-viewer gnome-games-common gnome-icon-theme-symbolic gnome-mahjongg gnome-media gnome-menus gnome-nettool gnome-online-accounts gnome-orca gnome-power-manager gnome-screensaver gnome-screenshot gnome-search-tool gnome-session gnome-session-bin gnome-session-canberra gnome-session-common gnome-settings-daemon gnome-sudoku gnome-system-log gnome-system-monitor gnome-terminal gnome-terminal-data gnome-utils-common gnomine growisofs gstreamer0.10-alsa gstreamer0.10-gconf gstreamer0.10-plugins-base-apps gstreamer0.10-pulseaudio gstreamer0.10-tools guile-1.8-libs gwibber gwibber-service gwibber-service-facebook gwibber-service-identica gwibber-service-twitter hplip hplip-cups hplip-data hwdata ibus ibus-gtk ibus-gtk3 ibus-pinyin ibus-pinyin-db-android ibus-pinyin-db-open-phrase ibus-table im-switch indicator-appmenu indicator-datetime indicator-power indicator-session indicator-sound inputattach intel-gpu-tools kerneloops-daemon lftp libappindicator0.1-cil libasound2-plugins libatk-adaptor libatspi2.0-0 libavahi-gobject0 libbamf0 libbamf3-0 libboost-serialization1.46.1 libbrasero-media3-1 libbrlapi0.5 libc-dev-bin libc6-dev libcamel-1.2-29 libcanberra-pulse libcompizconfig0 libcrypt-passwdmd5-perl libdbus-glib1.0-cil libdbus1.0-cil libdbusmenu-qt2 libdconf-dbus-1-0 libdconf-qt0 libdconf0 libdecoration0 libdotconf1.0 libebackend-1.2-1 libebook1.2-12 libecal1.2-10 libedata-book-1.2-11 libedata-cal-1.2-13 libedataserver1.2-15 libedataserverui-3.0-1 libespeak1 libexempi3 libexiv2-10 libfile-copy-recursive-perl libfolks-telepathy25 libfolks25 libgail-3-common libgail-common libgamin0 libgconf2.0-cil libgd2-xpm libgdata-common libgdata1.7-cil libgdata13 libgdiplus libgeoclue0 libgexiv2-0 libgkeyfile1.0-cil libglew1.5 libglewmx1.5 libglib2.0-bin libglib2.0-cil libglib2.0-data libgmime-2.4-2 libgmime2.4-cil libgnome-control-center1 libgnome-desktop-3-2 libgnome-media-profiles-3.0-0 libgnome-menu-3-0 libgnome-menu2 libgnome2-common libgnomekbd-common libgnomekbd7 libgnomevfs2-0 libgnomevfs2-common libgoa-1.0-0 libgomp1 libgtk-sharp-beans-cil libgtk-vnc-2.0-0 libgtk2.0-cil libgtkmm-3.0-1 libgtksourceview-3.0-0 libgtksourceview-3.0-common libgtkspell3-0 libgudev1.0-cil libgvnc-1.0-0 libgweather-3-0 libgweather-common libgwibber-gtk2 libgwibber2 libhyphen0 libibus-1.0-0 libidl0 libido3-0.1-0 libjson-glib-1.0-0 liblaunchpad-integration1.0-cil liblightdm-gobject-1-0 liblouis-data liblouis2 libmetacity-private0 libmission-control-plugins0 libmng1 libmono-addins-gui0.2-cil libmono-addins0.2-cil libmono-cairo4.0-cil libmono-corlib4.0-cil libmono-csharp4.0-cil libmono-i18n-west4.0-cil libmono-i18n4.0-cil libmono-posix4.0-cil libmono-security4.0-cil libmono-sharpzip4.84-cil libmono-system-configuration4.0-cil libmono-system-core4.0-cil libmono-system-drawing4.0-cil libmono-system-security4.0-cil libmono-system-xml4.0-cil libmono-system4.0-cil libmono-zeroconf1.0-cil libmysqlclient16 libmythes-1.2-0 libnotify-bin libnotify0.4-cil libnux-1.0-0 libnux-1.0-common liboauth0 libopencc1 liborbit2 liboverlay-scrollbar-0.2-0 liboverlay-scrollbar3-0.2-0 libpeas-1.0-0 libpeas-common libprotobuf7 libprotoc7 libpulse-mainloop-glib0 libqt4-dbus libqt4-declarative libqt4-network libqt4-opengl libqt4-script libqt4-sql libqt4-sql-mysql libqt4-svg libqt4-xml libqt4-xmlpatterns libqtbamf1 libqtcore4 libqtdee2 libqtgconf1 libqtgui4 libquadmath0 libquvi0 libraptor2-0 librasqal3 librdf0 libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-emailmerge libreoffice-gnome libreoffice-gtk libreoffice-help-en-us libreoffice-impress libreoffice-math libreoffice-style-human libreoffice-writer librest-0.7-0 librsync1 libsane-hpaio libsdl1.2debian-pulseaudio libspeechd2 libspeexdsp1 libstlport4.6ldbl libsyncdaemon-1.0-1 libtaglib2.0-cil libtelepathy-farsight0 libtelepathy-logger2 libtextcat-data libtextcat0 libtotem-plparser17 libtotem0 libubuntuone-1.0-1 libubuntuone1.0-cil libunique-1.0-0 libunity-2d-private0 libunity-core-4.0-4 libunity-misc4 libutempter0 libuuid-perl libwmf0.2-7-gtk libwnck-3-0 libwnck-3-common libwnck-common libwnck22 libxp6 libxres1 libyajl1 libyaml-tiny-perl libzeitgeist-1.0-1 light-themes lightdm linux-libc-dev make media-player-info metacity metacity-common mono-4.0-gac mono-gac mono-runtime mousetweaks mscompress mysql-common nautilus nautilus-sendto nautilus-sendto-empathy nautilus-share notify-osd notify-osd-icons nux-tools onboard oneconf openprinting-ppds overlay-scrollbar pinyin-database pkg-config plymouth-theme-ubuntu-logo protobuf-compiler ptouch-driver pulseaudio pulseaudio-esound-compat pulseaudio-module-bluetooth pulseaudio-module-gconf pulseaudio-module-x11 pulseaudio-utils pxljr python-brlapi python-configglue python-dateutil python-egenix-mxdatetime python-egenix-mxtools python-farsight python-gconf python-ibus python-imaging python-indicate python-libproxy python-louis python-openssl python-pam python-papyon python-pexpect python-piston-mini-client python-protobuf python-pyatspi2 python-pyinotify python-serial python-speechd python-telepathy python-twisted-bin python-twisted-core python-twisted-names python-twisted-web python-ubuntuone-client python-ubuntuone-control-panel python-ubuntuone-storageprotocol python-uno python-virtkey python-webkit python-wnck qdbus qt-at-spi radeontool rastertosag-gdi rdesktop rfkill rtkit sane-utils seahorse shotwell sni-qt software-center speech-dispatcher splix ssh-askpass-gnome syslinux syslinux-common telepathy-butterfly telepathy-gabble telepathy-haze telepathy-idle telepathy-indicator telepathy-logger telepathy-mission-control-5 telepathy-salut thunderbird thunderbird-globalmenu thunderbird-gnome-support tomboy toshset totem totem-common totem-mozilla totem-plugins ttf-opensymbol ubufox ubuntu-artwork ubuntu-desktop ubuntu-docs ubuntu-mono ubuntu-sounds ubuntu-sso-client ubuntu-system-service ubuntu-wallpapers ubuntuone-client ubuntuone-client-gnome ubuntuone-control-panel ubuntuone-control-panel-gtk ubuntuone-couch ubuntuone-installer unity unity-2d unity-2d-launcher unity-2d-panel unity-2d-places unity-2d-spread unity-asset-pool unity-common unity-greeter unity-lens-applications unity-lens-files unity-lens-music unity-scope-musicstores unity-services uno-libs3 update-inetd ure usb-creator-common usb-creator-gtk vinagre vino whois wodim xbitmaps xcursor-themes xdg-user-dirs-gtk xdiagnose xfonts-mathml xterm xul-ext-ubufox zeitgeist zeitgeist-core zeitgeist-datahub zeitgeist-extension-fts zenity zenity-common && sudo apt-get install lubuntu-desktop

I am loving the change, but when I boot I get a X sessions error. It seems to run fine despite that.

The machine I am on is a P4 2.4g single core with a gig of ram. I am using like 400 megs just to run the os and it is a bit sluggish. What is a good distro for this kind of system? If I need to/should start a new thread just let me know.

You guys really rock! Thanks for being so kind.
m
0
l
a b 5 Linux
March 7, 2012 7:32:55 AM

No way! Half of that stuff doesn't help.

I idle at 124MiB on LXDE Fedora.
m
0
l
March 7, 2012 7:42:52 AM

I used iostat to ckeck and I did have chromiom open at the time so my facts could be wrong. But XP ran smother on this machine and ubuntu has crashed like four time (before the change to LXDE). I am going for Fedora but am having issues using an external hdd for the install instead of a cd.
m
0
l
a b 5 Linux
March 7, 2012 7:45:19 AM

LXDE should run very smoothly. I would recommend installing a distro such as Fedora LXDE respin, Lubuntu or Linux Mint LXDE. All have LXDE by default and should reduce on bloat. I mean like why did you follow that guy? Gnome-soduku? :p 
m
0
l
March 8, 2012 6:15:06 AM

First off Why did I follow that guy? Because I have no @$#^ing idea what I am doing. Does any one in the Linux community understand this. I come from Windows where you do almost everything with a mouse. To install a program you double-click on an icon and choose the directory with your mouse. Not to say I have not manually installed windows programs, but again it was with a mouse, dragging and dropping icons in a window, not cmd. Could you please have some sympathy for a beginner and not treat them like an expert who is just stupid. I had found a package to revert to GNome 2 but it failed, so I tried this guys thing, and you know what; It worked. When I booted up I was in GNome 2 and apart from the X sessions going to default nothing seemed wrong.

The reason I have always had trouble with linux is the users have no sympathy for beginners.

Sorry for the rant.

I got Fedora 16 LXDE respin and when ever I start up I get
2.023379 render error detected EIR : 0x00000010
drm i915 report and clear *Error* EIR stuck 0x00000010 masking
And an error with my EDID. The 2.02 number changes every time.
Also when I reboot it gets stuck on a black screen with a cursor in the upper left, shut down works.

I think I need to get drivers for my Geforce 2 MX 4000 card- using this because I do not think there are drivers for my Intel 845g onboard chip and resolution is stuck at 1024 x 768 on my 1440 x 900 screen with either being used. How do I do this on F16 LXDE? I also want to change my resolution bigger and slow down the mouse double click speed.

Again if I should start a new thread let me know.

Again and again thank you very much for the help, it is all that is keeping this project going.
m
0
l
a b 5 Linux
March 8, 2012 6:57:21 AM

I'll be honest with you, don't worry about it, keep going along with the thread, I'm ther moderator down here and as long as we don't start talking about strawberry shortcake, I will leave it open :) .

I've never dealt with an issue like that so I will wait for the smarter ones to get here :) .

Historically I think Fedora dropped support for that kind of hardware... I think... could be wrong.

Honestly Linux Mint is the cloest possible to windows.
m
0
l
March 8, 2012 7:38:24 AM

Ok I'll give mint a try, but I am not burning a cd/dvd. What can I use to get it on a flash drive/external hard drive?

I tried LiveUSB creator with Fedora and it constantly failed during the install.

Keep inmind I am creating the install media from Windows 7. Unless there is an "EASY" way to do it from Fedora.
m
0
l
March 8, 2012 7:40:42 AM

Holy Cow! Mint comes with a manual. This is already looking good.
m
0
l
a b 5 Linux
March 8, 2012 7:45:11 AM

Make your USB drive with UNetbootin or Universal USB creator.

You'll be pleased to know.

Mint comes with VLC, adobe flash and an app store.

Possibly double-click install with debs. Can't remember.

But remember, all the major distributions have documentation. Even Fedora.
m
0
l
a b 5 Linux
March 9, 2012 12:13:29 AM

i have never had luck with unetbootin, in fact fails for me more often than it works.

http://www.linuxliveusb.com/
^this is the most reliable tool i have found for windows.

btw the intel 845g is supported by the xorg i915 driver
the error your getting is likely a kernel/mesa/drm bug
m
0
l
a b 5 Linux
March 9, 2012 2:46:06 AM

skittle said:
i have never had luck with unetbootin, in fact fails for me more often than it works.


Really? That's odd. I've never had it not work :??:  I wonder what the reason for the drastically different experiences is?
m
0
l
a b 5 Linux
March 9, 2012 12:46:40 PM

Some USB devices just plain old refuse to work as boot devices, especially older / cheap ones. I'd try with a different USB stick or two and see if the results vary.
m
0
l
!