Sign in with
Sign up | Sign in
Your question

Keyboard not responding after POST

Last response: in Systems
Share
May 23, 2007 2:21:18 AM

I have a little problem when I try to do a fresh install of windows on a newly bought hdd, my keyboard would work at POST so I can still get into BIOS and change the boot hdd order, then once it starts to boot windows from the CD drive and prompt me to press any key to boot my keyboard would stop working until the login screen of windows. There's no option to enable any USB support in BIOS, so I don't quite know where to go from here.

It's happened before but it's been quite long ago so I totally forgot how I got it to work the first time. It's rather frustrating as I just bought a 7800gtx off a mate, and since my old card was a 850xt I had to remove the ATI drivers and install nVidia drivers, and since I've done that I've been getting random stutters playing video and games.

My setup roughly:

ABIT AN8 ultra
2gb RAM
7800GTX (can't see the brand on card)
Antec True Power 480w PSU
4 hdds (3 SATA, 1 IDE)
Logitech G15 keyboard

I suspected it's something to do with power but it's fine in BIOS and once windows is booted up. Hope someone can shed me a light here!
May 23, 2007 2:59:19 AM

Yup. Mpilch nails it again. Your USB keyboard probably came with a ps2 adapter. Use it until the install is complete, make sure USB is enabled in the bios, sometimes the "safe" mode disables the USB ports. Thats about all the info you'll need to get you going.
May 23, 2007 3:03:55 AM

Excellent to have a firm answer so soon! I'm not sure if the G15 came with a PS/2 adapter, as it's 4am and my girl is asleep I'll have to check that tomorrow morning and give the install another go.

Thanks for the swift help, hope it all works :) 
Related resources
May 23, 2007 3:47:18 AM

I don't want to piss on anyones parade here but I have had the same ongoing issue with my Abit AN8 32X since day one (about a year now) and I do have USB options under 'Intergrated Peripherals' in BIOS but changing to OS rather than Auto makes bugger all differance as far as the keyboard and mouse being found by windoze is concerned, I need to use a KVM and for a while I had to use two keyboards (PS2 on the Abit & USB on the ECS) I thought that a powered KVM would sort the problem but nooo I now have a PS2 dongle in the back of the Abit rig into the KVM and while it works most of the time there are still instances where the Abit rig will fire up into windoze but mouse and keyboard don't work, solution unplug dongle wait a few secs & reinsert then mouse and keyboard work like they are supposed to PIA yes but better than continuous reboots, bottom line Abit mobos don't like USB keyboards I reckon, but by all means try the PS2/USB adapter though but that never worked for me.

Good luck and I hope the solution you find is quick, easy & cheap :) 
May 23, 2007 6:25:56 PM

If there is an "enable usb legacy support" option in the bios, use that to enable usb keyboard support from POST to windows takeover. Sometimes you need to update to latest bios on older mobo's. Had the same problem during memtest where i had to connect an old ps2 keyboard to get it out again.Luckily i have a bunch lying around, I'm kind of a packrat :p 
May 23, 2007 8:06:53 PM

:? Huh what?, are you replying to me or the OP?.
May 23, 2007 8:11:51 PM

Mostly to the OP but also a little to you :D  Seriously though, i think i hit the wrong reply button but maybe it's an option you overlooked as to me it was not exactly clear wat that option did untill i looked it up. So if it's of any use feel free to thank me later :wink:
May 23, 2007 8:21:38 PM

Wrong button clicking I can live so no worries there mate but if you reread my post I do mention that I do have USB options under 'Intergrated Peripherals' and on the AN8 32X there is no 'enable usb legacy support' option.
!