Frames skipped while playing video

Hi
With the same pc i could watch HD videos smoothly in windows...
but in linux i have some frame skipping... & the cpu gets hotter...
i tried to install the original nVidia drivers.
I tried VLC.
SMplayer.
Xine.
didn't help.

strangely GNOME MPlayer was difference
i set it to use vdpau (like i did in SMplayer)
i still got frames skipped
but i noticed that the cpu is real cool
& the gpu is getting warm by 5-7 degrees

i say strage because SMplayer is Mplayer
its just a frontend no?

i used "psensor" to check temperature
(btw, is there another app to test temperator? i need something that shows you the temp near the system watch)


anyway - i still got frames skipped...
do you have a suggestion?
i have a 2.2Ghz Core2Duo laptop
1Gb ram
128Mb nVidia card
& in windows it ran HD stuff good...
7 answers Last reply
More about frames skipped playing video
  1. 1.) For vdpau to work you need to make sure you are using the Nvidia propitiatory driver, and not the open source one.
    2.) you need libvdpau and mplayer/vlc need to be compiled with vdpau support. (i think this is default in ubuntu repository)
    to test vdpau:
    mplayer -vo vdpau -vc ffh264vdpau file.mkv 

    3.) yes smplayer is a front end/gui for mplayer.
    4.) you can also enable multithreaded decoding for h.264 videos instead.
    to test regular threaded decoding without vdpau:
    mplayer -lavdopts threads=N file.mkv


    So if your machine meets the above (and it sounds like it mplayer successfully uses vdpau), then I must ask what exactly does 'frame skipping' mean? is it actually dropping frames? or is it due to some post processing? is it just video tearing?

    (ps smplayer and gnome mplayer will both use the same mplayer binary)
  2. skittle said:
    1.) For vdpau to work you need to make sure you are using the Nvidia propitiatory driver, and not the open source one.
    2.) you need libvdpau and mplayer/vlc need to be compiled with vdpau support. (i think this is default in ubuntu repository)
    to test vdpau:
    mplayer -vo vdpau -vc ffh264vdpau file.mkv 

    3.) yes smplayer is a front end/gui for mplayer.
    4.) you can also enable multithreaded decoding for h.264 videos instead.
    to test regular threaded decoding without vdpau:
    mplayer -lavdopts threads=N file.mkv


    So if your machine meets the above (and it sounds like it mplayer successfully uses vdpau), then I must ask what exactly does 'frame skipping' mean? is it actually dropping frames? or is it due to some post processing? is it just video tearing?

    (ps smplayer and gnome mplayer will both use the same mplayer binary)


    i ran the first command & the mkv ran (but not smoothly)
    so i have Nvidia propitiatory driver & vdpau support?

    what is it actually dropping frame?
    when you have fast motion on screen
    or if the camera panning to the sides
    you see that frames are missing... lagging... tearing...
  3. Yes if the command plays back video then it supports vdpau :)

    What video card is this? can you try the command with multithreaded mplayer? this should be enough to playback 1080p 24fps h.264 :o
  4. skittle said:
    Yes if the command plays back video then it supports vdpau :)

    What video card is this? can you try the command with multithreaded mplayer? this should be enough to playback 1080p 24fps h.264 :o


    what number to put under "N"?
    its nVidia GeForce 8400M GS 128Mb Video Card
  5. use threads=#cores, so use N=2. (note that this does not use vdpau, only cpu for decoding)

    For that video card, IIRC for vdpau to work properly you need to change some options:
    check full thread: http://ubuntuforums.org/showthread.php?t=1683875
    specifically the second page has updated information

    Quote:

    1)install CompizConfig Settings Manager (CCSM) from ubuntu repository
    2)check the box "Unredirect Fullscreen Window" under composite settings


    if the above doesnt work, try settings in post #4
    http://ubuntuforums.org/showpost.php?p=10450935&postcount=4
  6. skittle said:
    use threads=#cores, so use N=2. (note that this does not use vdpau, only cpu for decoding)

    For that video card, IIRC for vdpau to work properly you need to change some options:
    check full thread: http://ubuntuforums.org/showthread.php?t=1683875
    specifically the second page has updated information

    Quote:

    1)install CompizConfig Settings Manager (CCSM) from ubuntu repository
    2)check the box "Unredirect Fullscreen Window" under composite settings


    if the above doesnt work, try settings in post #4
    http://ubuntuforums.org/showpost.php?p=10450935&postcount=4


    CompizConfig Settings Manager configs only unity for ubuntu no?
    xubuntu has xfce
  7. no, you can use compiz with any DE but xfce has its own compositor. Did not know you were using xfce :)
    xfce compositor has the analogous option: "display full screen overlay windows directly"

    in xfce "window manager tweaks" menu -> compositor: check option "display full screen overlay windows directly"

    http://docs.xfce.org/xfce/xfwm4/wmtweaks
    http://ubuntuforums.org/showpost.php?p=10531656&postcount=11
Ask a new question

Read More

Video