Sign in with
Sign up | Sign in
Your question

Linux Samba Help

Last response: in Linux/Free BSD
Share
April 5, 2012 9:36:50 PM

Hi, I run a linux fedora 15 samba server. My problem is that any windows 7 machine seems to have a tough time browsing the file share. It takes like 20 - 30 seconds to access the file share or if I want to initiate a new connection that prompts for a username and password. The server seems to perform fine for read and write speeds. It just seems like something is causing it to hang up at the initial share browsing.

smb.conf

[global]
domain master = yes
log file = /home/log/%m.log
netbios name = file server
server string = file server
workgroup = WORKGROUP
os level = 65
security = user
passdb backend = smbpasswd
max log size = 100
domain logons = yes
wins support = yes

[FileServer]
path = /home/data/fileserver/
browsable = yes
writeable = yes

Any input would be helpful

More about : linux samba

a b 5 Linux
April 5, 2012 11:44:40 PM

What's your network look like? Specs on both end?
m
0
l
April 6, 2012 2:52:26 PM

Well normally the server operates with about 10 windows 7 clients.
Even with just only one client accessing the machine, the issue still persists.
The connection would be a 100 megabit Ethernet with a basic router setup.
The server is an am3 x250 Athlon 3.0 GHZ x2 with 4 gb of ddr3 ram, with an asus m4a7lt-le board. The other machine accessing it is an am3 x250 Athlon 3.0 Ghzx2 with ddr2 ram. Ive narrowed it down to just the machine itself. from what ive read NetBIOS can be an issue it seemed like fixing it with wins support on the linux machine or if you disable the web client service on windows clients.
Ive tried the setting up wins on my samba server, not sure if I have it working properly because apparently that is supposed to fix it. I haven't tried disabling the web client service but I prefer to keep that running. Its a pain to interrupt all the clients on there pc's to disable the service.
m
0
l
!