Sign in with
Sign up | Sign in
Your question

No bootable device after installing Fedora

Tags:
Last response: in Linux/Free BSD
Share
Anonymous
May 3, 2012 2:40:31 AM

Hello, my name is Rich and I am looking for some help.

I've been running a dual-boot of Windows 7 and a Linux operating system for a while now. I've been changing the Linux one every now and then to see what they are like. I've been using Linux more and more, and today I decided I would try Fedora.

I created a bootable USB flash drive with the Fedora live cd. It worked fine, and I decided to install it to my hard drive. This is where the problems started. During the screen where you are asked for what partition you would like to install the OS, I decided to erase everything, and just have Fedora. Everything seemed to be fine, I kept pressing next until it began to install. There were no errors and it completed the installation asking me to reboot.

When I rebooted my computer I changed the BIOS settings to disable USB booting, so it would boot from my hard drive instead. But when I started my computer again, I got an error saying that no bootable devices could be found, and to insert a disk and press any key.

I guessed that I must have missed something in the installation or deleted something I shouldn't have. So I re-installed Fedora, this time following a tutorial on my phone, but the error message came up again.

The next step I took was to boot using the USB into the live cd mode, and tried to download Ubuntu. I figured it would have the simplest installation process and I would be able to rectify my mistakes. Unfortunately, I only have about 400MB of space allocated to me in this live cd mode, so the download failed.
I decided I would try to download PuppyLinux as its much smaller, I successfully downloaded it, but when attempting to burn the ISO to disk, Fedora crashes. Turns out theres a bug with it...

I went to my university library to use the computers there, and try and download some software that might help (one of those "Ultimate boot cds"), but it turns out the university computers are more restricted than I thought, and you can't have large amounts of files.

So, I'm kind of stuck with a computer that only works if I boot in live cd mode, which isnt too bad, as I can still do some basic things, and access the Internet, but I have exams over these next two weeks and I really need to get this fixed. I have a folder back home with all my drivers and OS discs and documentation etc but I cant get hold of them until I finish this semester.

Any advice on how I could fix this would be very much appreciated.

Thank you for reading,

Rich
May 3, 2012 7:05:43 AM

Hello Rich,

it sounds like your first order of business is to acquire the media to install the operating system. Did you also wipe out your recovery partition on the computer? If the recovery partition is still there you can restore the laptop to factory defaults by pressing the appropriate key during POST. if you have restore CDs that came with your computer you can use those to get up and running again too.

I've had some trouble installing from usb flash drives too. I find it works best to burn the ubuntu ISO CD to CD Media and not DVD media. For some reason if the ubuntu live CD gives you trouble installing you can use the Alternate text mode CD installer instead.

You didnt mention what version of fedora you tried to install. Fedora 16? Or a developmental version of Fedora 17? The release candidate should be out in a few days now.
Related resources
!