Sign in with
Sign up | Sign in
Your question
Closed

8 Blue Screen Errors in a week, losing my mind

Last response: in Windows 7
Share
August 7, 2011 4:51:08 PM

You might want to get comfortable, this one's a doozy.

I built this computer last Saturday, it was my first build. On the first day I got an error that I think happened when I was updating Windows. I figured it was normal so I moved on.

Later, I downloaded Left 4 Dead 2 to play on Steam, and I played it with my friend for an hour, then I played single-player for an hour and had no problems. The next day I played again but I got a blue screen within five minutes. Tried again and got the error again. I downloaded the demo for Arma 2 and could play that for an hour just fine. I downloaded Fallout: New Vegas and played for an hour then got blue screen. I played it again later and blue screened after just 10 or so minutes. I verified the integrity of the installs but the errors still roll in.

I tried looking up a lot of the problems and solutions online first, and many of them pointed to having bad RAM. So I took out one of my sticks and memtested the other all night long. It was at I think 950% with 0 errors when I went to bed. In the morning though, my computer was turned off to my dismay, and it turns out it recovered from an error again. Now I don't know how to check if my RAM ended up having an error or not because memtest closed. I'm planning on testing the other stick after this but I figure I'll ask you guys first.

Here's another thing I forgot to mention. When I first got Windows 7(64-bit) intsalled, I went to my computer > properties and it was telling me "Installed Memory (RAM): 4.00 GB (2.00 GB usable)." In the morning this problem fixed itself, then it happened again, then I manually fixed it by checking resource center and msconfig, then my computer crashed. Not sure if that helps the case that somehow the RAM is screwed up.

One last thing I should ask just to make sure since I'm still new at this. My motherboard is an ASRock 970 extreme4, and my RAM is G.Skill 2x2gb F3-10600CL8D-4GBHK. I had my parts checked for compatibility on eggxpert, but I guess I should run it by you guys just in case, because on ASrock's website that RAM is not on the memory support list. Is that really a problem?

Oh, and just to be safe, I did a virus scan with avast! and found no problems, and Malwarebytes Anti-Malware also found no problems.

I'm going to post my dump files here now. If there is a better place to upload than SkyDrive, or if the link doesn't work, let me know. https://skydrive.live.com/#!/?cid=bc0c02dcf6381d40&sc=documents&uc=1&id=BC0C02DCF6381D40!161!cid=BC0C02DCF6381D40&id=BC0C02DCF6381D40!161

I really really hope you guys can figure this one out. I would be eternally grateful.
a c 209 $ Windows 7
August 7, 2011 5:50:02 PM

The first thing to do is that if you've tweaked any of the settings, and especially if you've played with any of the clock frequencies, to reset everything back to the default values and try again.

Another thing to watch out for is that the CPU is dissipating heat properly. The CPU will shut down if it overheats, and that can happen if, for example, if you didn't get a good bond with the thermal paste between the CPU and the heatsink.
Score
0
August 7, 2011 6:44:51 PM

I just played L4D2 for an hour, surprisingly no blue screens, but I played in window mode to check the heat on the CPU using HWMonitor, and it never went over 44 degrees. So I don't think that's the problem. Also, I didn't overclock anything or change any frequencies as far as I'm aware. I'm gonna test my other RAM stick now and see what's up with that one.
Score
0
Related resources
a b $ Windows 7
August 7, 2011 6:46:05 PM



This might be one of those occasions where it's helpful to press the Windows key and R together then type msconfig into the Open box and hit Enter. Click teh BOOT.INI tab and press the Advanced button. In the NumProc box, scroll to tell the system you CPU has four courses, click Apply and OK your way out. Restart and when the system comes back, tick the "Don't show this message again" and hit Enter.


Score
0
August 8, 2011 1:16:52 AM

After testing the second memory stick up until 500+%, I decided to try L4D2 again and it played for 2 hours without a problem. I pushed my luck and played Fallout for about a half hour before stopping. I did follow saga lout's advice and checked the 4 core box, so maybe that solved the problem. I'm going to put the other stick back in and see if everything holds up.
Score
0
August 8, 2011 2:00:49 AM

This is just weird. I put both sticks in, and not even 5 minutes into left 4 dead 2 I got an "IRQL not less or equal" blue screen error. For some reason it won't show up in my dump folder. Now I'm just desperate for an answer. Do you think something is wrong with the RAM slot on the motherboard for it to mess up only when 2 sticks are in it? Also If someone can tell me what the dump files I posted earlier actually mean, I would be really thankful.
edit: forgot to mention that my computer is once again saying "4.00 GB (2.00 GB usable)." I have no idea.
Score
0
a b $ Windows 7
August 8, 2011 6:40:43 AM



It seems the system can see two 2Gb sticks but only one of them is working. Since things went downhill again when you put that stick back in, its problem must have shown up oin the extremely long test process, towards the end of it.


Score
0

Best solution

a b $ Windows 7
August 8, 2011 3:20:49 PM

Sounds like you have not configured your ram in the bios. Manually set the speed, timings and voltage in the bios according to the specs on the sticker.
Share
a b $ Windows 7
August 8, 2011 6:33:00 PM

It might be possible that you have a faulty slot on the motherboard as well
Score
0
a b $ Windows 7
August 8, 2011 7:35:54 PM

AntiZig said:
It might be possible that you have a faulty slot on the motherboard as well






Quite possible - a quick swap round of the sticks will settle that one.

Score
0
August 8, 2011 9:19:36 PM

I think we found the culprit. GeekApproved was right, the settings in the BIOS were wrong. Instead of 8-8-8-21 they were 9-9-9-24, and I also set the frequency to DDR3-1333 and set the voltage to 1.500V. So far I've been able to play ARMA 2 and L4D2 with no problems. Oh, and before I read that post, I put the RAM in slots A2 and B2 just for fun and it still didn't work, so I think the problem has been solved. If I have another problem I'll post it here, but for now I think it's okay. Many thanks to all you guys for helping me. Oh, and I'll wait just a little while before giving out best answer, just in case.
Score
0
a c 209 $ Windows 7
August 9, 2011 2:38:43 AM

That's strange - DRAM timings are encoded into the DRAM chips themselves and the motherboard is supposed to adjust itself to them by default. That was one of the issues I had in mind when I advised you to make sure all of the motherboard settings were at their default values.
Score
0
a b $ Windows 7
August 9, 2011 2:22:23 PM

sminlal said:
That's strange - DRAM timings are encoded into the DRAM chips themselves and the motherboard is supposed to adjust itself to them by default. That was one of the issues I had in mind when I advised you to make sure all of the motherboard settings were at their default values.


Default values almost never work properly. Nearly any 1155 board I have worked with defaults to the wrong speed and timings and sometimes voltage.

Never advise someone to use default or "auto" when it comes to memory settings.
Score
0
a c 209 $ Windows 7
August 9, 2011 3:55:52 PM

geekapproved said:
Default values almost never work properly. Nearly any 1155 board I have worked with defaults to the wrong speed and timings and sometimes voltage.
What that tells me is to avoid those boards like the plague.
Score
0
a b $ Windows 7
August 9, 2011 6:43:41 PM

Then you would be avoiding all of them.

Nearly all Intel and AMD boards default to 1333 if you insert 1600 ram.

Even the s775 DDR2 boards incorrectly defaulted all DDR2 memory to 1.8v, even though many sticks were 1.9, 2.0, 2.1, 2.2v. If you failed to manually set them you wouldn't even be able to load windows in most cases, you would get bsod's and stop errors.

My board defaulted my 1600 memory to 1066.

So just take 10 seconds to make sure the bios is setup right according to the sticker on the ram, and then you don't have to avoid boards like the plague.

This is the number one reason for all the BSOD posts on this forum, neglecting to correctly set your ram speed, timings and voltage according to the sticker.
Score
0
August 9, 2011 9:39:16 PM

Best answer selected by CoolDogsOnly.
Score
0
a c 209 $ Windows 7
August 9, 2011 9:54:43 PM

geekapproved said:
Nearly all Intel and AMD boards default to 1333 if you insert 1600 ram.
I can't speak for the AMD chips, but for at least some of the Intel CPUs that's the correct behaviour since, for example, that's the Intel-specified maximum spec for a stock Core i7 920. When RAM defaults to a slower speed it may hurt performance slightly (and let's not forget that RAM speed has one of the smallest impacts on overall performance), but it won't cause instability, and therefore it's a good first step when diagnosing crashing systems.
Score
0
a c 402 $ Windows 7
August 9, 2011 11:46:22 PM

This topic has been closed by Area51reopened
Score
0
!