Sign in with
Sign up | Sign in
Your question

Access Denied on installing Hardware

Last response: in Windows XP
Share
January 2, 2009 4:14:07 AM

I just reinstalled windows, and was setting up my devices. Two devices are giving me problems, this thread is about one of them, because the problems with them are entirely different.

[EDIT: Can't take screenshot, for some reason there isn't any MSPaint or Calculator in my Windows XP]
Quote:
There was a problem installing this hardware

Audio device on high definition audio bus

An error occered during the installation of this device

Access is Denied


Windows locates the drivers, but just at the end of the installation, I get this message. In the device manager, 'Audio device on high definition audio bus' is located under Sound, Video & Game controllers, with a 'speaker' icon on it's left which has a yellow exclamation mark (will post screenshot asap)

I've tried uninstalling, reinstalling the Realtek Audio Drivers, but still I get this error. I had backed up all my drivers before reinstalling windows. Even if I try to install it from there, the error pops up. I have no audio in my PC. I am the admin.
Any help appreciated
Thanks


EDIT 2: I was installing AVG, and this error came:

Quote:
Local machine: installation failed
Installation:
Error: Action failed for file avgfwfd.inf: file registration....
AVG Firewall NDIS driver installation failed.
Error 0x80070005: Couldn't install the network component. - Possible cause: Access is denied.


HALP!
January 2, 2009 6:11:18 AM

Make sure the latest drivers for your chipset are installed and that there isn't another firewall blocking the installation of these items. (nVidia chipsets usually had a firewall with the software package)
January 2, 2009 6:15:30 AM

Quote:
that there isn't another firewall blocking the installation of these items. (nVidia chipsets usually had a firewall with the software package)

How do I do this?
Related resources
January 2, 2009 6:46:27 AM

EDIT: The Audio problem has bees solved, but not the AVG one. Need help on that.
September 12, 2012 8:44:30 AM

phoenixankit said:
I just reinstalled windows, and was setting up my devices. Two devices are giving me problems, this thread is about one of them, because the problems with them are entirely different.

[EDIT: Can't take screenshot, for some reason there isn't any MSPaint or Calculator in my Windows XP]
Quote:
There was a problem installing this hardware

Audio device on high definition audio bus

An error occered during the installation of this device

Access is Denied


Windows locates the drivers, but just at the end of the installation, I get this message. In the device manager, 'Audio device on high definition audio bus' is located under Sound, Video & Game controllers, with a 'speaker' icon on it's left which has a yellow exclamation mark (will post screenshot asap)

I've tried uninstalling, reinstalling the Realtek Audio Drivers, but still I get this error. I had backed up all my drivers before reinstalling windows. Even if I try to install it from there, the error pops up. I have no audio in my PC. I am the admin.
Any help appreciated
Thanks


EDIT 2: I was installing AVG, and this error came:

Quote:
Local machine: installation failed
Installation:
Error: Action failed for file avgfwfd.inf: file registration....
AVG Firewall NDIS driver installation failed.
Error 0x80070005: Couldn't install the network component. - Possible cause: Access is denied.


HALP!

!