Sign in with
Sign up | Sign in
Your question

Slow Moving and Copying Files

Last response: in Windows XP
Share
January 12, 2009 1:59:45 AM


I have a Dell Dimension 4600 running XP. I also have a Seagate 250 gig external hard drive where I keep music, photo, and movie files. Lately, I began to get delayed write errors when copying/moving files from the c drive to my external (g) drive. I looked online for some fixes, went into the properties of both drives, and disabled the cache (whatever that means!). Now, I'm not getting the delayed write errors, but the moving/copying of large files is taking much longer that it was before. Copying a 1 gig folder will now take up to 5 minutes, when before any of these issues started, it used to take a few seconds. I ran Sea Tools and did a chkdsk of that drive and nothing. Any ideas what could be going on? Thank you all in advance for your replies.
January 12, 2009 12:01:57 PM

How much free space? Do you defrag?
January 12, 2009 12:18:22 PM

disabled cache is what is causing your slow down.

Delayed write errors, is caused when the cache is enabled windows will report that the file has been copied when infact its only been copied to the cache(hence the slower speed when its disabled), the delayed write means exactly what it says the write has been delayed and therefore not been copied to the drive correctly, this can happen for a number of reasons.

You may still recieve the delayed write error even when the cache is disabled because these errors are not always cleared correctly(windows will report the error whenever the drive is plugged in)

a few things to do to ensure its not a cause of your HDD, run chkdsk and Defrag on both drives.

To prevent this error in the future always use the "Safely Remove hardware feature" in windows, and never unplug the drive unless the 'busy' light is off and has been off for a minute or so.
Related resources
January 12, 2009 12:19:59 PM

i forgot to say, if chkdsk reports bad sectors you will need to replace the drive.
January 12, 2009 12:27:47 PM

Thanks Flakes for pointing out the cache problem... maybe I should read more carefully next time ;) 
!