Sign in with
Sign up | Sign in
Your question
Closed

Fedora 17, Virtualbox & multi-monitor

Last response: in Linux/Free BSD
Share
June 17, 2012 7:54:50 AM

Issue 1:
Well I wanted to mount shares
  1. E:/Nexus
  2. E:/Download
to a Fedora 17 guest. I succeeded by modifying my /etc/fstab:

  1. #
  2. # /etc/fstab
  3. # Created by anaconda on Sat Jun 16 19:29:14 2012
  4. #
  5. # Accessible filesystems, by reference, are maintained under '/dev/disk'
  6. # See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
  7. #
  8. /dev/mapper/vg_katyrvm-lv_root / ext4 defaults 1 1
  9. UUID=1c638e90-e6d7-4fcf-ac85-d415dd8d68fc /boot ext4 defaults 1 2
  10. /dev/mapper/vg_katyrvm-lv_swap swap swap defaults 0 0
  11. Nexus /home/strayfire/Documents/Nexus vboxsf defaults 0 0
  12. Download /home/strayfire/Documents/Download vboxsf defaults 0 0


But strangely I get this error on boot:



If I press Control-D it works just fine... how strange.

Issue 2:
Multi-monitor in LXDE under Virtualbox.

I get two identical displays (mirror). I want them to display two separate things each. Eg. 1 full screen Firefox + 1 full screen LibreOffice (extended/span mode) rather than both screens showing the same Firefox window.

I'm assuming LXdisplay won't help me here...

FYI: LXdisplay detects them as two separate displays, which is nice because Fedora 15 doesn't, it sees them as one and the same.

So I changed my Xorg.conf from

  1. # VirtualBox generated configuration file
  2. # based on /etc/X11/xorg.conf.
  3.  
  4. Section "Monitor"
  5. Identifier "Monitor[0]"
  6. ModelName "VirtualBox Virtual Output"
  7. VendorName "Oracle Corporation"
  8. EndSection
  9.  
  10. Section "Device"
  11. BoardName "VirtualBox Graphics"
  12. Driver "vboxvideo"
  13. Identifier "Device[0]"
  14. VendorName "Oracle Corporation"
  15. EndSection
  16.  
  17. Section "Screen"
  18. SubSection "Display"
  19. Depth 24
  20. EndSubSection
  21. Device "Device[0]"
  22. Identifier "Screen[0]"
  23. Monitor "Monitor[0]"
  24. EndSection


to

  1. # VirtualBox generated configuration file
  2. # based on /etc/X11/xorg.conf.
  3.  
  4. Section "Monitor"
  5. Identifier "Monitor[0]"
  6. Option "Primary" "false"
  7. ModelName "VirtualBox Virtual Output"
  8. VendorName "Oracle Corporation"
  9. EndSection
  10.  
  11. Section "Monitor"
  12. Identifier "Monitor[1]"
  13. Option "Right" "Monitor[0]"
  14. Option "Primary" "False"
  15. ModelName "VirtualBox Virtual Output"
  16. VendorName "Oracle Corporation"
  17. EndSection
  18.  
  19. Section "Device"
  20. BoardName "VirtualBox Graphics"
  21. Driver "vboxvideo"
  22. Identifier "Device[0]"
  23. VendorName "Oracle Corporation"
  24. EndSection
  25.  
  26. Section "Screen"
  27. SubSection "Display"
  28. Depth 24
  29. Modes "1920x1080"
  30. Virtual 3840 1080
  31. EndSubSection
  32. Device "Device[0]"
  33. Identifier "Screen[0]"
  34. Monitor "Monitor[0]"
  35. EndSection


based on this advice:
http://en.gentoo-wiki.com/wiki/X.Org/Dual_Monitors

but got absolutely no response from Fedora.

Do I need to configure Xinerama or something apart from the regular?

Best solution

a b C Monitor
June 17, 2012 7:59:13 AM
Share
June 17, 2012 8:44:54 AM

The problem doesn't seem to come up now. Very strange... :/  No matter...

Now I need to amend the dual-display problem. It's difficult even when I'm not in a VM. Never managed to solve it.

Edit: The installation exploded somehow. Now it shows a similar error message despite the measures I have taken...
Score
0
Related resources
June 17, 2012 2:36:32 PM

Just so I understand here, do you have two physical displays which you're trying to get VB to use when you run in full screen mode or do you have two virtual displays on one larger screen?

Score
0
June 18, 2012 3:02:46 AM

I can get VB to use two physical screens but they show the same thing. I want them to be able to show seperate things.
Score
0
June 18, 2012 1:11:00 PM

Best answer selected by amdfangirl.
Score
0
June 18, 2012 1:11:02 PM

This topic has been closed by Amdfangirl
Score
0
!