Sign in with
Sign up | Sign in
Your question

Can't install Server 2008 w/ AMD 780V onboard

Last response: in Windows Vista
Share
February 11, 2009 4:56:54 PM

This site doesn't seem to have a category for server products. Seeing as Server 2008 seems to be a derivative of Visa, I thought I'd ask here.

I also posted at the Microsoft Technet forum yesterday, but receive no responses.

I'm building a small machine with an M3A78-CM motherboard (AM2), 8-GB of ECC RAM, and two WD Raptor 300-GB drives.

If I run the two 300-GB drives in RAID-1 mode (using the onboard controller), I can't get the O/S to install. I am able to load the drivers, format the volume, copy/expand the files, load the network drivers, etc. But then the machine reboots, looks like it is going to resume setup, I get a mouse cursor on the screen, and then the machine reboots again.

I disabled auto-restart on failure and got a 0xC0000001 message. But I've also received a message along the lines of "something connected to the system is not working" (sorry, not verbatim).

None of this happens when I disable the motherboard's RAID and just run the drives as plain SATA. And a 3Ware 9650SE in Raid-1 also allows me to install the O/S no problem.

So it seems to be a problem with RAID on the AMD 780V chipset (which, BTW, appears to be based on Promise stuff as the built-in RAID configuration utility looks just like one from a Promise controller I have).

I'd rather not have to use the 3Ware card.

I have upgraded to the latest motherboard BIOS (1201) and I have tracked down the latest RAID drivers I can find. Here are the files for the RAID drivers I have:

03/17/2008 07:40 AM 9 ahcix64s
09/12/2008 10:43 PM 32,895 ahcix64s.cat
09/09/2008 12:55 PM 14,932 ahcix64s.inf
09/16/2008 11:42 AM 76,800 ahcix64s.msi
09/10/2008 10:07 AM 224,272 ahcix64s.sys
09/15/2008 05:46 PM 881 readme.txt

I'm not sure if there are later RAID drivers or not. I certainly can't find any. I found the above drivers at this site:

http://files.3dnews.org/pub/drivers/ati/

Not sure how to debug this one further. Any ideas?
July 21, 2009 5:12:54 PM

cgallery - Have you found a 64Bit RAID driver for server 2008? I havn't! Thank you...Vaughn
m
0
l
July 21, 2009 7:06:52 PM

Sorry, I have not. The project went to the back burner and I figured the next time I tried, I'd be able to find an update. Sounds like that isn't the case, from what you're telling me. That sucks.
m
0
l
Related resources
October 5, 2009 12:45:50 AM

I have spent 24 hours trying everything I know to get Windows 7 to install on a Asus M4A78-EM board with no luck. If AMD really wants to have people use their products they really need to get on the ball and get some drivers that work out here. I have been a AMD users for quite a few years. At this point I am really ready to bail out on AMD and go strickly Intel. I am getting tried of AMD's excuse for not providing driver for their hardware. Don't release new stuff if you don't have the drivers for them.
m
0
l
October 5, 2009 2:34:17 AM

cgallery - The Vista 64Bit RAID driver installs and works for server 2008 R2 (but not for server 2008)! Go Figure...Vaughn !:-)

PS - Server 2008 R2 is the released update to server 2008, just FYI.
m
0
l
October 5, 2009 3:26:14 AM

I tried that driver and I still get the BSOD when I can see one. Other than that it is just a blank screen.
m
0
l
October 5, 2009 3:57:28 PM

Retired_MSgt said:
I tried that driver and I still get the BSOD when I can see one. Other than that it is just a blank screen.



Retired_MSgt - Your motherboard has a different Northbridge Chipset (viz. AMD 780G) than the Northbridge Chipset used by me or cgallery (viz. AMD 780V). Possibly this is the problem. I don't know. Just FYI, I installed Raid and Win 7, 32 bit and 64 bit, using 32 bit and 64 bit Vista Raid drivers on a Gigabyte MOBO. Also I have a very different MOBO than you; I now have a Gigabyte MOBO and not a ASUS MOBO! Possibly this is the problem. Before I RMAed my ASUS M3A78-CM motherboard, I had Problems with RAID and Server 2008; the Gigabyte MOBO with the 780G Northbridge Chipset worked much better with the Vista RAID drivers (Server 2008 R2 64 bit and Win 7 32 bit and 64 bit) .

Good luck...Vaughn !:-)

PS - When I was trying to install 64 bit Server 2008 with RAID, ASUS tech support said that 'my raid installation problem' was with the AMD chipset drivers (NOT their MOBO!) Hmmmmmmmmmm! I hope that all of this helps in some way. Please recall that the initial problem that cgallery and I had was installing Raid and Server 2008 with the AMD 780V chipset on the ASUS M3A78-CM motherboard.
m
0
l
October 6, 2009 4:46:57 PM

OK, this is just a quick post to let everyone know that I have found a work around for installing Windows 7 32bit and 64bit on a RAID 1. My System is a Asus M4A78-EM with AMD 920 proc and 4x1GB memory. I will post more specific information once I am able to write down all the steps. So Bare with me a little while. If anyone knows of other sites where members have had a problem install Windows 7, please let me know and I will post my notes there. Hopefully I will the information posted today.
m
0
l
October 6, 2009 6:04:44 PM

OK first here is my system spec
Asus M4A78-EM
AMD 920 Processor
4x1 GB’s of memory
Sony DVD DL R/W
Samsung DVD DL R/W
2 250 GB’s Maxtor SATA hard Drives
2 80 GB’s Seagate hard Drives
Hauppauge 2250 HVR card
Apevia X-QPack 2 Case

PLEASE READ THROUGH ALL THE STEPS BEFORE STARTING. Because I had to do this several times on the 64bit installation to get it right. Also please feel free to point out any steps you added or did not do so others may hopefully be able to install Windows 7.

Ok let me start off by saying I was ready to give up on ever buying AMD or ASUS products again. Especially, since ASUS web site saying their boards is Windows 7 ready. The truth may be that they are ready but NOT easily ready to install Windows 7 on them. I spend almost 3 days working on this project and I have finally figure out a way to install both the 32bit and 64bit of Windows 7 Ultimate on a RAID 1. I do not know if these steps will work on any other board or with any other RAID setup.

Now you will notice that I have 4 hard drives listed. The reason for that is I discovered these steps while trying to install Windows 7 32bit. I did not want to destroy what I had done when I attempted these steps on a Windows 7 64bit install.

After many BSOD and thousand of very choice words I used the following steps. Now you may or may not need to do some of them but these work for me. Also if after reading this you have questions please post them here so I can try and answer them for everyone.

On the 32bit installation

I first configured the bios so that sata channels 1-4 were set to RAID and 5and 6 set to IDE.

Then is plugged in the hard drives and using the onboard RAID configuration tool, configured a RAID 1
.
After that was recognized, I then unplugged both drives from channel 1 and 2 and connected only 1 to channel 4. I left the RAID turned on.

I then proceeded to install Windows 7 Ultimate 32bit. I had previously downloaded all the latest drivers and programs from ASUS website. During the installation of the 32bit version, I did NOT install any additional drivers. I did a complete installation of all programs and updated the drivers and Windows update.

Once this was completed, I also install RAIDXpert2.4.1540.4_X2. I used this to view and work with the RAID setup in Windows.
Then I first plugged the one drive that I had installed the O/S to channel 1. Upon booting the built in RAID controller showed the array as critical but continue to post. Once back into the O/S I made sure I could see everything. With that completed, I powered down and plugged the second drive into Channel 2.

Upon rebooting and going into RAIDXpert, the second drive showed up as a JBOD drive. I just deleted that and a rebuild kicked off. Once the rebuild completed everything is running fine.

Now for the 64bit version. Most of the steps are the same expect for what is below.

After creating the RAID, you will have to go back into the bios and set ALL the SATA controller channels to IDE.

I also again only plugged in one drive to channel 5.

During the beginning of the installation I had the following files on my USB key.

Ahcix64s.cat
Ahcix64s.inf
Ahcix64s.sys
Amdsata.cat
Amdsata.inf
Amdsata.sys
Amdxata.sys

I had to uncheck the hide files button, but I choose to install all of the inf files it provided me.

The installation went on without any problems. Again I did a completed installation and update.

Once that was completed, I powered down and went back into the bios and turn on RAID for channels 1-4. I STILL HAD THE DRIVE PLUGGED INTO CHANNEL 5 AT THIS POINT.

I powered on the system and let it completely boot up. Once that was done, I powered down, plugged the one drive into channel 1 and powered on again.

I had to reboot twice in order to see the drive. I receive a no boot device found on the try. But on the second it saw the drive.

Again I let it completely boot up. I powered down one more time, this time I plugged in the second drive. Powered on again. Using RAIDXpert, I saw both drives with the second as a JBOD, again I deleted it and the rebuild started. Once the rebuild was completed everything ran fine.

adobe win7 32bit
Aisuite V1.05.32 07202009
AMD Chipset Program Driver WHQL V3.0.732.0 07312009
AMD HDMI Driver V5.10.0.5880 08072009
AMD VGA Driver V8.632.0.0 07222009
ASUS AMD Cool&Quiet utility V 2.18.01 07222009
ASUS EPU-4 Engine V1.00.29 07082009
ASUS Express Gate Installer V1.4.10.4 07222009
ASUS PC Probe II V1.04.75 07272009
ASUS TurboV V1.00.41 07312009
ASUS Update V7.17.02 Install Program 07302009
Hauppauge
RAIDXpert2.4.1540.4_X2
Realtek HD Audio Driver v5.10.0.5859_6.0.1.58 07272009
Realtek RTL8111BC & RTL8112L 10_100_1000M LAN Driver V7.3.522.2009 07302009
9-9_vista64_win7_64_dd_ccc_wdm_enu
m
0
l
October 7, 2009 4:03:05 PM

Retired_MSgt - Congrats on your successful installation of Win7 with RAID on your MOBO! You sure did have to go through 'heroics'!!!

If you want more visibility for your effort, you may consider starting another thread with key words in the title such as RAID, Asus M4A78-EM and/or Windows 7 and include your post that you have here...Vaughn !:-)
m
0
l
October 7, 2009 7:45:21 PM

Thank I think I will do that.
m
0
l
!