Low Quake2 FPS on Fast PC........

Archived from groups: alt.games.quake2 (More info?)

I have an Athlon 2700+, ATI 9600SE, Windows XP, and a gig of ram. My
Quake2 framerate is somewhere around 25-30 fps. Any Ideas on why its so
low?

Thanks,

JT
21 answers Last reply
More about quake2 fast
  1. Archived from groups: alt.games.quake2 (More info?)

    "Goodner79" <jtg30@hotmail.com> schrieb im Newsbeitrag
    news:1106723388.819670.33270@z14g2000cwz.googlegroups.com...
    > I have an Athlon 2700+, ATI 9600SE, Windows XP, and a gig of ram. My
    > Quake2 framerate is somewhere around 25-30 fps. Any Ideas on why its so
    > low?
    >
    > Thanks,
    >
    > JT
    >
  2. Archived from groups: alt.games.quake2 (More info?)

    maybe your cl_maxfps is set to 30.
    try adding "set cl_maxfps 200" or higher to your config; or type "cl_maxfps
    200" in the console.


    "Goodner79" <jtg30@hotmail.com> schrieb im Newsbeitrag
    news:1106723388.819670.33270@z14g2000cwz.googlegroups.com...
    > I have an Athlon 2700+, ATI 9600SE, Windows XP, and a gig of ram. My
    > Quake2 framerate is somewhere around 25-30 fps. Any Ideas on why its so
    > low?
    >
    > Thanks,
    >
    > JT
  3. Archived from groups: alt.games.quake2 (More info?)

    McGrandpa wrote:
    > "Goodner79" <jtg30@hotmail.com> wrote in message
    > news:1106723388.819670.33270@z14g2000cwz.googlegroups.com
    > > I have an Athlon 2700+, ATI 9600SE, Windows XP, and a gig of ram.
    My
    > > Quake2 framerate is somewhere around 25-30 fps. Any Ideas on why
    its
    > > so low?
    > >
    > > Thanks,
    > >
    > > JT
    >
    > You have just about got to be in software mode for that rig to go so
    > slow! Have you checked the console to see any errors? Like possibly

    > the game dumping OGL for software instead?
    > McG.

    Im not in software mode, I have it set for GL and my maxfps is set at
    the default of 90. I can tell its in GL mode because the graphics look
    good they are just slow. It is easy to tell when its in software mode
    becasue of the poor quality of the graphics. I have the latest drivers
    for my video card from the ATI site too.

    Any other ideas?

    Thanks,

    JT
  4. Archived from groups: alt.games.quake2 (More info?)

    "Goodner79" <jtg30@hotmail.com> wrote in message
    news:1106723388.819670.33270@z14g2000cwz.googlegroups.com
    > I have an Athlon 2700+, ATI 9600SE, Windows XP, and a gig of ram. My
    > Quake2 framerate is somewhere around 25-30 fps. Any Ideas on why its
    > so low?
    >
    > Thanks,
    >
    > JT

    You have just about got to be in software mode for that rig to go so
    slow! Have you checked the console to see any errors? Like possibly
    the game dumping OGL for software instead?
    McG.
  5. Archived from groups: alt.games.quake2 (More info?)

    "Goodner79" <jtg30@hotmail.com> wrote in message
    news:1106793785.137522.205990@f14g2000cwb.googlegroups.com...
    >
    >
    > Any other ideas?
    >
    > Thanks,
    >
    > JT
    >


    I had this problem once when I first moved to win xp. But I cannot for the
    life of remember what the fix was. Just keep checking back here, I will
    think of it sooner or later and post. It almost came to me this morning,
    but then slipped away again.

    --

    Margolis
    http://web.archive.org/web/20030215212142/http://www.agqx.org/faqs/AGQ2FAQ.htm
    http://www.unrealtower.org/faq
  6. Archived from groups: alt.games.quake2 (More info?)

    > "Goodner79" <jtg30@hotmail.com> wrote in message
    > news:1106793785.137522.205990@f14g2000cwb.googlegroups.com...
    > >
    > >
    > > Any other ideas?
    > >
    > > Thanks,
    > >
    > > JT
    > >
    >
    >


    ahh, I think I got it. Run the game in win95 or 98 mode. Right click on
    the quake2.exe file and select the "Compatibility" tab and put it at
    "windows 98/ windows me"

    --

    Margolis
    http://web.archive.org/web/20030215212142/http://www.agqx.org/faqs/AGQ2FAQ.htm
    http://www.unrealtower.org/faq
  7. Archived from groups: alt.games.quake2 (More info?)

    "Goodner79" <jtg30@hotmail.com> wrote in message
    news:1106793785.137522.205990@f14g2000cwb.googlegroups.com
    > McGrandpa wrote:
    >> "Goodner79" <jtg30@hotmail.com> wrote in message
    >> news:1106723388.819670.33270@z14g2000cwz.googlegroups.com
    >>> I have an Athlon 2700+, ATI 9600SE, Windows XP, and a gig of ram. My
    >>> Quake2 framerate is somewhere around 25-30 fps. Any Ideas on why its
    >>> so low?
    >>>
    >>> Thanks,
    >>>
    >>> JT
    >>
    >> You have just about got to be in software mode for that rig to go so
    >> slow! Have you checked the console to see any errors? Like possibly
    >
    >> the game dumping OGL for software instead?
    >> McG.
    >
    > Im not in software mode, I have it set for GL and my maxfps is set at
    > the default of 90. I can tell its in GL mode because the graphics look
    > good they are just slow. It is easy to tell when its in software mode
    > becasue of the poor quality of the graphics. I have the latest drivers
    > for my video card from the ATI site too.
    >
    > Any other ideas?
    >
    > Thanks,
    >
    > JT

    Not a one. I'm stumped there. try starting it with NO .cfg files (just
    move em all to a temp place). Sometimes there will be something in your
    \baseq2\config.cfg or autoexec.cfg that makes odd changes. Q2 will
    generate a new default config.cfg when it starts up. Most all the
    problems I'd ever had with Q2 were in the .cfg files I'd write.
    McG.
  8. Archived from groups: alt.games.quake2 (More info?)

    OK if I select run in 256 colors I can get it to 74 frames per second
    and it doesn't matter what resolution I set it for in the game. Always
    74 fps. I have max setting or lowest settings still 74 though. That
    isnt too bad but I dont recall having to keep windows 98 in 256 color
    mode back in the day to play quake2. And I had far less of a machine
    and still got over 100 fps.

    I have CL_Maxfps at 200

    Any other suggestions?

    Thanks JT


    Margolis wrote:
    > > "Goodner79" <jtg30@hotmail.com> wrote in message
    > > news:1106793785.137522.205990@f14g2000cwb.googlegroups.com...
    > > >
    > > >
    > > > Any other ideas?
    > > >
    > > > Thanks,
    > > >
    > > > JT
    > > >
    > >
    > >
    >
    >
    > ahh, I think I got it. Run the game in win95 or 98 mode. Right
    click on
    > the quake2.exe file and select the "Compatibility" tab and put it at
    > "windows 98/ windows me"
    >
    > --
    >
    > Margolis
    >
    http://web.archive.org/web/20030215212142/http://www.agqx.org/faqs/AGQ2FAQ.htm
    > http://www.unrealtower.org/faq
  9. Archived from groups: alt.games.quake2 (More info?)

    OK under compatability mode if I select run in 256 colors (OS setting
    doesnt seem to matter)I can get it to 74 frames p­er second and it
    doesn't matter what resolution I set it for in the ga­me. Always 74
    fps. I set video to max settings or lowestest settings still I still
    get 74fps. That isnt too bad but I dont recall having to keep windows
    98 in ­256 color mode back in the day to play quake2. And I had far
    less of a­ machine and still got over 100 fps. Also if I set my
    monitor refresh rate at 60hz my fps drops to 54. Default is 72hz.
    I have CL_Maxfps at 200


    Any other suggestions?


    Thanks JT
  10. Archived from groups: alt.games.quake2 (More info?)

    Also just noticed that my crosshair doesnt show up either.....jt
  11. Archived from groups: alt.games.quake2 (More info?)

    "Goodner79" <jtg30@hotmail.com> wrote in message
    news:1106956105.588686.253330@z14g2000cwz.googlegroups.com...
    > OK if I select run in 256 colors I can get it to 74 frames per second
    > and it doesn't matter what resolution I set it for in the game. Always
    > 74 fps. I have max setting or lowest settings still 74 though. That
    > isnt too bad but I dont recall having to keep windows 98 in 256 color
    > mode back in the day to play quake2. And I had far less of a machine
    > and still got over 100 fps.
    >
    > I have CL_Maxfps at 200
    >
    > Any other suggestions?
    >
    > Thanks JT
    >
    >
    >

    it seems to have fixed your problem. The reason you are stuck at 74fps now
    is because of vsync. You will need to disable vsync in the video drivers
    and also in the game options. (sometimes you have to enable it in the game
    options to disable it, very strange)

    I don't know why you have to do 256 color though. All I have to do is just
    select win98 compatibility mode.


    --

    Margolis
    http://web.archive.org/web/20030215212142/http://www.agqx.org/faqs/AGQ2FAQ.htm
    http://www.unrealtower.org/faq
  12. Archived from groups: alt.games.quake2 (More info?)

    How do I toggle vsync from within Q2? And what about the crosshair not
    showing up?
  13. Archived from groups: alt.games.quake2 (More info?)

    Oh and what does vsync do?
  14. Archived from groups: alt.games.quake2 (More info?)

    vsync is short for vertical sync. It synchronizes the framefrate from the
    game to the refresh rate of the monitor. With it enabled your computer will
    not draw any more frames than your refresh rate will allow. Disabling it is
    good for testing, but under most conditions it is better to keep it on. It
    doesn't matter how many fps your computer is capable of when it cannot
    display any more fps than the monitor's refresh rate allows.

    To enable it and disable it you would look in the video option menu in quake
    2, it is called "sync every frame". You also have to disable it in the
    video cards drivers 3d options.

    as for the crosshair problem, that may be due to the 256 color. Why do you
    have to play in 256color? where are you setting this options and why did
    you try it?.


    --

    Margolis
    http://web.archive.org/web/20030215212142/http://www.agqx.org/faqs/AGQ2FAQ.htm
    http://www.unrealtower.org/faq
  15. Archived from groups: alt.games.quake2 (More info?)

    In windows XP when you go to the properties for the quake2.exe, there
    are compatability options. If I dont have the 256 colors selected under
    compatability I only get 25-30 fps. I did uncheck the option and my
    crosshair does come back. Why the heck would 256 color mode fix my
    problem of only 25-30 fps?

    Thanks,

    Jeremy
  16. Archived from groups: alt.games.quake2 (More info?)

    "Goodner79" <jtg30@hotmail.com> wrote in message
    news:1107151990.822162.214360@z14g2000cwz.googlegroups.com
    > In windows XP when you go to the properties for the quake2.exe, there
    > are compatability options. If I dont have the 256 colors selected
    > under compatability I only get 25-30 fps. I did uncheck the option
    > and my crosshair does come back. Why the heck would 256 color mode
    > fix my problem of only 25-30 fps?
    >
    > Thanks,
    >
    > Jeremy

    I don't remember the start of this thread, but looking at just this
    message I'd be looking at my video card and driver on this issue. If
    that doesn't fix it, then I'd look at which opengl32.dll is in use and
    where it is. I recall that placing that file (comes with your vid card
    driver AND Windows also has a version that's 'generic') in the Q2 game
    folder helped with OGL issues I'd been having. Q2 would look in its own
    folder first, then in the \dll or \driver or \system32 folder, where
    ever it's stored.
    McG.
  17. Archived from groups: alt.games.quake2 (More info?)

    this sounds like a driver issue like McGrandpa said. First off, look in
    your q2 folder and all subfolders for a file called opengl.dll or
    opengl32.dll. If you find one, delete it. This has been known to cause
    problems when it was there.

    If that doesn't help, give us a bit more info. Which drivers are you using
    for the video card? Just saying the "latest" isn't too helpful. Plus having
    the "latest" isn't always a good thing. And which version of the game are
    you playing? 3.20 I hope

    --

    Margolis
    http://web.archive.org/web/20030215212142/http://www.agqx.org/faqs/AGQ2FAQ.htm
    http://www.unrealtower.org/faq
  18. Archived from groups: alt.games.quake2 (More info?)

    I have an ATI Radeon 9600SE with the latest drivers from ATI's site -
    Version: 6.14.10.6505

    There is a file named ref_gl.dll in my Q2 folder but if I move it or
    rename it I can no longer select OpenGL in the video options, It kicks
    back to software mode. If I take the Opengl32.dll from my
    c:\windows\system32 and copy into the Q2 folder and rename to
    ref_gl.dll it errors out of quake2.
    Oh and I am using version 3.20 of Q2.

    Thanks..JT
  19. Archived from groups: alt.games.quake2 (More info?)

    Any guess on why I have to run in 256 color mode? This is when my
    crossharis disapear.

    Thanks..JT
  20. Archived from groups: alt.games.quake2 (More info?)

    "Goodner79" <jtg30@hotmail.com> wrote in message
    news:1107540358.732310.316500@z14g2000cwz.googlegroups.com...
    > Any guess on why I have to run in 256 color mode? This is when my
    > crossharis disapear.
    >
    > Thanks..JT
    >


    sorry, been busy for a couple days. What is your windows desktop color set
    at?

    --

    Margolis
    http://web.archive.org/web/20030215212142/http://www.agqx.org/faqs/AGQ2FAQ.htm
    http://www.unrealtower.org/faq
  21. Archived from groups: alt.games.quake2 (More info?)

    Highest - 32 bit
Ask a new question

Read More

Games FPS Windows XP Video Games