Sign in with
Sign up | Sign in
Your question

External HDD files only visible in Linux.

Last response: in Linux/Free BSD
Share
August 14, 2012 1:52:18 PM

I have been using an external hdd as storage for all of my files, and haven't really kept anything on the internal hdd of my laptop. A few months back, I started using Ubuntu. I saw the external just fine, and I have been using it regularly.

Recently, I wanted to transfer some of my files from my external onto a friend's computer. He was running Windows 7. The drive was recognized, drivers were automatically installed, and I could open the drive just like normal. However, only two folders are visible, when there should be many more. One of the folders is one of mine which contains all the files that I put in it while in Ubuntu, and the other one is one that I have never seen before; it is called .Trash-1000. There are folders within .Trash-1000, but no files are in those folders. I would imagine that that folder is used by Ubuntu as a place to put files that are deleted but haven't been emptied from the trash can yet. My trash can was empty in Ubuntu, which would explain the lack of any files in that folder. There are many folders not being shown by Windows. When I check the amount of space being used on the drive in Windows, it shows that the correct amount is being occupied (~.8 of 1.5 TB), but the only folder with any files in it doesn't come close to that amount.

I have already tried to "show hidden files" in Windows and had no luck. I am not extremely tech savvy, so it would be appreciated if any answers were explained step by step (sorry if that makes it longer :/ ).

Also, I wasn't sure whether to put this in the Linux section, or the Windows section.

Thanks in advance for any answers.
August 14, 2012 11:18:28 PM

I have spent all day trying to get it to work with no luck so far.

I have tried changing the permissions on the hard drive, I used NTFS Configuration Tool, I tried checking for an error while in windows, I tried making a new partition to act as in intermediary, all to no avail. I am not using SRT, so that isn't an issue.

Windows isn't even recognizing the presence of the new partition, and still shows no files on the drive. Even the one folder that it previously showed before is now gone.

The main partition is NTFS, and the new partition is ext4, if that makes any difference.

Now, I can't even eject the drive. It says that it is busy. Can someone help with that too?

This doesn't seem like it is going to get resolved soon. I would really appreciate some input.
m
0
l
Related resources
August 15, 2012 1:17:12 AM

Now, on the external hdd, I can no longer delete things as I previously have. Instead of asking if I want to move the file to the trash when I hit delete, it says that I can't move it to the trash, would I like to delete it permanently?

Does anyone know how to fix any of this?
m
0
l
August 15, 2012 2:15:57 PM

Are you experiencing the new problem on the Windows machine or on your Ubuntu laptop?

.TRASH is indeed the trash folder where Ubuntu temporarily stores deleted items. When you click to "eject" the HDD it is emptied.

I suggest backing everything up to another HDD, then reformatting this one in a Windows machine. Then see if both machines can read it.
m
0
l
August 15, 2012 4:03:51 PM

I was planning to reformat it, and have already backed everything up, but why reformat it in Windows?
m
0
l
August 15, 2012 4:33:34 PM

That way you will know that it is formatted with a Windows-compatible file system.
m
0
l
August 15, 2012 5:09:28 PM

I reformatted the drive in Ubuntu, but formatted it as NTFS. This should work with windows. However, I still can't seem to move things to the trash with the delete key. It still asks if I want to permanently delete it. I am not sure how to attach pictures, but this is what the fstab files says. I have unmounted and remounted the drive several times, which might account for the several sdc1s.

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc nodev,noexec,nosuid 0 0
/dev/sdd1 /media/Seagate\040External_ ntfs-3g defaults,nosuid,nodev,locale=en_US.UTF-8 0 0
/dev/sdc1 /media/Seagate\040External ntfs-3g defaults,nosuid,nodev,locale=en_US.UTF-8 0 0
/dev/sdc1 /media/sdc1 ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/sdc2 /media/sdc2 ext4 defaults 0 0
/host/ubuntu/disks/root.disk / ext4 loop,errors=remount-ro 0 1
/host/ubuntu/disks/swap.disk none swap loop,sw 0 0
m
0
l
August 15, 2012 5:20:38 PM

So the deleting problem you are experiencing in Ubuntu? Are you still having difficulty reading the drive in Windows, or has that problem been resolved?


Have you emptied the .TRASH file on the HDD when unmounting? When you select "Eject" it should prompt you to empty the trash. If you don't do it, the .TRASH file will keep building up even though you can't see the files.

That is strange that it seems to be recognizing your HDD as four separate drives. It looks to me that there are multiple partitions that it is recognizing as separate drives. Is it possible that you only reformatted a partition but not the whole drive?

m
0
l
August 15, 2012 5:45:31 PM

I forgot to mention that there are currently two of the same external drives hooked up. I transferred all data that was on the one that I had been using onto a spare on, and then reformatted the old one. The spare is still hooked up since it now has all my files, but I don't want to move anything back onto the old one until everything is resolved, as I don't want to let it transfer for another 13 hours (that is how long it took last time).

I have yet to see if files can be seen on a Windows computer from my old drive because I can't get my hands on one at the moment, but I will update with any info as soon as I can.

Edit: I almost always have nothing in my trash can as it annoys me to know that something is there. Having sid that, I have never been prompted to empty the trash upon ejecting.

I tried to eject the old drive, but it said that media was busy. I unplugged it anyway as nothing was on it that wasn't on the spare drive (that shouldn't be a problem, right?).

A preliminary test (I put a small folder on the old drive then hooked it up to a Windows computer) showed all present files while in Windows (good sign). However, when I plugged it back up to my Linux (Ubuntu) computer, I got an error message.

Error mounting: mount exited with exit code 1: helper failed with:
mount: only root can mount /dev/sdd1 on /media/Seagate External_

I tried to mount it wit ha command in the terminal and got the following messages. (the first command was the command that I used last time to mount this drive, the second one used the location in the error report) I am pretty lost here on what to do. Thanks for sticking with me so far.

sebastian@ubuntu:~$ sudo mount /dev/sdc1
[sudo] password for sebastian:
ntfs-3g: Failed to access volume '/dev/sdc1': No such file or directory

ntfs-3g 2012.1.15AR.1 external FUSE 28 - Third Generation NTFS Driver
Configuration type 7, XATTRS are on, POSIX ACLS are on

Copyright (C) 2005-2007 Yura Pakhuchiy
Copyright (C) 2006-2009 Szabolcs Szakacsits
Copyright (C) 2007-2011 Jean-Pierre Andre
Copyright (C) 2009 Erik Larsson

Usage: ntfs-3g [-o option[,...]] <device|image_file> <mount_point>

Options: ro (read-only mount), remove_hiberfile, uid=, gid=,
umask=, fmask=, dmask=, streams_interface=.
Please see the details in the manual (type: man ntfs-3g).

Example: ntfs-3g /dev/sda1 /mnt/windows

News, support and information: http://tuxera.com
sebastian@ubuntu:~$ sudo mount /dev/sdd1
The disk contains an unclean file system (0, 0).
The file system wasn't safely closed on Windows. Fixing.
fuse: failed to access mountpoint /media/Seagate External_: No such file or directory
m
0
l
August 15, 2012 10:53:40 PM

Just for the sake of fun, let's add a new problem. I tried to edit the permissions of the old drive after being reformatted to ntfs. It wouldn't let me. Anytime that I picked an option, it just reset itself (I was using gksudo nautilus). I then reformated it again to ext4, and it let me set the permissions (all this formatting and reformatting can't be good for the drive, I'm sure).

This was all after I realized that the error messages didn't want me to have both drived plugged in at the same time. After disconnecting the spare that has all of my files, I plugged in the old drive, and it mounted correctly and I had access to it (though couldn't read or write anything due to the permissions thing which was resolved by going to ext4).

I noticed something while reformatting. The old drive was called /dev/sdb1 by gparted, but that wasn't in the fstab at all. Maybe there is something wrong somewhere that is confusing the spare drive for the old one which is stopping me from mounting them both at the same time.

I really need some help with this.
m
0
l
!