Sign in with
Sign up | Sign in
Your question
Closed

Solved: No sound from SoundMax Audio Devices

Last response: in Linux/Free BSD
Share
August 26, 2012 5:53:40 AM

I have 2 laptops that I am refurbishing to donate to a needy family. I am unable to use Windows on either machine and have decided to go the Linux route.

Reasoning: IBM ThinkPad R32 is designed so poorly that it is too slow to run multiple .NET frameworks as required for the laptop's purpose.

The Compaq Evo N610c has no hard drive as a special proprietary IDE adapter is required. This machine runs off a 16GB USB stick and can not run XP as XP re-enumerates the USB upon boot and 768 MB DDR1 RAM likely wont do well under Win7 lite.

My problem: Both the IBM ThinkPad R32 and the Compaq Evo n610c use a SoundMax audio device, which is apparently supposed to work out of the box with Debian based systems. The IBM is supposedly compatible with RedHat and SuSe according to lenovo.com

I have tried running Kubuntu 12.04 and Debian 6.0.5 which are supposed to work out of the box but on both machines, I have no sound.

pulseadio is installed. The alsamixer is not muted or turned down. I have tried installing OSS, that swiss army knife of sound, the compatability mode pulseaudio drivers and still i get no sound.

I don't even hear the normal "pop" you get from the speakers when the sound device is initialized..

Any ideas? I tried the Kubuntu IRC community but they don't have any answers past, "check the alsa mixer"
September 5, 2012 9:45:00 PM

have you tried this website yet
http://wiki.debian.org/ALSA

you can try 'alsactl init' as root and then reboot the computer to see if sound works. so your code would look something like this
"sudo alsactl init"

you may need to instal alsa-utils

That kind of the generic way to do it on debian as i understand. But if that doesnt work that page has other various methods of setting up sound
Score
0
October 16, 2012 10:41:10 PM

Solved:

Turns out the audio jack is bad on both systems. Loose connection, fixed by re-soldering the jack.
Score
0
October 17, 2012 4:55:30 AM

This topic has been closed by Amdfangirl
Score
0
Related resources
!