Sign in with
Sign up | Sign in
Your question

Vista64 installs, but the updates fail for various reasons

Last response: in Windows Vista
Share
March 13, 2009 1:59:23 AM

Problem: I can install Vista 64, but many Windows Updates fail. You know after a fresh install it says there are like 73 important updates. On the most recent attempt 43 of them succeeded, and 30 failed. The ones that fail, fail repeatedly. Thats pretty much par for the course.

I looked at each one of the error codes. They are:
80073712
800F0826
8024200D
80070017
8007370B

System:
MB GIGABYTE GA-P35-DS3L P35+ICH9
CPU INTEL E6550
MEM 4GB (2x2G) GSKILL DDR2-800 (PC2 6400)
HD 320GB SATA2 WD3200AAKS
VIDEO MSI 7600GS

Details: I've got the hard drive partitioned in three parts (XP, Vista, and a data drive). I've been using the XP drive for months without problems. When I install vista, all goes fine until I try to update it. I get numerous errors and none of the troubleshooting on error codes achieved any success. I broke down and contacted MS support at the end of January and am currently working with an Escalation Support person, but we're getting nowhere.

I've completely formatted the partition and reinstalled multiple times with the same results. The MS support folks have had me try numerous things with limited success, but nothing that completely solved the problem. He is currently suggesting that the MB is possibly the problem. I'm leaving out a lot of detail, I know, but here are my questions:

1) Is it possible that there is some hardware problem that is giving Vista fits but is not affecting the operation of the XP (32-bit) operating system?

2) Do you think that replacing any of the above components with something else may help?

3) The BIOS is updated, and I update the drivers the best I can once Vista does install. I'm wondering if maybe the order in which I install updated drivers and perform the Windows Update makes any differences. Thoughts?
March 20, 2009 1:53:22 AM

Update:
1) I tried installing all mobo drivers prior to any Vista updates and still had same problems.
2) I obtained a 32-bit version of Vista, formated the drive, and installed the 32-bit version without any problems.

It would seem to be an issue with the 64-bit configuration. Microsoft is sending me a new DVD, but I doubt that's going to resolve anything.

Can anyone think of any reason why I'd have these problems?
m
0
l
March 20, 2009 12:51:17 PM

I can't imagine what the problem is. I can tell you this is an unusual problem. It may be tangentially related to 64 somehow but this is certainly not something we see very often on 64 bit and probably most of us regulars here are running 64. I would give the new DVD a shot and if that fails I would try installing Vista to a separate hard drive - don't ask me why, it's just a gut guess, and since trying another MOBO might be the next step after that it might be worth taking a shot on a few long shot ideas first.

Any other problems with the 64 bit install? Bluescreens, restarts, freezing, etc.? If so then I would sure carefully check your memory configuration - voltage and timings - be sure they are set to exact mfg. specs. I would also try running the updates with only 1 stick of memory in there. Naturally on 64 bit the OS is going to be using memory a little differently so this could be a clue. It is also the case that subtle memory problems can cause unusual problems that don't seem like they should be memory related and when you have any system irregularity you can't put your finger on memory is going to be a prime suspect to try changing on general principles. Try 1 stick only and a different brand/model if you have any before you give up.

One more question; do the updates eventually go through after repeated efforts or not?
m
0
l
Related resources
March 20, 2009 8:46:01 PM

Thanks for the suggestions. I'll give them a try and post the results.

To answer your questions about another problems (Bluescreens, restarts, freezing, etc.), the answer is no. Although I haven't actually used the OS for anything. The installation process goes fine and the OS behaves normally until attempting to install the OS updates.
m
0
l
March 21, 2009 2:06:13 AM

Update:
1) I put in an old hard drive (it is IDE, my other is SATA). Tried installing Vista64. The install went fine, but windows update succeeded in installing 21 updates while 51 failed.

2) I pulled one of the two memory sticks. I formatted and reinstalled again. This time 31 updates succeeded and 43 failed.

"do the updates eventually go through after repeated efforts or not?"
Oh, I forgot to answer this earlier. With Microsoft Tech Support I was eventually able to get SP1 installed. There must be 15-20 emails back and forth trying stuff, but the gist of all of it was that they wanted all startup items disabled via MSCONFIG and to use the SP1 standalone installer. We successfully got SP1 to install (after several attempts), but in subsequent attempts to do additional updates resulted in an endless loop of rebooting ("Updates not installed correctly. Reverting changes. Shutting down") that we couldn't even stop via safe mode or a restore point.

Perhaps the new install DVD will help.
m
0
l
March 21, 2009 3:09:37 AM

Thanks for the update and for trying my ideas, sorry none helped :( 

Any other problems downloading things, you could have a faulty network card which could be stopping and/or corrupting data. Or maybe that NIC card doesn't like the 64 bit driver which will be a little different than the 32 driver. I'd maybe try another card before throwing in the towel and getting a new MOBO. The more I think about that the more it sounds possible. Of course if you have DL a lot of stuff to the Vista 64 install from other sources and got no errors this would tend to let the NIC card off the hook.
m
0
l
March 28, 2009 2:21:42 AM

Update:
I borrowed a 3com network card but apparently the card is too old and there are no vista 64-bit drivers for it. Bummer.

What I did try was to download the Vista 64 SP1 standalone update from a Microsoft link while booted with the XP OS. I then reformatted and installed a fresh Vista 64 and the standalone SP1 install. I got the same results. I tried numerous various on this, including disabling the NIC in BIOS and installing chipset drivers. Since I'm having the same problems even with the on-board NIC disabled and using update files downloaded while booted to XP, I'm assuming there isn't a NIC problem.

FWIW, I downloaded and installed Ubuntu 8.10 64-bit. All of its updated just fine.

There just seems to be some dislike between Vista 64 and my hardware.

m
0
l
!