Sign in with
Sign up | Sign in
Your question

Setting up WiFi in Ubuntu Server 12.04

Last response: in Linux/Free BSD
Share
November 22, 2012 8:45:20 AM

I have Netgear WNA1100 (Athreos 9271) based USB WiFi DOngle. I cannot start wlan0.I have installed the required firmware in /lib/firmware. OS is Ubuntu Server 12.04

Following are my configurations:

root@ubuntu:~# lsmod | grep ath9k
ath9k_htc 90811 0
mac80211 436455 1 ath9k_htc
ath9k_common 13781 1 ath9k_htc
ath9k_hw 391554 2 ath9k_htc,ath9k_common
ath 19387 3 ath9k_htc,ath9k_common,ath9k_hw
cfg80211 178679 3 ath9k_htc,mac80211,ath



/network/interfaces

# The loopback network interface
auto lo eth0
iface lo inet loopback

# The primary network interface
iface eth0 inet dhcp

auto wlan0
iface wlan0 inet dhcp


root@ubuntu:~# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0846:9030 NetGear, Inc. WNA1100 Wireless-N 150 [Atheros AR9271]

root@ubuntu:~# iwconfig
lo no wireless extensions.

eth1 no wireless extensions.

eth0 no wireless extensions.
November 22, 2012 1:54:02 PM

Do you have an active ethernet connection? If so the wireless adapter will be disabled automatically. Remove the cable, wait a few seconds, the wireless should be activated.
m
0
l
November 22, 2012 3:03:21 PM

hi, after you have reloaded the module (or rebooted) can you 'sudo ifconfig wlan0 up' ?
m
0
l
Related resources
November 24, 2012 4:53:07 AM

skittle said:
hi, after you have reloaded the module (or rebooted) can you 'sudo ifconfig wlan0 up' ?


Yes. After couple of restarts and changing CMOS battery, my wlan0 interface powered up.
But facing a new problem now. With my wired connection enabled (eth0) and static ip and gateway assigned, i can successfully browse net. But after I disconnect the wire, the wlan0 gets IP from router by DHCP and I can also ping the router. But I cannot ping the Internet like 8.8.8.8 etc. How to resolve this issue?
m
0
l
November 24, 2012 4:53:57 AM

ex_bubblehead said:
Do you have an active ethernet connection? If so the wireless adapter will be disabled automatically. Remove the cable, wait a few seconds, the wireless should be activated.


I also tried by unplugging the wire.. But cannot ping internet ips.
m
0
l
!