Sign in with
Sign up | Sign in
Your question

Vista 64 problems with old system

Last response: in Windows Vista
Share
March 26, 2009 3:54:45 AM

Hey all,

I am posting here in hope that I can get some help with a little problem that I am having. I have recently built a new computer. I was attempting to revive my old one but decided it wasnt worth the money thanks to the help of the people on this forum. But I am now having a problem with my old system.

I have ran this computer in its current state for over the past year. I did have a different motherboard but it died on me. I also bought a new graphics card sense the computer was first built. But here is the system Specs:


Operating System: Windows Vista 64bit with SP1
Motherboard: Asus A8V-X
Processor: AMD Athlon 64bit +3700 (939)
Memory: 4gb OCZ Platinum pc3200
Graphics Card: 512mb Sapphire Radeon HD3850 (AGP)
Sound Card: Creative Labs Sound Blaster Audigy 2
Hard Drive: 200gb Western Digital (IDE)
Power Supply: Rosewill 400watt RD400-2-DB


Here is the situation...I am selling this computer to a friend since I bought a new one. I asked him what OS he wanted and he said Vista since he knows Vista the best. I didnt think it would be a huge deal even though I dont like Vista very well. I have ran three different operating systems on this computer (Windows XP 32bit and 64bit and Windows 7 32bit beta) . All of there OS' have ran perfectly fine with no problems whats so ever. However since I have installed Vista on it I have had a problem with my video.

Basically what is going on is that the system runs fine for normal use. It doesnt have problems with normal uses, watching dvds or videos on the internet, listening to music, etc. But when I load up some games the computer basically hangs and I have to reboot. I have so far installed Quake 4, GRAW 2, Crysis and Far Cry 2. (I have plenty of others to try). Quake 4 and GRAW 2 run fine. However, when I start up Crysis and Far Cry 2 the screen turns a solid color (color can very) and the computer just sits there. I cant alt-tab, bring up task manager, etc. I then reboot and the computer runs fine. I have ran both these games with XP 32bit and 64bit with no problems. (didnt have the games when I was using Windows 7 beta)

I talked to a few of my friends and they thought it sounded like a power supply problem so I made a trip to Best Buy and purchased a 850watt Thermaltake Toughpower power supply to test and it gave me the same results. I returned it and hit the drawing board again. I have tried to reformat, run as administrator, compatibility, etc. but nothing helps. I have tried a few graphics drivers as well but didnt do any good.

There is also something else I have noticed as of today too, when the UAC box pops up and the screen dims, a lot of the time the dim is currupted and shows a bunch of black times randomly. So by this I am assuming that it is a driver problem. I am going to try a couple more things tomorrow in hopes to get it fixed. I have all the drivers downloaded (catalyst package and just display driver ) from 9.3 all the back to 8.9. Going to try them all!

Also, another small thing, when I installing new programs on the ccomputer. There is no start menu folder created even if I have it checked to create one? Anyone want to take a stab at this one?

So does anyone know what might be the problem? Any info on this would be awesome!

Thanks!
Chris Stickles

*EDIT* With just the standard vga driver installed the UAC problem goes away.

More about : vista problems system

March 26, 2009 4:28:42 AM

If drivers don't work then check to make sure the fan is still spinning on the video card and after that if problem persists you may have a defective card but these are just general ideas - there are probably other possibilities too - you could always run an extensive memtest86 which will stress the memory and the mobo without involving much from video card. I'm thinking this is probably a video card problem though because if you had a more general problem it would probably generate bluescreens or restarts but you always seem to get video issues only.
m
0
l
March 26, 2009 4:38:42 AM

notherdude,

I will try that out. Do you really think that it is a problem with the graphics card itself? The fan is fine, I have already checked that. I ran three other OS' on it with no problems. I was actually playing Crysis on it right up to the point I shut the computer down and immediatly formatted with Vista. After all updates and drivers, installed Crysis and then started having the problem. Another thing also like a said, with just the standard vga drivers installed by Vista, the UAC curruption is gone, but when I install the ATI drivers, it comes back. I know that it could be the graphics card, but seems a little wierd to me that it was working fine, then like 2 hours later with fresh Vista install the problem starts. Also the UAC thing only happens with ATI drivers installed. I may have to just try to put XP back on it to test if the problem goes away!

Thanks,
Chris Stickles
m
0
l
Related resources
March 26, 2009 12:48:52 PM

Well somehow I missed the part about it happening so suddenly just going to Vista. That being the case it does sound like it might be something other than the card itself. Naturally drivers come to mind first - if you get no help from trying different driver versions then it may be worth trying an OS reinstall and then installing a different driver version first, before the one you installed first last time, in case it left traces. It is also possible Vista 64 is utilizing memory a bit differently than the other OSes. You might try running with 2 gig of RAM only and see if the issue persists. It does sound like one of those problems that is tough to pin down. Your best hope may be to find others who had the same issue. Googling your video card and Vista 64 might be useful. I tried that just now and didn't find much specific. Have you tried 'fastwrite' off in the BIOS? Or fiddling with the 'aperture size'? I'd also look into a BIOS update for that old MOBO.

I suspect not too many people are running Vista with AGP cards/MOBOs, which may explain the lack of data and possible unresolved problems. If nothing seems to work there is always XP and then of course 7 is coming.

EDIT The fact it works in standard VGA could mean the ATI drivers are not working or it could simply mean the VGA mode is not utilizing some advanced rendering features of the card. It is fairly common I think for a slightly defective card to work in VGA mode but fail in more advanced modes.

You might want to try posting this in the video card forum if you have not already
m
0
l
March 26, 2009 1:41:51 PM

I see that you were running Crysis until the format.
Was that on XP or W7?
If it was on XP it was running DX9.
With it on Vista try to create a new shortcut and in the properties make it read
crysis.exe-dx9
This will force it to run using DX9 to see if that might be causing the problem
It may just be that your vid card cant take DX10

edit its either crysis.exe-dx9 or crysis.exe -dx9
sorry cant remember offhand
m
0
l
March 26, 2009 2:40:00 PM

pat mcgroin said:
I see that you were running Crysis until the format.
Was that on XP or W7?
If it was on XP it was running DX9.
With it on Vista try to create a new shortcut and in the properties make it read
crysis.exe-dx9
This will force it to run using DX9 to see if that might be causing the problem
It may just be that your vid card cant take DX10

edit its either crysis.exe-dx9 or crysis.exe -dx9
sorry cant remember offhand

Oh man , I need to read more carefully, yea, if all those other games are working and crysis and FC2 are not then for sure I would be looking at DX 10 issues too.
m
0
l
March 26, 2009 10:11:17 PM

To All,

Ok, it seems like I have the video problem solved. After working on the computer for most of the day it seems to be running stable. Far Cry 2 runs fine and I am installing Crysis back on as I type this. This is what seems to have fixed it:

I went into the bios and re-enabled agp fastwrite and bumped the agp memory size down to 64mb from 256mb. This seemed to fix the problem cause Far Cry 2 booted up 2 times in a row. However on the third boot it did the same thing as before (solid color on screen and have to hard reboot). When Vista booted back up it said it was caused by the ATI drivers. I then thought about you guys suggested removing 2gb of memory to see if that fixed it. I didnt do this, but I did go back into the bios and disabled hardware memory hole under my northbridge chipset option. This baiscally allowed Vista to use all 4gb of memory. With it disabled it only uses 3gb. I then booted back up to Far Cry 2 lauching fine after many reboots and also the display curruption is gone from the UAC.

So running all 4gb of the ram seems to be the cause of the problem. It ran fine with that setting enabled in XP 64bit but I guess Vista doesnt like it. There has been another plus to disabling this feature. Before I ran with a 300mhz overclock on my processor but from the start if I attempted the oc, Vista wouldnt boot half of the time. With the setting disabled I can now oc my processor once again. It actually made my Vista cpu score go from 4.1 to 4.3, and memory from 4.6 to 4.8 so that is always good.

So being able to only use 3gb out of the 4gb installed doesnt seem that bad sense I have the processor oc'ed and Vista score is better with the processor oc then the extra 1gb of memory.

Also, for what my friend wants to use it for (normal use with maybe some older gaming, he has a ps3 and xbox 360 and he will play those more) he really wont need all 4gb of memory anyways.

There was also something I noticed while messing around with the computer today, my sound had a bit of a echo with the Audigy 2 sound card. I tired to reinstall the drivers but it didnt help. So I went to Best Buy and bought the Dynex sound card with a VIA chipset that I use in my new computer and the echo is gone. So my sound it all set as well!

So as far as perfomance goes, everything seems to be 100%. I can play Far Cry 2 at 1680x1050 with medium settings at 30 to 60fps so not too shabby if you ask me with the outdated hardware and running Vista.

Thank you for all your help! If anything else seems to go wrong I will post back!

Thanks!
Chris Stickles


*EDIT* When I installed Crysis it still didnt add a start menu group, anyone know how to fix this? *EDIT*
m
0
l
March 27, 2009 1:15:07 PM

Its under the folder games|games explorer.
Its the new way to be a pain in the ass. Just make a shortcut and move it wherever you want.

As for the memory hole, that was designed for the OS/X op system and should be off for all versions of anything except OS/x.

Its normal for window to not show all of the memory. It is being used by the system is all so it doesnt show as available.
m
0
l
!