Sign in with
Sign up | Sign in
Your question

I can't get windows clock working properly

Last response: in Windows 7
Share
August 8, 2011 7:24:52 AM

I searched through the internet a lot before I ask the question here.

I mainly use my desktop and the laptop sometimes isn't turned on for days, though a dozen hours seem to be enough to produce the problem.

The problem is that the clock resets every so often and goes to a date that has the correct month and day of the month, but wrong time and very wrong year (2049 usually).

What I have done:
1) Changed the clock manually -> goes back to being wrong
2) Synchronized it with the internet -> it doesn't always work (sometimes I get a timeout message), but when it does, it doesn't keep the setting
3) Checked BIOS time -> It's correct (the one time I checked it)
4) Did some things microsoft support proposed within a command prompt (something like net stop w32tm and other commands) -> no luck
5) Last thing I did was disable Windows Time from Services (I read online that it would help) -> It didn't change anything and now I can't re-enable Windows Time because it's not in the Services. Also, I can't change the internet time sync settings; it says that I should contact my admin...(I'm him...I'm practically the only user, I don't even use passwords on the laptop)

My computer is fully updated, I even download the non-important updates, virus free (according to AVG), I even use the zone alarm free firewall, to make sure that it's protected, even if it's rarely connected to the internet.

So, except from reformatting, what is there to do? Please help!
August 8, 2011 8:13:23 AM

BIOS clock is correct, and the laptop is fairly new (18 months)...so probably not.

Edit: I would also like to ask if anyone knows of a way to make the 'Windows Time' service reappear.
Related resources
a b $ Windows 7
August 8, 2011 5:39:15 PM

to restart windows time service go to start--type services in the search box--open the services by clicking on services--if more than one services is listed its the one where the icon looks like gears--this will bring up a list of services--they are alphabetically arranged--double click the windows time service then you can choose to start it or set it to start automatically etc
August 8, 2011 6:13:25 PM

Actually, that was where the Windows Time Service disappeared from. It just disappeared. It went away, as if it never was in the "Services".

In any case, I think I fixed it, but we'll see tomorrow. I read some more online and it probably had to do with the fact that 1) the internet connection was through wi-fi 2) There were 2 computers on the network (that one + my WinXP desktop), connected to each other, 3) I had set time to be updated through the internet.

So, I ran some commands in the prompt and lo and behold Windows Time reappeared in the services (still deactivated). Now I could access the Internet Time settings again (while Windows Time had disappeared, I couldn't) and I disabled the automatic synchronization. I manually put the time in the clock.

For now, it seems to be working...we'll see...
August 9, 2011 10:10:40 PM

Update: it didn't work, so I need more help. Surprisingly, this time the clock didn't go forward to 2046, but it just went ahead a few hours. Any ideas? Anything I haven't tried?
Related resources
!