Sign in with
Sign up | Sign in
Your question

PS2 - USB Keyboard Nightmare

Last response: in Components
Share
May 26, 2007 9:27:08 PM

Recently the ps2 port my motherboard uses for my keyboard seemingly stopped working. I was reduced to using the visual keyboard embedded into Windows for a while until I could get myself a new USB keyboard. Now that I finally did, I realized legacy USB (what makes USB devices work before Windows boots) wasn't enabled in the BIOS because I cannot do anything before my pc is fully booted up, no safe mode either...

I know the obvious thing to do would be to go into the BIOS and enable legacy, but how in the blue heck am I supposed to do that without a working ps2 port?? I tried removing the BIOS battery to see if it was enabled by default, no such luck of course...

This really sucks, the way things are going, I'll have to buy a new CPU & MoBo next time I have to reinstall Windows... That's just retarded, anyone has an idea I didn't think of?
May 26, 2007 9:35:13 PM

Every BIOS is a bit different and default settings, but since you're in a pinch, try removing the battery from the mobo for a minute, pop it back in and see if that'll help. My USB keyboard works by default after such a reset, so maybe yours will too? *fingers crossed*
May 26, 2007 9:57:59 PM

Nah as I've said, I tried that already and wasn't lucky, the legacy setting is off by default on my BIOS...
Related resources
May 26, 2007 10:07:50 PM

Sorry man. :?
May 26, 2007 10:52:06 PM

Are you sure it was the port that died? There are usb to ps2 adapters that can be had, try one of those with your new usb KB...
May 27, 2007 3:51:15 AM

I should have mentioned I tried a brand new ps2 keyboard and an old one before I jumped to the conclusion that my port was fried...
May 27, 2007 5:39:22 AM

Sorry... Either live with default bios or get a new MB. any chance that the MB is still under warranty?
May 27, 2007 7:05:34 AM

You should try asking the motherboard manufacturer the same question.

What motherboard is it btw?
May 27, 2007 7:45:27 AM

I know a way to fix it: Get a copy of your BIOS and the proper BIOS modification utility, modify the copied BIOS to provide USB Legacy Support by default, write a custom Autoexec command with the proper switches, and reboot your machine from floppy. Done. It's that easy!

The hard part is doing it! LOL
May 27, 2007 8:42:30 AM

Did you try clearing your RTC RAM :)  ? Is there a jumper close to your battery on your motherboard? Sometimes this works. To do this you turn off the computer and unplug the power cord. Remove the battery. Move the jumper cap from pins 1-2 (default) to pins 3-4.Wait 5-10 seconds, then move the cap back to pins 1-2. Reinstall the battery. Plug the power cord and turn on the computer. Hold down the <DEL> key during the boot process and enter the BIOS set-up to re-enter data.
May 27, 2007 5:11:02 PM

Quote:
I know a way to fix it: Get a copy of your BIOS and the proper BIOS modification utility, modify the copied BIOS to provide USB Legacy Support by default, write a custom Autoexec command with the proper switches, and reboot your machine from floppy. Done. It's that easy!

The hard part is doing it! LOL


Crashman is right on both accounts. Stupid me was thinking "but how will you flash your BIOS without a keyboard to enter the commands?".
May 27, 2007 5:37:07 PM

@ Flasher702 : It's an ASUS KV8x.
Thanks Crashman, that does sound like it would work, until I get to the boot-from-floppy part (since I have no input and can't even get a "Enter" through). Still sounds like my best shot though I'll look into that, thanks for the idea.

If any of you guys know the procedure, please let me know. I have an American Megatrend BIOS, an Asus Kv8x and a AMD64 CPU. I didn't find any utilities for that yet, I'll update if I find anything new. I'll be crawling Google for a while on that one it may seem.
!