Sign in with
Sign up | Sign in
Your question

Quick question regarding linux install on flash drive

Tags:
  • ISO
  • Flash Drive
  • Linux
Last response: in Linux/Free BSD
Share
January 12, 2013 8:28:00 PM

Ok so I got my usb flash drive formatted to NTFS, I downloaded the Linux file to my computer and I downloaded Windows 7 USB/DVD download tool to put the linux os onto my pendrive. I click on the linux iso file to add to my pendrive and it says "The selected file is not a valid ISO file. Please select a valid ISO file and try again".

The linux file I downloaded is called:

linuxmint-14.1-mate-dvd-32bit.iso

It's type is "Disc Image File" and it is approximately 1 GB? So how do I get this thing onto my usb drive so that I can boot from it?

More about : quick question linux install flash drive

January 13, 2013 12:03:13 AM

This is a known problem with the Win7 USB tool. There is a work around somewhere on the internet, but in all honesty I would recommend using a different program.

Most people like to use unetbootin (http://unetbootin.sourceforge.net/) for that kind of thing but I seem to have problems with it, the program I use for flashing an .iso to a pendrive is RUFUS (http://rufus.akeo.ie/)

Regards,
- D4rk0wl
m
0
l
Related resources
January 14, 2013 2:48:55 PM

Use unetbootin to burn to USB stick.
m
0
l
January 15, 2013 6:19:06 PM

I used Unetbootin and put Mint 32 bit on my USB drive. I popped it into my laptop> boot up> F12 for boot menu> boot from USB> does not work. It just boots from my HDD anyway and loads up windows.

My laptop is pretty old though (from '07). Is this the problem or is there something wrong with the linux install on my usb stick? How do I tell?
m
0
l
January 15, 2013 6:42:31 PM

Sounds like you have made the USB stick correctly. An '07 laptop should be fine.

When you go into Bios boot menu, see if there is another option for 'HDD priority' (or the equivalent). You should see a list of HDDs. If your USB is on the list, it thinks your USB stick is a HDD. Bump it up to the top of the HDD list. Otherwise, since it recognizes your USB stick as a HDD, it skips the USB option and then goes to the first HDD on the list, which is your "real" HDD.
m
0
l
January 15, 2013 7:18:59 PM

I don't see such an option. The only thing I see in the bios is the boot priority:

1. USB
2. HDD
3. etc
4. etc

That's how I set it and it still booted off the hdd.
m
0
l
a b 5 Linux
January 15, 2013 7:23:35 PM

That would tend to indicate that your thumbdrive doesn't have a valid boot block on it. Try on a different machine. If you get the same result then rebuild the thumbdrive.
m
0
l
January 15, 2013 9:07:10 PM

It is possible that your laptop does not support booting from USB. I ran into that when trying to install linux on my mother-in-law's laptop (a Toshiba about 7-8 yrs old). Try doing a google search for your laptop model and see if anyone has had this problem. In that case, your only option would be to burn linux to CD/DVD and installing from the disc.
m
0
l
a b 5 Linux
January 16, 2013 5:04:57 PM

rcfant89 said:
I don't see such an option. The only thing I see in the bios is the boot priority:

1. USB
2. HDD
3. etc
4. etc

That's how I set it and it still booted off the hdd.

Click on hdd or the + if there is one. If your flash is there promote it with the f5 key.
m
0
l
a b 5 Linux
January 16, 2013 5:07:31 PM

rcfant89 said:
I don't see such an option. The only thing I see in the bios is the boot priority:

1. USB
2. HDD
3. etc
4. etc

That's how I set it and it still booted off the hdd.

Click on hdd or the + if there is one. If your flash is there promote it with the f5 key.
m
0
l
a b 5 Linux
January 16, 2013 10:40:07 PM

In addition to the above . . .

"Ok so I got my usb flash drive formatted to NTFS, . . . F12 for boot menu> boot from USB> does not work."
If USB stick was not formatted to a linux FS before using unetbootin to load Mint onto it, this is a most
likely source of OP's problem. Learn to use SystemRescueCD, as a suggestion. Any trace of NTFS on a boot
medium can cause failure to boot linux, in my experience.

Lose the MS mindset, too, as a suggestion. LOL!
m
0
l
!