Sign in with
Sign up | Sign in
Your question

Card Reader Just Disappears

Last response: in Windows XP
Share
March 11, 2009 2:46:08 AM

Yesterday I picked up a cheap internal card reader for my wife's computer. There is absolutely no brand on this thing at all. I have DYNEX in my own computer that I have never had problems with, how hard can it be right?

Yesterday I installed the reader in her computer and fired it up. It worked fine, showed up as several drive letters, just like my DYNEX. After a reboot, however, the card reader is gone. I can look in the device manager and under the USB section there is one unknown device. It lists no drivers installed. I have tried deleting all the USB items from the device manager and rebooting, it does not help. It will redetect everything, including the unknown device.

I've spent the last hour trying to research the problem and I have come to the conclusion that it's pretty common, but nobody lists a real answer. The most commonly suggested answer is to simply format and rebuild the system and even that doesn't work 9 out of 10 times. I don't consider that an answer anyway, just a shot in the dark fix-all for people who are too lazy to actually troubleshoot. I will not rebuild this system because we just built it less than a month ago and it's perfectly clean. There are no hardware conflicts and it is not a spyware / corrupted system issue. My research tells me that it's actually a Windows problem, I'm just hoping somebody has a Windows answer.

Please don't tell me to unplug the device and plug it back in. This is an INTERNAL card reader, that is not a solution. The internal USB headers that it is plugged into works fine, I have tried other devices. Furthermore the card reader has a plain old USB port on the front that also works. Only the card reader portion is not working.

System Specifications:
MSI P45 Neo3 Motherboard
Intel Core 2 Quad Q6600 CPU
4 GB Corsair DDR2 800 RAM
Nvidia 8800 GTS 320 MB Video Card
Adaptec 29320 Ultra 320 SCSI Controller
Windows XP SP3

More about : card reader disappears

March 15, 2009 7:17:53 AM

perhaps it died, the usb connection is straight thru
m
0
l
March 15, 2009 3:48:24 PM

It's possible but not likely, the symptoms are too common. A quick Google search reveals that this happens all the time but nobody seems to have an answer. Ultimately I took it back and got a refund. I was able to go get a DYNEX like mine for $5 less money and it will read more types of cards. It works perfectly.
m
0
l
September 11, 2009 6:09:34 PM

I have a simulator problem, ( in that the Dynex card read will only work after unplugging it from the mother board. I have just upgraded from an Abit NF7 mobo to an Asus M4A78T-E.. The problem started with the new Mobo.) It worked correctly on the old mobo.
When I click on eject, it says that the drive is busy.. this when the reader is empty. I plug in an SD card, the green Led comes on but the J drive says insert media..
m
0
l
!