Sign in with
Sign up | Sign in
Your question

Access is Denied dialog (not permissions related)

Last response: in Windows XP
Share
March 12, 2009 3:12:32 PM

Hi everyone, new to the forum. Long time lurker, but decided to post for the first time due to an issue that not even MS TS can't solve. I searched the forums before posting this, btw.

The issue: I cannot open folders on my computer. I can only Explore them. If I try to open them (usually by double-clicking), I get an "Access is denied" alert. However, if I right-click and select Explore, all is good. I then usually drill down (using the expand plus signs) to get to the folder I want. But again, I cannot double-click on a folder that appears on the right pane in Explorer.

I am 99% positive it has nothing to do with permissions. Just to be sure, I have tried all the permission fixes I could find, to no avail. In most cases, I can't even see a Security tab on a folder (right-click, then Properties).

My hunch is that it's a file type association. In the File Types tab (Tools > Folder Options), I see a FOLDER and FILE FOLDER file type, both with the (NONE) extensions. The FOLDER file type has EXPLORE and OPEN in the Advanced area, FILE FOLDER has FIND and OPEN. I have tried tweaking these options, but nothing seems to work.

I have booted into Safe Mode: no go. I have logged on as a different user (with Admin rights): no go.

Any ideas would help.
March 12, 2009 4:16:53 PM

How recent is this problem?

I would try system restore to prior.
March 12, 2009 4:24:31 PM

I looked into that, and unfortunately it's been a few months.
I've sort of learned to live with it by Exploring folders, vice double-clicking them.
Related resources
March 13, 2009 5:59:23 PM

Try one more thing from Microsoft.....

Reset the registry and the file permissions
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
To reset the registry and file permissions, follow these steps:

1. Download and then install the Subinacl.exe file. To do this, visit the following Microsoft Web site:
http://www.microsoft.com/downloads/details.aspx?FamilyI... (http://www.microsoft.com/downloads/details.aspx?FamilyI...)
2. Start Notepad.
3. Copy and then paste the following text into Notepad.
cd /d "%ProgramFiles%\Windows Resource Kits\Tools"
subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f
subinacl /subdirectories %windir%\*.* /grant=administrators=f /grant=system=f
secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose
Microsoft provides programming examples for illustration only, without warranty either expressed or implied. This includes, but is not limited to, the implied warranties of merchantability or fitness for a particular purpose. This article assumes that you are familiar with the programming language that is being demonstrated and with the tools that are used to create and to debug procedures. Microsoft support engineers can help explain the functionality of a particular procedure. However, they will not modify these examples to provide added functionality or construct procedures to meet your specific requirements.
4. Save this Notepad file as Reset.cmd.
5. Double-click the Reset.cmd file to run the script.

Note This script file may take a long time to run. You must run this script as an administrator.
Be carefull.
March 13, 2009 8:49:46 PM

Thanks proedros for this procedure. It did a lot of cool stuff in the command-line window, but unfortunately it did not work. I even restarted the machine, but no go.

It seems like such a minor issue, but is really driving my Windows experience quickly towards the ground.

Imagine a file folder based UI in which you can't open folders.
March 13, 2009 9:01:45 PM

What file system do you have on your hard disk? Did you do an upgrade? What was the last thing you installed on your system before you had this problem? Did you ever encrypt your drive? Did you try to repair your Windows installation? Viruses? Malware? Every little thing that you did will help us to help you.
March 13, 2009 9:08:58 PM

proedros said:
What file system do you have on your hard disk? Did you do an upgrade? What was the last thing you installed on your system before you had this problem? Did you ever encrypt your drive? Did you try to repair your Windows installation? Viruses? Malware? Every little thing that you did will help us to help you.


Hi proedros,

I have a FAT32 FS. I did not upgrade. It's an XP SP3 Pro install on VMWare running on Mac OS X Leopard.

I've had the problem for about 2 months.

The one thing that I am pretty sure is the cause is that I messed around with the Folder Options in Tools... > File Types tab. In the File Types list, there is a File Folders and Folders, both with (NONE) as their extension. For File Folder in the Advanced tab, I see 'find' and 'open' with 'open' as the default. For the Folders file type, I see 'explore' and 'open', with 'open' as the default. For both types, I've changed the defaults, to no avail. I've also tried changing the 'Confirm open after download' and the other checkboxes. For both file types, the Change... button is grayed out.

I tried doing some things to try to get something to run automatically when I opened a folder. I am pretty sure that is when the problem started.

Thanks for your efforts.

!