Sign in with
Sign up | Sign in
Your question

How to turn ON registry editing

Tags:
  • Registry
  • Microsoft
  • Windows XP
Last response: in Windows XP
Share
Anonymous
May 27, 2005 2:50:11 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

I need to delete a registry item but XP by default turns this funtion off. I
get an "Error While Deleting Key" message when attempting to delet a folder.

How do I turn it ON?

Thanks
MikeT

More about : turn registry editing

Anonymous
May 27, 2005 2:58:47 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

On Fri, 27 May 2005 10:50:11 -0500, Windows XP wrote:

> I need to delete a registry item but XP by default turns this funtion off. I
> get an "Error While Deleting Key" message when attempting to delet a folder.
>
> How do I turn it ON?
>
> Thanks
> MikeT

Is the key or one of the subkeys it contains protected by permissions?
While logged on with an account that belongs to the administrator group,
right click on a registry key and select permissions. Edit permissions to
give the Administrator group the necessary permissions to perform the
failed operation.

--
Sharon F
MS-MVP ~ Windows Shell/User
Anonymous
May 27, 2005 3:30:10 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

Yeah, I've checked permissions are set correctly and I still cannot delete a
KEY?!


"Sharon F" <sharonfDEL@ETEmvps.org> wrote in message
news:evQnxTtYFHA.3620@TK2MSFTNGP09.phx.gbl...
> On Fri, 27 May 2005 10:50:11 -0500, Windows XP wrote:
>
>> I need to delete a registry item but XP by default turns this funtion
>> off. I
>> get an "Error While Deleting Key" message when attempting to delet a
>> folder.
>>
>> How do I turn it ON?
>>
>> Thanks
>> MikeT
>
> Is the key or one of the subkeys it contains protected by permissions?
> While logged on with an account that belongs to the administrator group,
> right click on a registry key and select permissions. Edit permissions to
> give the Administrator group the necessary permissions to perform the
> failed operation.
>
> --
> Sharon F
> MS-MVP ~ Windows Shell/User
Anonymous
May 27, 2005 7:10:07 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

In this case, in addition to the Administrators group, add your username and give it full control of the key in question.

--
Doug Knox, MS-MVP Windows Media Center\Windows Powered Smart Display\Security
Win 95/98/Me/XP Tweaks and Fixes
http://www.dougknox.com
--------------------------------
Per user Group Policy Restrictions for XP Home and XP Pro
http://www.dougknox.com/xp/utils/xp_securityconsole.htm
--------------------------------
Please reply only to the newsgroup so all may benefit.
Unsolicited e-mail is not answered.

"Windows XP" <mike@feedbackhost.com> wrote in message news:o 69UeltYFHA.3636@TK2MSFTNGP10.phx.gbl...
> Yeah, I've checked permissions are set correctly and I still cannot delete a
> KEY?!
>
>
> "Sharon F" <sharonfDEL@ETEmvps.org> wrote in message
> news:evQnxTtYFHA.3620@TK2MSFTNGP09.phx.gbl...
>> On Fri, 27 May 2005 10:50:11 -0500, Windows XP wrote:
>>
>>> I need to delete a registry item but XP by default turns this funtion
>>> off. I
>>> get an "Error While Deleting Key" message when attempting to delet a
>>> folder.
>>>
>>> How do I turn it ON?
>>>
>>> Thanks
>>> MikeT
>>
>> Is the key or one of the subkeys it contains protected by permissions?
>> While logged on with an account that belongs to the administrator group,
>> right click on a registry key and select permissions. Edit permissions to
>> give the Administrator group the necessary permissions to perform the
>> failed operation.
>>
>> --
>> Sharon F
>> MS-MVP ~ Windows Shell/User
>
>
!