Sign in with
Sign up | Sign in
Your question

Hokay... Cat. 7.5'a are out! Any takers yet?

Last response: in Graphics & Displays
Share
June 1, 2007 12:42:38 PM

I'm running an X1950 Pro AGP so I'm still running 7.3's which run my card like a champ. Anyone else upticking their CCC?

Da Worfster

More about : hokay cat takers

June 1, 2007 2:06:26 PM

I installed them yesterday around midnight, was setting up XF and had to reinstall the drivers, so got them without even realizing they were out already.

Appart from a slight drop in performance in single card mode compared to 7.4 (4840 3DM06 vs 4800), everything went fine wihout a hickup. I'm not sure if its the case, but I find CCC to start pretty fast now compared to before.

Edit: The only Freaking annoying thing that's been added since 7.4 are ads and free stuff directly with the drivers. You can choose not to install them, but still it's starting to become a general annoyance to have all this stuff added to installers.
June 1, 2007 3:14:48 PM

Quote:

Edit: The only Freaking annoying thing that's been added since 7.4 are ads and free stuff directly with the drivers. You can choose not to install them, but still it's starting to become a general annoyance to have all this stuff added to installers.


What are you referring to? I'm still on 7.3. They've imbedded ads in the drivers? Are you chittin' me? Have they no shame?

Da Worfster
Related resources
June 1, 2007 4:04:55 PM

He probably means that sutff like the google toolbar and stuff is added as an option to install.
June 1, 2007 4:19:42 PM

It has options for installing Steam and an Earthsim program imbedded in the installer, and they are selected by default.


On the bright side, overclocking my ultimate x1950pro even 1 mhz no longer results in a constantly flickering screen (Vista 64 Premium). This is a welcomed fix.


Unfortunately, driver still has issues causing seemingly random BSOD under some 3d games. :( 
June 1, 2007 6:47:38 PM

Quote:
It has options for installing Steam and an Earthsim program imbedded in the installer, and they are selected by default.


On the bright side, overclocking my ultimate x1950pro even 1 mhz no longer results in a constantly flickering screen (Vista 64 Premium). This is a welcomed fix.


Unfortunately, driver still has issues causing seemingly random BSOD under some 3d games. :( 


Do you have problems with that card with Vista only or with XP as well?
June 1, 2007 8:56:46 PM

I haven't had the time to install XP on the machine to test it out, and as it really seems to only Blue Screen with WoW, it's not a huge deal at the moment.

It may actually be a WoW issue, as I have not experienced any major crashes with any other game. Unfortunately, it is not entirely reproducable as it can run hours with no problems, and the next day playing in the same areas will cause immediate (~ < 5min) crashes.

Hopefully I'll get a day soon to test XP. Slight chance my PSU could be the cause of the different errors, though I had hoped the Silverstone ST60F would be adequate :( 
June 2, 2007 5:35:49 PM

Got x1950pro pcie and it is going fine with the 7.5

Gain some (light) overclocking for mem.
(Was impossible before)

I also use avivo conversion util. it is more stable now.

Had frequent crash before when converting video.
June 3, 2007 2:15:39 PM

I upgraded from 7.4 and it has made a nice improvment for my system. First problem i found is the colour settings got reset, had to change to multimedia preset colours to get it back to a nice contrast.

Next problem for Xfire rigs is i found if you adjust the brightness is CCC it only does it for one card, causing a flicker to occur when each card renders a new frame as the old and new brightness settings flicker. After setting it to multimedia defaults it reset.

Performance seems good and playing games is stable, not had 1 crash yet. Performance in Xfire has jumped up to almost the best performance i have had since i moved to vista, so xfire wise it is a big improvment.
June 3, 2007 6:03:33 PM

7.5 working fine on the laptop with extensive Oblivion play (about 5-6 hrs), and did some FartCry and UT2K4 gameplay for ya, stable in all three.

Nothing new/different for me, although it's the first time that updating the drivers without uninstall resulted in me losing all my CCC presets (like enabling geometry instancing, HQ AF, manual monitor detection, etc), that was a bit annoying (geometry instancing is noticeable on FartCry when you have every other setting just dialed in).

So I would suggest everyone double check their setting in the Control Centre.
June 3, 2007 10:08:55 PM

Quote:
UT2K4 gameplay for ya


whats ur in game name :p 
June 3, 2007 10:46:44 PM

I installed them 7.5 and when i tried to set res to 1440x900 the monitor went black and reported 20Hz and was way out of sync to display. did they remove support for 1440X900. Vista Ultimate 32 running 7.3 without any problems.




X1900xt x2 Crossfire
4gb corsair ddr 400-oc450
4000+ oc 2700Mhz
WD 150 Raptor x x2 raid 0
June 3, 2007 11:01:41 PM

I'm waiting for XG WarCat drivers to come out. I'm a fan of modded drivers, Omega's used to be my favorite but they haven't been updated since 7.1. I'm currently using XG WarCat 7.4 with ATI Tray Tools. I never use CCC, I prefer to overclock and change settings with Tray Tools, way less resource-intensive.

Supposedly the 7.5 edition of WarCat drivers are going to be almost complete rewrites, they're expecting big things from this set. I'll probably try 7.5 later this week, but I'm happy with my modded 7.4 set.
June 5, 2007 4:38:41 AM

Woohooo it comes with Half Life 2: Lost Coast !!!

They also fixed the problem I've had in overdrive with the screen flashing green when I overclock. About time.
June 10, 2007 2:30:37 PM

It fixed my BF2 problem. Of course, I was using an old driver that came with the card. Heh.
!