Sign in with
Sign up | Sign in
Your question

Wierd network throughput issue

Last response: in Networking
Share
October 4, 2007 3:14:07 AM

I have a very strang network related issue and am looking for help.
I have an HP DC7700 small form factor PC, brand new. It's a Core 2 duo 2.13, 1 gig DDR2.

The problem is...
Anytime you try to do any network tasks that require much throughput, it stops responding. You can still ping the gwy and even other internet addresses with 0 packet loss but just can't transfer any data. I can't join it to a domain. I can't download any file from any website more than a few kb. When navigating web pages, sometime you have to stop and re-click things several times to get any response.

My diagnostics...
I first thought the issue was my router so I tried this PC in a different building, different network with same issue.
Second thought, the onboard Intel Gigabit nic. So I added a Realtek GB NIC with the same exact issue.
Maybe it's the OS. I re-imaged the PC with an older image that is tried and true on hundreds of other PCs. Same.
I thought maybe it was the bios so I reflashed it and reset to factory defaults. I changed the NIC settings to 10/half dupluex. I adjusted MTU settings. I OBVIOUSLY used different patch cables. Everything that I can think of has been replaced except the motherboard, CPU, RAM and hard drive. I can't imagine it's the hard drive so we can rule that out. The only thing left is the MB, CPU or RAM. Anybody seen this or have any idea what I can do now? Is is possibe for the MB, CPU or RAM to cause a wierd issue like this? Keep in mind that I haven't seen any other wierdness or issues on this computer. No problems imaging it, booting up or copying files from USB drives.
October 5, 2007 1:41:06 AM

My roommate had a similar problem to this burn a memtest86 disk and check your ram. When your straining your computer with networking tasks your using more ram and when your computer hits the corrupt area of the ram it locks up. I wouldn't say it's the motherboard since the odds of the pci and onboard on different pathways causing the same issue seems slim. Could be CPU but I doubt it.
October 5, 2007 8:03:05 PM

I swapped the RAM with another identical PC that works properly. This didn't fix it. So far I've swapped...
NIC
Hard Drive
Operating System (fresh image known to work)
RAM
Many Cables
Different entire networks, switch, router, etc.
Related resources
October 5, 2007 8:44:13 PM

Run memtest86 anyway might be memory controller reading ram. But looks to me like you've got a bad motherboard. You tried diff pci slots for the network card right. I'm just trying to find a common link since on board and pci network cards should not even use the same lanes. Run a cpu burn test and see if you can repeat it under load without networking. Also try disabling the other onboard lan in device manager or bios if possible. Try loading up live linux cd too like ubuntu or knoppix. Sometimes drive images have drivers in them that conflict and have weird issues (this is invalid if you have seen your exact comp running fine with image). If you get linux to crash than that completely rules out software. Sorry if this is just guessing but motherboards are a pain and you only buy a new one once you have ruled out everything.
October 8, 2007 6:57:24 PM

I figured it out. It was the onboard LAN on the motherboard. I noticed this time that when I tried downloading something using the onboard Intel LAN that it eventually stopped responding and all other computers on that switch also lost connection. I had to unplug the defective computer and reboot the switch. Once the switch was working again, I installed a PCI NIC and tested again with the onboard LAN disabled in the BIOS. Now, it's all good. I guess the freaky LAN controller was locking up my switch and causing the other test cards I was using to fail also.
October 8, 2007 8:20:36 PM

don't worry it's not easy to figure out it took LAX airport entire IT department 4 hours to find the network adapter that took out there network. I just had a feeling that both the onboard lan and pci slot wouldn't both fail without some sort of software problem or ram since they are separate systems.
!