Sign in with
Sign up | Sign in
Your question

Limited or No Connectivity

Last response: in Wireless Networking
Share
January 11, 2008 4:06:18 PM

Hello,

This seems to be a common problem when I Google it, but I have been unable to resolve it.

I recently purchased a Trendnet N Wireless router and a Trendnet N USB adapter for my PC. I connect just fine through my Comcast cable modem if I use an ethernet cable and I can connect to the Wireless router when I enter the password through an IPhone, but when I attempt to connect through the wireless adapter's, it says "Limited or No Connectivity" an there is no signal.

I can see the wireless signal is very strong and it allows me to attempt to connect and accepts the password, but then it brings up the warning of limited or no connectivity.

Any idea what would cause this? I've looked through the first 9 pages of the forum, tried using the search, and read the FAQ's, but have been unable to find anything.

Also, can most Apple Laptops connect to wireless routers?

More about : limited connectivity

January 11, 2008 7:43:07 PM

In my experience "limited or no connectivity" normally means Windows has not successfully negotiated encryption with the access point or wireless router. Another symptom will be that there'll be no IP address set to the wireless interface, you can check this by running "ipconfig /all" on the command line. If the IP address is blank or 0.0.0.0 then the interface has no IP.

Failed encryption negotiation is usually down to incorrect password or incorrect encryption type. If you are using Windows XP go to Control Panel -> Network Connections. Right click your wireless device and select Properties. Click the Wireless Networks tab and delete the connection profile for your network. Now click View Wireless Networks, click on your wireless network, say Connect and enter your password here, this will let Windows decide what encryption type to use.

If it still doesn't work, if your wireless password has non alpha-numeric characters in try typing it into notepad and making sure it appears correctly. I've seen incorrectly configured keyboards cause problem because of wrong characters appearing e.g. backslash appearing when you press the hash key.

If it still doesn't work do you have any third party wireless network management software on the PC either from Trendnet or other vendors? If so delete it and fall back to the Windows built-in wireless tools.

And Apple computers can connect to wireless networks the same as PCs AFAIK. One of my friends had an iMac with wireless.
January 14, 2008 11:22:55 PM

I am trying to get two computers to connect via wireless. When I run ipconfig /all from the command prompt on the computer using the Trendnet USB adapter it says:

Windows IP Configuration:

Host Name ....................... : Computer name
Primary Dns suffix ............. :
Node Type ....................... : Broadcast
IP Routing Enabled ............. : No
WINS Proxy Enabled ........... : No

Ethernet adapter Local Area Connection:

Media state ...................... : Media disconnected
Description ....................... : NVIDIA nForce Networking Controller
Physical Address ................ : 00-11-09-62-2A-D4

Ethernet adapter Wireless Network Connection 4:

Media State ..................... : Disconnected
Description ...................... : TRENDnet TEW-6240B 300Mbps Wireless N USB 2.0 Adapter #3
Physical Address ............... : 00-14-D1-39-70-51


On this computer I can see the wireless network on available networks, but am unable to connect. Sometimes when I have connected it will say "Limited or No Connectivity".

I was able to connect to the router and successfully browse the internet using a laptop with an Intrino chip, but am still having trouble with the desktops and an iMac.

I did all of your other suggestions, but those didn't make any difference. It looks like it may have the first problem you listed about Windows not successfully negotiating encryption with the wireless router. What should I do to help it negotiate?
Related resources
January 15, 2008 7:45:18 AM

These desktops that won't connect, what version of Windows (or Linux) are they running? If they are running Windows XP are they updated to Service Pack 2?
January 15, 2008 11:06:00 PM

Yep, they are both running Win XP and are updated through SP2.

Update:

I got the computer that is using a non-Trendnet adapter to connect finally. I went in and manually set an IP Address instead of allowing the router to assign them and that got rid of the "limited or no connectivity" message.

On the computer that has the Trendnet USB adapter I have been able to get the adapter itself to recognize the signal and connect, but there seems to be some kind of conflict between the adapter and Windows. After I connect the adapter through software that was provided with it, I go into Windows -> View All Networks -> Connect to my network, and it attempts to connect to the router. It tries to connect for about 30 seconds and then clears out the networks and says that I should try to reconnect and that there aren't any wireless networks in range (I moved the PC so it is about 5 feet from the router and the adapter picks up an excellent signal until I try to connect).
January 15, 2008 11:40:43 PM

So I downloaded a newer version of the driver for the TRENDnet USB adapter, uninstalled the old driver, installed the new driver... It asked me to reboot, so I did. Now it won't allow windows to load. Whenever I start the computer it just loops. It will load the "Windows" loading screen and then it shuts off and restarts. It won't allow me to start in any of the safe modes or the option to start at the last configuration that worked.

Any ideas what would cause this?
January 16, 2008 7:18:32 AM

I think you should boot into safe mode and uninstall the new driver. If Windows can boot again after this I suggest you take both the router and USB adapter back to the shop you bought it from as they seem to me to be total rubbish.

If manually setting the IP in a Windows machine allows it to connect fully then this points to a problem with DHCP on the router. Check to see if DHCP is enabled on the router, if it isn't then enable it, if it is enabled then the router is faulty and should definitely be taken back.

Personally at this point I'd just take them both back anyway and replace them with a different brand product, but maybe you have more patience than me.
January 16, 2008 8:44:39 PM

I booted into repair mode using the windows CD at the recommendation of a friend and ran chkdsk /r and that repaired some kind of registry error. Windows booted up successfully and the adapter was able to finally link up with Windows and everything is working.

I don't know if it was the registry error that was causing it not to work originally or if it was updating the driver that fixed the problem, but I'm happy it is finally working. Thanks for the help!
!