Sign in with
Sign up | Sign in
Your question

2nd IDE Hard Drive - Cannot boot

Last response: in Storage
Share
June 4, 2007 8:59:10 AM

I currently have a 120GB Maxtor IDE H/D installed, but as i am rapidly running out of space i wanted another for storage.

I bought a Hitachi 80GB IDE H/D, I set the jumpers (Slave) and connected the cables, and booted.

The bios recognised the hard drive, everything looked correct. However, when i went to boot, it went through some procedures and eventually came up with the error..

Boot Failure, Insert System Disk (Something along those lines).

I always thought installing a second hard drive was an easy process, just set the jumpers and plug it in. I dont understand why it is not working.

Any help is appreciated.
June 4, 2007 9:41:54 AM

Did the BIOS show BOTH drives? With 80 wire cable, set both drives to CS (Cable Select), System drive on end of cable, 80Gb on middle connector. Check Boot order includes master/drive0.

Mike.
June 4, 2007 10:52:34 PM

Check the boot sequence in your BIOS, it sounds like the machine is looking at the wrong hdd when booting. Usual boot sequence is Floppy, the hdd the OS is on, and the DVD/CD Drive. The data hdd shouldn't even be included in the boot sequence. I was helping a friend yesterday with a Dell and had to go into the BIOS and "turn on" both hdds when there were to and "turn off" one when only one hdd was corrected but this was a Dell and had never run into this before.
Related resources
June 8, 2007 4:37:58 PM

Hey, Thanks for the help but no luck im afraid. I have tried setting both jumpers so both hard drives are on Cable Select. The system drive is on the end cable, and Additional drive on the mid cable.

I have an epox 9npa+ motherboard, which allows me to set both the boot order (Hard Drive / CD Drive / Floppy)

And also allows me to set the boot order for the Hard Drive Itself...
So, Master Drive, Then Slave Drive, Then removable NvidDrive.

When both Hard drives are in, the welcome screen takes alot longer to disapear, however it does recognise both drives, In the bios everything looks fine, it recognises the size and everything.

When it goes to boot. It just holds at one spot...before eventually saying Boot from CD:

Nothing happens for about 45 Seconds, until it says:

Nvidia boot agent ....

Client mac address etc etc

PXE-E53 No Boot filename received
Exiting NVIDIA Boot Agent

Disk Boot Failure, Inset System disk and press enter

Any ideas is appreciated. Im really stumped.
a b G Storage
June 8, 2007 5:11:37 PM

Try setting them to master and slave. Master will be the boot drive, slave will be the new drive. Master drive will be on the end and the slave drive on the middle connector..

If that fails remove the new drive and see if windows will boot normal.
June 8, 2007 5:16:35 PM

Quote:
Try setting them to master and slave. Master will be the boot drive, slave will be the new drive. Master drive will be on the end and the slave drive on the middle connector..

If that fails remove the new drive and see if windows will boot normal.


It is already set up like that (Set jumpers back to master/slave instead of cable select).

It boots without any problems when the drive is disconnected. However it will not boot when the drive is connected.
a b G Storage
June 8, 2007 5:26:15 PM

can you plug the new drive onto the cd rom cable to see if it works there? Try a different cable.

Double check the boot order in the bios. I have seen some bios that allow you to select a specific drive to boot from, just not the primary master drive.
June 8, 2007 5:52:45 PM

Okay, I plugged the Hard drive into the CD Rom cable (Middle connector) and it recognised it as Channel 1 - Slave.

Now, It did actually boot...finally! Even though it took an extremly long time to boot.

When the system loaded, I went into computer management and formattted the hard drive and its now recognised as Drive D:....

What does this mean though, Why does it work on my CD Rom cable, but no t on my Hard drive cable..?
a b G Storage
June 8, 2007 6:14:39 PM

Do a restart and see if the boot time is still slow.

Try a new cable on the primary hard drive and reattach the new drive to it and see if things change.
June 8, 2007 6:34:06 PM

Well, i really dont get it.

I swapped over the IDE Cables. So the cable that the hard drive was working on (CD Rom cable) was the one being used for both hard drives....It didnt work.

I dont understand why, I've reconnected it so the hard drive is on the same cable as the CD-ROM (Currently disconnected as the cable is not long enough for both hard drive, and cd-rom to be connected at the same time.)

It still takes as long to boot when the 2nd hard drive is connected.
June 8, 2007 6:42:52 PM

Check the jumpers on the Maxtor, WDs have seperate setting for Master with Slave present, Maxtor may be the same.

Mike
June 8, 2007 6:44:16 PM

Check the jumpers on the Maxtor, WDs have seperate setting for Master with Slave present, Maxtor may be the same.

Mike
June 8, 2007 6:54:25 PM

Im pretty sure the jumpers are set correctly, i dont see how they wouldn't be when the do provide a diagram to help too :) 
June 8, 2007 8:48:56 PM

If you have to ATA connections on your mobo, make sure your hdd is connected to the front one, the one closest to the edge of the board and the CD is connected to the one behind it
June 8, 2007 9:19:13 PM

I thought the outside one (Closest to the edge) should have the CD Drive because...

The inside one is IDE Channel 0 Master/Slave Which i had my hard drive plugged into.
The outside is IDE Channel 1 Master/Slave which i had the CD Drive plugged into.

At the moment the only way the hard drive is working is by having it on the CD-Rom ATA cable.

Is there any concequences of running the master hard drive on one cable. And the Slave hard drive/Master CD-Rom drive on the other cable.

The boot times are extremly long when the other hard drive is plugged in. But i can live with that and move around my cd-rom drive so that the cable can reach if i know if will work properly, without any concequences.

Cheers.
June 8, 2007 11:20:32 PM

If you have only 2 ATA drives, a hdd and a CD drive, then use a separate cable for each, they should both be set to Cable Select though it's possible they should be set to Master but try Calbe Select first. You can check your mobo manual but I'm pretty sure that the hdd should be connected to he first one and the CD to the 2nd, I think the CD connector is blue. Once you have them on separate cables there will be no Slave unless there is an addition drive on the cable. It's the cable that determines if you have Master Slave not where they're connected on the board
a b G Storage
June 9, 2007 1:24:45 PM

As a test do you have any other computers that you can test the new hard drive on? Its possible the drive is bad and the bios is just taking a long time to see it.
Have you formated the drive yet/used it?

Having hard drives on seperate cables wont hurt anything at all. In fact any transfers from one drive to the other will be a little faster since they are on seprate channels.
!