Sign in with
Sign up | Sign in
Your question
Closed

Need help with every game unexplainably crashing

Last response: in Windows Vista
Share
September 7, 2009 5:05:08 AM

I've been having a problem recently with my machine. Before I begin the long story, heres the specs:

Windows Vista Ultimate x64
i7 920 @ 4ghz
6gb corsair dominator ddr3 1600
evga x58 3xSLI
three gtx 260/c.216 in 3xSLI
silverstone decathlon 1000w psu
80gb intel x25-m system drive
1tb caviar black storage drive



Here is my very frustrating problem:
I have had this system since the beginning of January this year. It has run like a champ, doing everything and playing all games at the highest settings on my LG w3000h 30" monitor. Recently though, everything relating to games has broken down. I will go into detail in a moment. I will note beforehand that every game has at one point worked perfectly fine, for months each.

All my problems started a few weeks ago when COD4 just didn't open up. On launch of the game it would start up but at the first black screen it would give the error message "iw3mp.exe has encountered a problem and needs to close. windows is searching for a solution." Using event manager under administrative tools I discovered that it was the actual exe file that was the faulting module. I tried everything that anyone has said to fix the problem, thinking that it was just COD4 that was broken. I enabled Stereo mix, I had a usb headset microphone in and working but also tried the rear microphone jack trick, tried renaming the miles audio file to a .bak, manually updating punkbuster, tried replacing the exe from my install DVD, tried reinstalling the entire game and repatching, tried every trick you can think of, nothing worked.

So then I decided to try COD WaW instead, but it didnt start up - same error. I thought it might just be the code because COD WaW is based off the COD4 engine. So I try Far Cry 2, which also had been working for months. It flashed up the splash screen but immediately crashed to desktop, no error message. I tried to troubleshoot that one but came up with nothing. Then I tried Bioshock, but just after the splash screen it crashed with an error message like the call of duty games. Finally I tried Crysis, and this game worked. I have no idea even now why this still works.

Very frustrated with this all, I updated my DirectX from microsoft, and after that completed succesfully, tried everything again, no luck. I then updated all my sound device drivers (integrated realtek and my creative usb headset firmware and drivers) and still no luck. I updated the bios on the evga x58 motherboard, no luck. New intel X58 chipset drivers, no luck. New realtek gigabit ethernet network chip drivers, nothing.

At this point I thought that Nvidia had screwed me over with driver installs getting botched (the most recent 190.62 driver) so I got Guru3d's driver sweeper, booted into safe mode, uninstalled, swept, and reinstalled 190.62, still no luck. Retried but installed the older 190.38 (note that these were all the whql certified drivers, not betas), but still no luck.

This got to the point where I just decided to do a system restore to a restore point that had been made 11 days ago (august 25th) in hopes that it would save me. It didn't.

I then decided to use Acronis True Image to restore both my system drive and storage drive to an image I had made a very long time ago (july 25th). I figured that nuking every bit on the drives with an image that I knew worked (there were no problems back then) would be about as final as it got. As soon as I got it up and running again (the drivers in use back then was the stable forceware 186.18), I tried COD4 and low and behold it worked. I then proceeded to install Far Cry 2 and Bioshock because I didn't have them installed two months ago when the image was made. I managed to open up both of these games as well! Then when I went to open up COD4, Far Cry 2, and Bioshock for the second time, they all reverted to their previous states of crashing on startup. This made me think that there was something else at play here, because I had just put everything back two months and the crashing had not actually occurred two months ago.

Because of this strange behavior I decided to check throughly for any viruses or malware. I did a through scan with Avast antivirus, found nothing, and then used Malwarebytes' anti-malware scanner to scan again. Malwarebytes found two registry items infected, one was a "hijack start menu" and the other a "hijack display properties", whatever those may be. I quarantined those and then proceeded to uninstall, sweep, and reinstall the nvidia drivers (I used 190.38). At this point I tried the games again, but nothing worked.

I have no idea what to do next. I have tried everything that I have thought of, and done what my friends who also know their way around computers suggested. I thought for sure that the "hijack display properties" infected registry entries was the problem, but it was not. If you have any ideas, please post them.

It should also be noted that everything works perfectly fine but games. The problem is not an overclocking or hardware failure, but a software failure (no hard lockups or bsods). Please don't send me to check the minimum system requirements for the games, because my computer has and will rip through these games like butter, if they would run.



Thank you so much in advance for any advice you can offer, I really don't know what to do next.

Best solution

September 7, 2009 5:18:03 AM
Share

Of course the last and ulötimate solution is to backup all your personal data and game saves and simply do a hard drive formating and clean install of your OS. 2-3 days of hard work (weekend) of copying and reinstalling programs and you should be able to play games again.

But let's hope somebody else has a better solution that does not include an OS clean install.
September 7, 2009 2:02:09 PM

What was the error on the COD game in the event viewer? The error its self may help clue in to the problem.
Related resources
September 7, 2009 10:06:31 PM

Here are the event viewer error logs

for COD4:
Faulting application iw3mp.exe, version 0.0.0.0, time stamp 0x4859a219, faulting module iw3mp.exe, version 0.0.0.0, time stamp 0x4859a219, exception code 0xc0000005, fault offset 0x0c6e4c25, process id 0x4ac, application start time 0x01ca3006706b5fc7.


for COD WaW:
Faulting application CoDWaWmp.exe, version 1.5.1220.0, time stamp 0x4a5241f6, faulting module CoDWaWmp.exe, version 1.5.1220.0, time stamp 0x4a5241f6, exception code 0xc0000096, fault offset 0x00dc605c, process id 0x1564, application start time 0x01ca3006ccd7b62f.

and it also hung after crashing:
The program CoDWaWmp.exe version 1.5.1220.0 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Problem Reports and Solutions control panel. Process ID: 1564 Start Time: 01ca3006ccd7b62f Termination Time: 317


for Bioshock:
Faulting application Bioshock.exe, version 1.0.0.0, time stamp 0x474f12d3, faulting module unknown, version 0.0.0.0, time stamp 0x00000000, exception code 0xc0000005, fault offset 0x571b4eb0, process id 0x17c8, application start time 0x01ca3006fa575a56.


Far Cry 2 does not display a windows error message when it crashes to desktop on startup, so there is nothing in the event viewer.

It should also be noted that Crysis, Crysis Warhead, and Crysis Wars still run, no crashes, no hangups.
September 8, 2009 6:06:16 PM

Perhaps you should try swapping out your memory, do you have any extra you can try?
September 9, 2009 3:15:59 AM

I do in fact, though it's unlikely that it is the problem. I tried each module individually and nothing changed, and all of the other programs work fine.

But because I have nothing to work off of, I'll try. I have a 3GB DDR3 1066 kit taken from a newer Bloomfield Mac Pro and will try that out when I have the chance.
September 13, 2009 5:57:55 AM

Popped in the other ram sticks, booted up fine, everything works great but the games still crash. Not the memory.

In addition I also tried GTA4, which I hadn't tried before. It crashed to desktop just like everything else did. Checking event viewer didn't do any good though. There was no error message but a warning did pop up that had to do with xlive.dll, which I think has to do with Games for Windows - Live.

At this rate, if nobody has any idea what's going on, I think I'll have no other option but to start backing up what I care about, and then do a complete format of my hard drive and a deep format of my SSD as well (from a dos usb floppy), followed by reinstalling everything.
September 18, 2009 4:26:31 AM

I gave up and did a secure erase of everything. Both hard drives and the ssd, probably good for my ssd, might speed it up a bit.
Will be reinstalling vista ultimate x64 and trying again. wish me luck for prolonged months without problems.
January 31, 2010 2:39:34 PM

I know that this thread is marked solved and that the last post on this was months ago, I'm just wondering how things have been since then.

I have been having the exact same problem as you. I played COD4 the most and for a year the game ran perfect, then all of a sudden the crashing started... same error as yours. The thing is, this all started for me a couple months ago which was about 6 months after I had done a clean OS install and wiped everything and started fresh... naturally I'm skeptical that this is the only solution, but, as you, I've tried all the other fixes from plugging the mic into the headphone jack (seriously? lol), to updating, renaming the .bak file, enabling stereo mix, reinstalling the games themselves etc... and like your situation, none of the many suggestions out there has worked.

So I'm wondering, since you wiped everything and started over, how have things been running?

cheers - D
January 31, 2010 3:11:01 PM

dmb_28 said:


So I'm wondering, since you wiped everything and started over, how have things been running?



Things have been good, no big problems. Then again, I don't use my gaming machine as my primary computer, so it's only on when I am playing, so it might have something to do with usage time (vista might be just ticking down to oblivion haha). But at any rate, everything that was going wrong before is fine. I still have no idea what happened before, but every game except Crysis wasn't working for me.

Is COD4 the only one broken for you?

I'd try looking in the event viewer after the program crashes and see what it says. Specifically what was the faulting module of the program. You can get a sense of what might be wrong from there. If you're having troubles with other games then you can look for similarities (all of my previously broken games had the faulting module as the actual game executable file.

And on a side note, I don't really play COD4 anymore. Besides punkbuster kicking me every 2 minutes because of disallowed program/driver error (stupidest thing ever), I dropped it for MW2.
January 31, 2010 3:40:55 PM

Hey thanks for the reply! :) 

COD4/COD2, Flashpoint, Rainbow Vegas 6... all crash. Flashpoint hasn't worked properly since I got it either...

The event viewer always just shows:

"Faulting application iw3mp.exe, version 0.0.0.0, faulting module unknown, version 0.0.0.0, fault address 0x00000000."

Not a lot of info there other than what I already know... lol. I'm just trying to explore all the possibilities here before I do a fresh os install...it's such a desperate last resort lol.
February 6, 2010 6:18:24 AM

This topic has been closed by Mousemonkey
!