Sign in with
Sign up | Sign in
Your question

"Network cable is unplugged"

Last response: in Networking
Share
February 1, 2004 2:33:57 PM

Hi again,

The many problems I have been having with my network took a dramatic turn for the better when I flashed my router with a special build for the Scandinavian market, (this did not appear on D-Link's normal firmware site).

I still have a problem with the XP system. A little bubble keeps appearing in the system tray area saying "A network cable is unplugged", at when that is showing, my LAN connection is not working, the LAN icon has a red cross through it and the lights on the router that the machine is using are out. There are not cables out of course, and the bubble disappears without intervention, usually after just a few seconds.

The router is a DI-804V, the NIC is an SMC 1233A-TX with SMC's driver not the XP default. OS is XP Home, fully patched. Have tried swaping cables, no change, and router ports, no change.

There is a current Belarc report for the system at www.adrianxw.dk/PersonalSite/JillsPages/Foniks.html if any use.

Any ideas of things to try next?
February 3, 2004 11:23:43 PM

you get that notification when you simply have no power running through the network cable, so it's either that the power to the router is off at that point, or that the cable itself has a bad connection...try using a different network cable, and you might get a constant connection.
February 4, 2004 6:34:23 AM

The power to the router is on on these occassions. The other lights on the router including those to the other machine are on, it it the lights on the port I have the XP system connected to that go out. I have obviously tried moving the XP system around the ports available with no joy.

Similaly the physical cable. I have swapped that with another, and even swapped it with the known good cable that the 95 system had been using. The XP still complains, the 95 runs fine with the other cable.

It will run fine for a few days, then start playing up until the bubble is almost permenantly there.

Incidently, The motherboard has an onboard NIC. To eliminate that as the problem, I bought a new NIC, disabled the onboard in the BIOS and run the new NIC with an updated driver. Exactly the same.

Weird huh?
Related resources
February 9, 2004 8:59:34 PM

Try forcing the link and duplex settings. Open the settings and click on 'Configure' for the network card not the tcp protocol. From there you'll have to search for the setting since it is driver specific and I do not have one of those cards. Basically you are looking to change the setting of Auto or Hardware default to 100MB full duplex. If that doesn't work try moving down in speed and duplex.
February 11, 2004 2:24:44 PM

Hi,

Currently, the machine is behaving, but I found the setting and changed it as suggested. Leave it like that and see.

Thanks for the tip.
February 13, 2004 3:13:39 PM

Okay, so it started playing up again. I found the place and changed to 100 FD but the problem persisted, so I have now set it down to 10 FD.

This preumably means that whilst the internet connection will be unaffected, file transfers etc. between my machines will now be several times longer in execution. Is this a test, or a proposed long term solution?
February 15, 2004 2:20:28 PM

Still getting the message at 10M FD.
February 17, 2004 8:06:01 PM

Make sure that you are on the same network as the router. Check to see that you are getting an address automatically in the TCP/IP properties of your NIC, or that you are on the same network as the router if you are using static.

Dev

---
My new years resolution is 1280 x 1024
February 17, 2004 8:25:29 PM

you say you have swapped out the cable. are you SURE the cable is not damaged in anyway? maybe you put too much tension on it when you hook it up to the other comp? your problem really sounds like a cable problem. maybe some kind of interference? do you have the cable wrapped around or simply laying on a power cable?

wpdclan.com cs game server - 69.12.5.119:27015
now featuring (optional) cheating death!
February 17, 2004 8:52:35 PM

The router is the networks DHCP server. At restart, the Windows 95 machine gets a dynamic address, although realistically, it allways gets the same one, as the router is configured to give the XP machine the same fixed address everytime which is much higher.

I know the XP machine is getting the correct address, (at least I think I do!), because the router also has a port open against that fixed IP address, and the http server the XP machine runs, seems to be working fine. If it was not getting the address from the router, I wouldn't expect it to be right, by chance, everytime.

Is this what you mean? Sorry, I'm not completely sure I understood what you were suggesting.
February 17, 2004 8:55:21 PM

When I was last fiddling with the cables, I think I left it suach that the 95 machine is using the cable that the XP box had originally, and the XP box has either the 95's old cable, or a spare cable that I had from another NIC.

The problem does not seem to move with the cables or the router ports, it was one of the first things I tried as "cable unplugged" suggested that.

:( 
February 19, 2004 12:13:13 AM

hmm... I get this problem too. Linksys BEFSX41 and Linksys NIC, windows XP. Seems to happen if I'm using P2P software or am downloading a big file for more than 50mins (though could happen anytime randomly before this).

I have no idea why and would like to find a solution as well. Are you doing anything similar when you get the message?
February 19, 2004 6:55:09 AM

I don't have any p2p software. What I'm doing at the time varies. I tend to notice it the most when I am using a chat client, but that could easily be because I notice it as my attention is on that screen.

Frequently, I'll be doing nothing at all, using the other machine, (which I prefer). I'll see the bubble popping up and down out of the corner of my eye. When it happens, I notice the MSN icon flickers around for a few seconds as well, (I've tried to get rid out that MSN thing as I don't use/want it - but it always tells me it is "in use", despite the fact I have it disabled).

I've had a packet sniffer running but it shows nothing leading up to an event, just a load of, presumably, recovery activity when the bubble goes.

It does so look hardware, but I can't see what. I do not believe it is the cable as I've switched them around, the same with router ports. I added a NIC to the machine and disabled the on-board in the BIOS in case it was that, but the new NIC, (which is identical to the NIC in the working machine), has made no difference.
February 22, 2004 6:09:55 PM

OK, I'm using a Linksys router and you said you were using a D-link one but maybe it's a similar sort of issue???

I think I've solved my problem. After loads of searching on google, I stumbled across this thread;

http://www.broadbandreports.com/forum/remark,8300136~ro...

turns out it's a problem with the latest (and all except the betas) firmware of my router. I kept my advaned firewall connetion on, but allowed proxy, java, active-x and cookies.

Now it all seems to work fine. Maybe there's also a bug in the D-link firmware?

-does your router reset when you get the cable unplugged message?
-have a search around and let us know how you get on!
March 2, 2004 6:46:54 PM

I've spoken to D-Limk in Denmark. The website shows a software release which I had originally, and didn't work. The local office gave me the current software I am using, and have assured me this is the most up to date for use in the country.

The router does not reset when the bubble appears, the other machine on the network is running fine the whole time, if I was getting resets, I would, by now, have noticed some correlation between the bubble events and some performance glitch on the other system. This is not the case.

I've searched and searched and searched! It was only a call to D-Link Denmark that enabled me to find this software release, I've not found it mentioned on the web.

I still have a few other problems with this machine even without the bubble. A page that routinely loads perfectly on the 95 machine with IE5 will often "miss" some of the graphics on the XP, (get the red X), right click and "show Picture" and in they come.

I don't know, I really don't.
March 2, 2004 9:21:25 PM

It might be a power management issue with the XP computer in that to save power XP turns the NIC off. This would be the point the network cable error message appears, the router then polls the NIC to see if it is present and so the NC wakes up again thus reconnects the network.
To turn of the power management press win-key and pause break at the same time. This should bring up system properties. Then go to Hardware, Device management, network adaptors, choose the NIC you are using, power management and take the tick out the top box. Try it like that for a bit and see if it fixes it. Don’t worry about using extra power as I would be doubtful as to whether this makes any difference to the power consumption of the computer.

Good Luck

'.'
March 3, 2004 6:15:53 AM

Thanks for the suggestion SN, but I'd already thought of that, I've been running without that check for some months, I'm not sure it ever made any difference.

Right now it is back in traditional mode, it runs seemingly without incident, (apart from missing the odd .gif or .jpg), for days on end, then for some reason starts popping up the bubble. The bubble never seems to appear just once. After it has been there, it will pop up and down sometimes several times a minute for days, then just as suddenly, stops.

I've considered many weird and wonderful scenarios, but I just can't correlate the onset or cessation of the events with anything. It is irregular, happens during busy periods and slack, warm weather and cold, bright sunshine and overcast, Venus above the horizon and below...etc.!!!
March 5, 2004 8:49:34 PM

i kinda didn't read through all those long posts but did you run a Line Tester through your cat5 cable to see if the cable is good? defective rj45 jack or whatnot might of gotta messed up from pulling out and in.

Just a suggestion.

Asus A7N8X Deluxe
80gb Maxtor
200gb WD 8mb cache..
Lian-Li PC-60
LiteOn 52X/LiteOn 811s DVD-RW
AMD XP2800+
LeadTek GF4Ti4200 128mb
Hitachi CML174
1GB Corsair XMS PC3200
March 6, 2004 9:44:11 AM

I've not used a tester, but much of the thread has had focus on the cables. I have 2 machines and 3 cables. Each machine has had each cable, the 95 machine works with all of them, the XP shows the fault with all of them. I do not believe the cable is the source of the problem.
March 7, 2004 6:40:24 AM

bad network card?

Asus A7N8X Deluxe
80gb Maxtor
200gb WD 8mb cache..
Lian-Li PC-60
LiteOn 52X/LiteOn 811s DVD-RW
AMD XP2800+
LeadTek GF4Ti4200 128mb
Hitachi CML174
1GB Corsair XMS PC3200
March 7, 2004 6:42:37 AM

i don't know if this makes sense but are you using a ROUTER? if yes..... go to your router config and add another DHCP USER. problem happened to me a few times.

if that's not the case, try to make your WORKGROUP the same and uninstall tcp/ip and then reInstall it again...

hope one of those helps ya

Asus A7N8X Deluxe
80gb Maxtor
200gb WD 8mb cache..
Lian-Li PC-60
LiteOn 52X/LiteOn 811s DVD-RW
AMD XP2800+
LeadTek GF4Ti4200 128mb
Hitachi CML174
1GB Corsair XMS PC3200
March 7, 2004 7:00:06 AM

As I said earlier, my motherboard has an onboard NIC which I was using until the summer. To eliminate that as a possible source of problem, I disabled it in the BIOS and added a new NIC, identical to the working one in the 95 machine, it made no difference. I do not believe the card to be the source of the problem.
March 7, 2004 4:13:05 PM

was that for me? Cause i didn't say anything about the network card. Usually when you add more users on your network or something and the router doesn't pick it up you have to manually go in and add another DHCP user.

Also like i said above sometimes windows gets all weird you have to uninstall and then reinstall your TCP/IP

Asus A7N8X Deluxe
80gb Maxtor
200gb WD 8mb cache..
Lian-Li PC-60
LiteOn 52X/LiteOn 811s DVD-RW
AMD XP2800+
LeadTek GF4Ti4200 128mb
Hitachi CML174
1GB Corsair XMS PC3200
March 9, 2004 7:54:40 AM

Yes, I can see that will get rid of the bubble, which is annoying. I would rather know though! I want to fix the problem, not just clear the symptom!!!

Actually, I have news! I egt the odd BSOD on this machine, mostly with a stop code of 50 or 77, implication device driver problem.

Last night I had a D1 BSOD, DRIVER_IRQL_NOT_LESS_OR EQUAL. Interestingly, the culprit was identified, it was tcpip.sys. I'm sure that is relevent, possibly even relevationary, but sadly not to me, not yet anyway.

Thanks Capn!

<P ID="edit"><FONT SIZE=-1><EM>Edited by Jill on 03/09/04 05:48 AM.</EM></FONT></P>
!