Sign in with
Sign up | Sign in
Your question

Remote desktop connection failure

Last response: in Applications
Share
June 14, 2010 3:59:35 PM

Hello. Sorry I am new to the forum and cannot find my original message that I had a reply on. I am running Windows XP Home edition and trying to connect to my Remote desktop server windows 2003. Out of the blue it quit working. I have tried everything everyone has asked me to do. The port is correct, the users are listed, etc. I can ping to the computer. Everything. I have even deleted updated from my xp to see if it was that being a connection problem and nothing happened. I am stumped as to what it is. I even got a new modem/router and still nothing.
What is a last resort to try. I thought it was my xp , but I think now it is the server?

Any suggestions
a b L Programming
June 14, 2010 9:21:07 PM

What port are you currently using out of curiosity?

are the computers on the same network, or are you trying to connect over the internet? Is the firewall set up to allow connections on the given port? Are you trying to use an ip address or netbios name?

Is the computer you are trying to remote into set up to allow connections (in control panel > system > remote settings)?


These will help to further troubleshoot your problem.

m
0
l
June 15, 2010 3:12:57 PM

PORT 3389
Connecting over the internet
firewall is set up to allow this connection
using an Ip address static ip. I am wondering if that is the problem. ATT DSL says it is fine, but I am not sure. THey could not find my account but yet could see my router/modem. Strange.

Yes my server 2003 computer is set up to accept , Just checked again this morning.

m
0
l
Related resources
a b L Programming
June 15, 2010 8:17:01 PM

First, if you can, i would try remoting into the server from the local network to see if that works. This should tell you if it is a networking problem (ip address, firewall, port forwarding etc.) or if the server is what is not allowing the remote desktop connection. You should use the netbios name of the server or its internal IP address (example 192.168.1.xxx) for this test, to make sure that you are not trying to go out of the firewall then come back through the firewall.

Some other things that come to mind are verifying that the RDP is still listening on the defualt 3389 port on your windows server. You can do this by:

1. Start Registry Editor.
2. Navigate to: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber
3. Insure the port number is 3389

One last thing to check is if you have the actual static IP address that ATT says you have. You can go to a website such as http://www.whatismyip.com/ to find your external ip address, and insure it matches what it should be acording to ATT.


Let me know how this goes. Good luck :) 
m
0
l
June 17, 2010 3:48:45 PM

Thanks. I did the internal ip and I can connect internally.
The port is the same at the registry editor.
I did go to the static ip look up and my static ip is what it should be.

Now I have noticed that when I go to ipconfig/all my static ip does not show up? is it supposed to?

I am now stumped. I thought it was my machines, but I remember that my software company logs in also to do upgrades and they cannot log in. So it is something with the server and the static ip I would thinkg?
m
0
l
a b L Programming
June 17, 2010 4:05:00 PM

kimfmcelhaney said:

Now I have noticed that when I go to ipconfig/all my static ip does not show up? is it supposed to?


Nope, it should only have info about the ip addressed assigned to this computer, so that is completelly normal.

If you can use remote desktop internally on the network, and you have the proper external ip address, then chances are the firewall/router is the problem. You should verify that the firewall (either on the pc or a if you have a firewall between the network and the internet) is set up to properly allow rdp connections. Also, make sure you have the port forwarding set up correctly so that incoming remote desktop ruquests get sent to the correct internal IP address and port.

Good luck! :) 
m
0
l
!